After renaming imap folder, message list is not dislayed only once.

RESOLVED FIXED in Thunderbird 52.0

Status

defect
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: mkaneda, Assigned: hiro)

Tracking

({regression})

24 Branch
Thunderbird 52.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird25?, thunderbird_esr24?)

Details

(Whiteboard: [regression:TB24][needs mozmill test])

Attachments

(1 attachment, 1 obsolete attachment)

User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.0

Steps to Reproduce:
1. Rename IMAP folder with one or more messages.
2. Click the renamed folder.

Actual Results: 
The message list is not displayed.
(After step 2, click other foler then click the renamed foler, the message list is displayed.)

Expected Results: 
The message list is displayed at step 2.
Is this occurring with bug 902370 fixed, or not fixed?
Flags: needinfo?(mkaneda)
This is caused by the fix for bug 901959.
Thanks hiro
Assignee: nobody → hiikezoe
Blocks: 901959
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Flags: needinfo?(mkaneda)
Hiro, any thoughts of a fix?
Posted patch A possible fix (obsolete) — Splinter Review
I think this patch fixes the issue but does not include test cases yet.
Posted patch FixSplinter Review
I think this patch is a correct fix but could not write any test yet.
Attachment #817071 - Attachment is obsolete: true
OS: Windows 8 → All
Hardware: x86_64 → All
do we need a test?
Status: NEW → ASSIGNED
Flags: needinfo?(mkaneda)
Whiteboard: [regression:TB24]
is test possible / do we need it?  (question was meant for hiro)
Flags: needinfo?(mkaneda) → needinfo?(hiikezoe)
I think it's possible to write an xpcshell test but it's very hard to write. Actually I tried before.
I am guessing it's easier to write a mozmill test.
Flags: needinfo?(hiikezoe)
Whiteboard: [regression:TB24] → [regression:TB24][needs mozmill test]
(unfortunately hiro is no longer with us)
Assignee: hiikezoe → nobody
Status: ASSIGNED → NEW
Whiteboard: [regression:TB24][needs mozmill test] → [regression:TB24][needs mozmill test][patchlove]
Duplicate of this bug: 1088514
has potential patch for bug 1062408, bug 1120361
Flags: needinfo?(acelists)
Do we have actually have imap fake server support in mozmill? We have one fox xpcshell, but then there is no message list (there is no UI) in xpcshell, maybe that is why Hiro says it is hard.
Assignee: nobody → hiikezoe
Flags: needinfo?(acelists)
Whiteboard: [regression:TB24][needs mozmill test][patchlove] → [regression:TB24][needs mozmill test]
Comment on attachment 824418 [details] [diff] [review]
Fix

Review of attachment 824418 [details] [diff] [review]:
-----------------------------------------------------------------

I could now reproduce this on IMAP. This patch helped in the case. The new folder contents is again displayed in the message list. But no message contents can be displayed due to errors "error clearing message pane" as described in bug 1062408.

I suggest we try landing this and continue in the other bugs.

(At check in time, please fix the commit message).
Attachment #824418 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/666da1b1fc5721d00a996c1b52d864f649fa2fd6
Status: NEW → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
Blocks: 1062408
See Also: → 1083994
You need to log in before you can comment on or make changes to this bug.