Closed Bug 1120361 Opened 6 years ago Closed 5 years ago

IMAP: after folder rename or move messages couldn't be opened anymore until new messenger window open - works in an older TB version (< 31)

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

31 Branch
x86_64
Windows 7

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1328814

People

(Reporter: spadge, Unassigned)

Details

(Keywords: regression, Whiteboard: [regression:TB30?])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

Using an IMAP mail account: rename a folder containing messages, click on another folder containing messages and TB won't open any messages.


Actual results:

TB won't open any more mails in the renamed folder or other folders.


Expected results:

Mails should be displayed properly without restarting TB.

NOTE: this works in pre 31 versions.
Severity: normal → major
Priority: -- → P2
I tried this on recent trunk and esr31, and could not reproduce. So we need to pin down the particular circumstances that might cause this.
Tried it again on 31.4 and used the following steps to reproduce: 
- created a subfolder of a folder in the inbox named "test"
- created 2 subfolder of "test" named them "testsub1" and "testsub2"

Made sure, that every "test" folder contains one email. 

Now I've renamed "testsub1" to "testsub11". Next thing I did is selecting the folder "testsub2" and then I clicked on the email contained in "testsub2" and nothing gets displayed in the message pane.

Hope you can reproduce this :)
Did you have any success reproducing this issue?
I tried the STR in comment 2 using Thunderbird 31.4.0, everything worked fine for me. So I still cannot reproduce.
Strange, I've tried in with different mail servers.
Is there something I could do to trace this (like enabling debugging, ...) so you may get a clue what went wrong?
(In reply to spadge from comment #2)
> - created a subfolder of a folder in the inbox named "test"
> - created 2 subfolder of "test" named them "testsub1" and "testsub2"

   Inbox
     Inbox/test 
         Inbox/test/testsub1 
         Inbox/test/testsub2 

> Made sure, that every "test" folder contains one email. 

How?
Copied a mail to each folder, clicked each folder at folder pane, and view the copied mail at each folder?
Or merely "Unread count=1 was shown after folder creation"?

> Now I've renamed "testsub1" to "testsub11". 

   Inbox
     Inbox/test 
         Inbox/test/testsub1 => renamed to Inbox/test/testsub11
         Inbox/test/testsub2 
   After rename testsub1 testsub11 
   Inbox
     Inbox/test 
         Inbox/test/testsub11
         Inbox/test/testsub2

> Next thing I did is selecting the folder "testsub2" 
> and then I clicked on the email contained in "testsub2" and nothing gets displayed in the message pane.

"Message list of testsub2 was shown at Thread pane correctly". Right?
Is this first your open of "testsub2" folder after you created the "testsub2"?
Or you opened testsub2/viewed mail in it, after create testsub2 before you do rename testsub1 testsub11?

What is shown by "View/Message Source"?

testt, testsub1, testsub2, testsub11, is actually used folder name by you?
Or it's merely simplified string for bug reporting?

Rename in imap is usually "rename Inbox/test/testsub1 Inbox/test/testsub11".
This is rename of lowest level testsub1.
Why can "rename of other subfolder under same parent" affect on "access to a folder under same parent folder"?
What is state of relevant folders in subscribe list?

Anyway, get imap log, and check log file content by yourself using Text Editor.
Rename is done by "rename" command, and fetch is done by "uid fetch NN ..." command, and they are placed as string in log text.
"create folder named ZZZZZZZZZZ just borore your rename" like one may be a good eye catcher in log.
See .Bug 402793 Comment #28 for getting log.
The problem persist even using the latest 31.5.0 version.

@WADA you are correct, i've created the folders as described be yourself.
I'm using the "classic view" (tree an the left, message list right top, message content right bottom).

Before renaming the folder "testsub1" to "testsub11" you have to click on an email contained in "testsub1" (so you will see the mail's content). 
After you've renamed the folder "testsub1" to "testsub11" try to open/view a mail for example of the "testsub2" folder: the mail's content is completely empty.

"Message list of testsub2 was shown at Thread pane correctly". Right?: yes

"Is this first your open of "testsub2" folder after you created the "testsub2"?
Or you opened testsub2/viewed mail in it, after create testsub2 before you do rename testsub1 testsub11?": Doesn't matter

What is shown by "View/Message Source": the correct mail source.

Why can "rename of other subfolder under same parent" affect on "access to a folder under same parent folder": probably some pointer/handler is lost/misleading (TB internal) because a mail contained in the renamed folder is not (anymore) in it's (original) location. 

I'm pretty sure, this has nothing to do with IMAP (server) itself, as it happens accross multiple commercial mail providers, including a self hosted IMAP server system.
@WADA: forgot to answer "> Made sure, that every "test" folder contains one email. 
How?": I've just moved existing (test) mails to this folders. 
But it doesn't matter, even after a TB restart, as soon as I rename a folder where a contained mail is currently opened I'll get the same error.
It will greatly help to determine the one-day regression range using nightly builds. Somewhere between
http://archive.mozilla.org/pub/mozilla.org/thunderbird/nightly/2013/06/2013-06-28-03-13-28-comm-central/
and
http://archive.mozilla.org/pub/mozilla.org/thunderbird/nightly/2014/03/2014-03-18-03-02-03-comm-central/

Using a binary search it should take no more than 10 build tests to nail it. Use a test profile, or backup your profile before testing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(spadge)
Whiteboard: [regression:TB30?]
I can reproduce this too on a new profile with Thunderbird 45.1.0 on both windows and Linux

Here's something new :
* no need to restart Thunderbird to see messages again, just change disposition (from classical to large or vertical) and messages content reappear
* Just after renaming of folders, two errors are thrown in console :

Horodatage : 26/05/2016 15:16:01
Erreur : error clearing message pane
Fichier source : resource:///modules/errUtils.js
Ligne : 34
Horodatage : 26/05/2016 15:16:01
Erreur : [Exception... "Illegal value"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://messenger/content/msgMail3PaneWindow.js :: ClearMessagePane :: line 1093"  data: no]
Fichier source : resource:///modules/errUtils.js
Ligne : 35
well, spadge doesn't answer any requests :(

Gregr, you sound like an upstanding person. Can you do what is requested in bug 1062408 comment 21 - to narrow the regression range cited in comment 9? (although that might not be accurate)
Flags: needinfo?(spadge) → needinfo?(gregory.rocher)
Depends on: 1062408
I tried to reproduce this bug.  I created two new folders, added a message to each and then renamed one of them.  I then clicked on another folder and had no problems.  Note, my imap server allows for subfolders but I can't create the subfolders in thunderbird.  I have to login to the account go to the mail directory and make a directory.  Then I can add subfolders to that directory.
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #11)
> Gregr, you sound like an upstanding person. Can you do what is requested in
> bug 1062408 comment 21 - to narrow the regression range cited in comment 9?
> (although that might not be accurate)

Hi, sorry for the delay

I think I've found a regression window : [2014-01-13, 2014-01-14]

> 2016-10-06T12:59:14: INFO : Narrowed nightly regression window from [2014-01-12, 2014-01-14] (2 days) to [2014-01-13, 2014-01-14] (1 days) (~0 steps left)
> 2016-10-06T12:59:14: INFO : The bisection is done.

Test considered GOOD : 
rename folder devis to devisaaa
messages disappear
change folder to Inbox
content messages of the Inbox is displayed
change folder to devisaaa
content messages of the devisaaa is displayed

Test considered BAD : 
rename folder devis to devisaaa
messages disappear
change folder to Inbox
content messages of the Inbox is NOT displayed
change folder to devisaaa
content messages of the devisaaa is NOT displayed

when test is BAD if you change the disposition messages reappear. I traditionally found that if you renamed the folder a second time (revert back from devisaaa to devis) it has the same effect : messages are displayed again for all folders.

complete log and screenshot attached
Flags: needinfo?(gregory.rocher)
Attached file bissect-02-1120361.log
Attached image bissect-02-1120361.png
thanks Gregr!

If it's c-c regression: https://hg.mozilla.org/comm-central/pushloghtml?startdate=2014-01-13+03%3A05%3A00&enddate=2014-01-14+03%3A05%3A00
* Could it be bug 331376
* Or, is what landed a day before not a coincidence?  Bug 956609 - Land the IM front-end in comm-central

Else https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-01-13+03%3A05%3A00&enddate=2014-01-14+03%3A05%3A00
Flags: needinfo?(acelists)
Duplicate of this bug: 1292170
Duplicate of this bug: 1248660
In the recent version of thunderbird this bug is resolved. Thank you all!
more potential duplicates:
bug 1088514 The message list and the text are not displayed after renaming the IMAP folder.
Bug 916095 - After renaming imap folder, message list is not dislayed only once.
I am seeing this too w/ TB 45.5.1 (on Linux, Gentoo x86_64) after moving folders to Trash. Either I restart TB or a switch layout back and forth, otherwise I cannot open a single mail again in any folder and get the above mentioned error msgs in my log.
(In reply to Matthias Dahl from comment #21)
> I am seeing this too w/ TB 45.5.1 (on Linux, Gentoo x86_64) after moving folders to Trash.
> Either I restart TB or a switch layout back and forth,
> otherwise I cannot open a single mail again in any folder
> and get the above mentioned error msgs in my log.

What do you mean by "above mentioned error msgs in my log"? Error message of commemt #10 in Error Console?

I also saw issue like next a few times.
  after rename, move, delete(move to trash, IIRC) of Gmail IMAP folder,
  folder pane display doesn't reflect the change,
  and couldn't see correct folder pane display until restart of Tb.

When imap, Tb's behavior is affected by following:
  Server Settings/Advanced : [ ? ] Show only subscribed folder
   Checked : folder is shown based on subscribed state (via. subscribe, LIST subscribe etc.)
   Unchecked : folder is shown based on LIST response(existent mbox or not)
  IMAP delete model in Server Settings = move to trash, just mark as deleted, remove it immediately
   move to trash : delete ABC/folderX == rename ABC/FolderX Trash/FolderX or Trash/ABC/FolderX
                   and obtaine mbox under ABC and Trash for folder pane refresh
   other model : delete ABC/folderX == delete ABC/folderX
                 and obtaine mbox under ABC if required

Although problem seems Folder Pane refresh issue(timing problem is suspected), because communication with imap server is always relevant, I believe that no one can analyze this kind of issue without data for "actual communication between imap servder when your problem occurred".
And, the "actual communication between imap servder when yourproblem occurred" depends on you setting, and depends on server.

Does your problem consistently occur?(when you tried to delete folder, your problem always occur, or not)
If not "always", what is difference between "problem doesn't occur" and "problem occurs"?

When I saw similar folder refresh issue, it was "mbox at deep level" and "mbox with special character(mbox himself, or parent mjbox)" which was intentionally created for test.

Is there any error in Activity Manager in addition to Error Console?
What is your Server Setting and Advanced of it?
"move to Trash" = Drag&Drop folder to Trash? Delete from context menu?
Namespace such as "NBOX/", "INBOX." used by server?
"Server Directory" is used?(Server Settings/Advanced)
Is "\Noselect" folder(shown in Italic at folder pane/subscribe) relevant to your problem?
Vire/Folder/All? View/Folder/Unified?

What is shown by "subscribe".
"Folder rediscovery" is done when "account is collapsed and expanded", and "LIST %/%" is requed when "Folder is collapsed and expanded" or "collapsed folder is double cliced".
Does your promlem remain even after such operation?

What occurs when "Go Work Offline", "then Go Work Online", and account collapse/expand etc. is done?

If new messenger windoew is openbed, what happens? (open new 3pane window as new window, instead of open in new tab)
If object for folder pane is broken or wrong state is held in it, I guess folder pane is recovered by this operation.

Can you provide IMAP log when your problem happened?
Following is bug 1062408 comment #9, which is set in dependency tree of this bug.
> The problem is fixed if View -> Layout is changed.
> But not when View->Folders mode is changed.

Have you read bugs pointed in this bug? Is above effective recovery procedure from your problem?
To all problem reporters.
Please read bugs in dependency tree for bug 1062408 which is set in dependency tree of this bug.
Error message in comment #10 is same error code at same module as bug 1062408 and bug 1083994, although string is slightly different.
And, recovery operation in comment #10 is same as one stated in bug 1062408.
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1062408
Flags: needinfo?(acelists)
Resolution: --- → DUPLICATE
Duplicate of bug: 1062408
(sorry, wrong dup bug)
Duplicate of bug: 1083994
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #26)
> *** This bug has been marked as a duplicate of bug 1083994 ***

This bug already had duped bugs. Duping bug who has dupes to bug who has dups to bug who has dups ... is a way to effectively hide bug reports from users. I believe duping should be one level only.

If regression window was found in this bug and the regression window is correct, why problem analysis is not executed in this bug?
Summary: IMAP: after folder rename or move messages couldn't be opened anymore until restart - works in an older TB version (< 31) → IMAP: after folder rename or move messages couldn't be opened anymore until new messenger window open - works in an older TB version (< 31)
Cause of problem was found at last, and bug 1328814 was opened.
Duplicate of bug: 1328814
You need to log in before you can comment on or make changes to this bug.