Closed Bug 1063352 Opened 6 years ago Closed 6 years ago

the contact update/import button is in a weird place

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.1+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: dietrich, Assigned: wilsonpage)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image screenshot
Flame, master, Sept 4.

Once you're at the screen where you can select contacts to import (or update), the import button itself is in a very odd place and doesn't look like a button.

It's up on the left, between the [x] button and the title. It's in inconsistently placed, and unbuttonlike - the combination of which makes this a bug.

On the page before it, the "done" button is in the expected location - top right on title bar.

Screenshot attached.
Requesting UX feedback.
Flags: needinfo?(firefoxos-ux-bugzilla)
Dietrich, I can't see this on my device. Are you in the Browser, a Gmail app, or mobile Gmail, something else? Thanks!
The Contacts app, per the component I filed this bug in.

STR:

1. Open Contacts
2. Click the gear icon
3. Click Import Contacts
4. Click Gmail
5. Log in to Google
6. Wait for it to get friends list

You are now on the screen which has this problem. Screenshot of the Import version coming soon.
Attached image Screenshot (import)
Ah ha - got it. Yeah that's... less than ideal. The layout during import is also a mess. Flagging Carrie.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
And... describing the issue a bit more for triage posterity: I can see how this layout issue would prevent the user from being able to import contacts. After selecting some or all contacts to import, there appears to be no button for the user to click and no way to move forward to complete the import. The "Import" is tiny and not where one would expect to find a button, nor is it obvious that "Import" (which appears as non-clickable title text) is a button at all.
Duplicate of this bug: 1063207
[Blocking Requested - why for this release]:

Nominating to 2.1 because there has not been any new design in 2.1 for changing this screen.

Leaving ni to Carrie and Fang to confirm it
blocking-b2g: --- → 2.1?
Flags: needinfo?(fshih)
Wilson, i think this is caused by the new header component work. Do you still think that is a old gecko? Or is a issue in gaia?
Flags: needinfo?(wilsonpage)
Attached file pull-request (master)
Attachment #8485782 - Flags: review?(francisco)
Flags: needinfo?(wilsonpage)
Assignee: nobody → wilsonpage
Comment on attachment 8485782 [details] [review]
pull-request (master)

Working perfect!

Thanks Wilson!
Attachment #8485782 - Flags: review?(francisco) → review+
Keywords: regression
I'm pretty sure this is a regression. Can we confirm this was working in 2.0?
Keywords: regressionqawanted
QA Contact: jmitchell
Duplicate of this bug: 1064207
regression confirmed - This bug does NOT repro in Flame 2.0

Actual Results - the import button is on the right side of the title bar (as expected)

Device: Flame 2.0
Build ID: 20140906031700
Gaia: f02a8e4ef0fabeb28593fa660a0a4ca8a5fe67e5
Gecko: 8e46e547f4ad
Version: 32.0 (2.0)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawantedregression
Comment on attachment 8485782 [details] [review]
pull-request (master)

LANDED https://github.com/mozilla-b2g/gaia/commit/814fb3ba7da3f0bca0ef3f4d2433e2d1f38b091c
Flags: needinfo?(pbylenga)
Flags: needinfo?(fshih)
Flags: needinfo?(cawang)
Attached file pull-request (v2.1)
Attachment #8485892 - Flags: review?(francisco)
triage: obvious UI defect.
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8485892 [details] [review]
pull-request (v2.1)

LGTM in 2.1
Attachment #8485892 - Flags: review?(francisco) → review+
Comment on attachment 8485892 [details] [review]
pull-request (v2.1)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
New heades as a web component
[User impact] if declined:
Bad user experience, with buttons swapped
[Testing completed]:
Has been some days in master, looking good
[Risk to taking this patch] (and alternatives if risky):
Not pretty risky, is a change in dom placement
[String changes made]:
Attachment #8485892 - Flags: approval-gaia-v2.1?(fabrice)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Duplicate of this bug: 1065666
Tested and working
Flame
2.2
Gecko-eb14ebf
Gaia-7c5014a

Pending 2.1
Comment on attachment 8485892 [details] [review]
pull-request (v2.1)

very low risk visual change baked/test on master, approving to land on 2.1.
Attachment #8485892 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Tested and working
2.1
Gecko-a50444f
Gaia-944e5b4
Status: RESOLVED → VERIFIED
This issue is verfied fixed for the Flame 2.2 Master (319mb) and the Flame 2.1 KK (319mb)

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1 KK (319mb) (Full Flash)

Device: Flame 2.1
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: The contact update/import button is in an appropriate place.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.