Closed Bug 10642 Opened 20 years ago Closed 20 years ago

[DOGFOOD] HOME and END keys not hooked up

Categories

(Core :: Editor, defect, P1)

defect

Tracking

()

VERIFIED DUPLICATE of bug 18033

People

(Reporter: scottputterman, Assigned: mjudge)

References

Details

The HOME and END keys are not hooked up.  As I'm using Ender more for composing
messages, I'm finding myself trying to use these keys a lot.
Assignee: buster → mjudge
Summary: HOME and END keys not hooked up → [DOGFOOD] HOME and END keys not hooked up
Assignee: mjudge → brade
OS: Windows NT → All
Hardware: PC → All
Target Milestone: M10
Since this is a keybinding, I'm reassigning to myself.
M10; all platforms
Status: NEW → ASSIGNED
Depends on: 11456
waiting for bug 11456
Blocks: 12658
Target Milestone: M10 → M12
move to M12; no api yet
Whiteboard: [PDT+]
Putting on [PDT]+ radar.
Blocks: 16654
Priority: P3 → P1
Assignee: brade → mjudge
Status: ASSIGNED → NEW
reassign until mike finishes API; Mike reassign to me when the API is done.
Blocks: 17907
Whiteboard: [PDT+] → [PDT+] [dependent on saari, no start/end date]
Whiteboard: [PDT+] [dependent on saari, no start/end date] → [PDT+] [dependent on saari]
This bug looks orphaned - [HOME] and [END] appear to be working
properly everywhere now; judging by bug 16636, it's been FIXED for a
while now.

Tested both keys in <textarea>, <input type=text...>, UI text entry boxes,
and compositor in these parts of the product:
Main Browser window
Edit>Preferences
File>New>Edit Blank Page
File>New>Message
File>New>Address Book Card
  ... and both [HOME] and [END] appear to work properly in all of those places.

Tested with: 1999-11-19-09-M12 nightly binary on Windows NT 4.0sp3
Home and End do not work properly on Macintosh.  The reason is that they *need*
to work differently from Windows behavior.  This will be handled with platform-
specific keybindings.

Right now Home and End are hard-coded to their current behavior.  This is the
bug.  Mike is currently working on an API (though he needs some fixes from Chris
Saari before he can finish).  Once Mike has his API in place, I'll get this bug
and enable the behavior by keybinding rather than the hard-coded behaviors.

I hope that is clearer for everyone.
Whiteboard: [PDT+] [dependent on saari] → [PDT-] [dependent on saari]
changing to PDT- per PDT team
Depends on: 19981
Blocks: 18033
Whiteboard: [PDT-] [dependent on saari]
this can't be a PDT-, 18033 (which is a PDT+ bug is dependent on this one
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
There was a bug yesterday that had arrow keys, home and end.
18033 covers this too.  Would like this to be a dup of 18033.

*** This bug has been marked as a duplicate of 18033 ***
Blocks: 20870
Status: RESOLVED → VERIFIED
verified in 12/7 build.
No longer blocks: 17907
No longer blocks: 20870
You need to log in before you can comment on or make changes to this bug.