Fix some TypeErrors and SyntaxErrors seen in JS strict mode when running mozmill tests

RESOLVED FIXED in Thunderbird 36.0

Status

defect
--
trivial
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

Trunk
Thunderbird 36.0
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird36 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
JavaScript strict warning: resource:///modules/msgDBCacheManager.js, line 131: SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function

JavaScript strict warning: file:///tbird-bin/dist/bin/components/imContacts.js, line 101: SyntaxError: in strict mode code, functions may be declared only at top level or imm
ediately within another function

JavaScript strict warning: file:///tbird-bin/dist/bin/components/nsAbAutoCompleteSearch.js, line 364: SyntaxError: in strict mode code, functions may be declared only at top
level or immediately within another function

JavaScript strict warning: resource://mozmill/modules/frame.js -> file:///mail/test/mozmill/tabmail/test-tabmail-dragndrop.js, line 328: TypeError: "recentlyClosedTabs" is read-only
(Assignee)

Comment 1

5 years ago
Posted patch 1070614-imSplinter Review
Attachment #8492637 - Flags: review?(florian)
(Assignee)

Comment 2

5 years ago
Posted patch 1070614-tbSplinter Review
Attachment #8492638 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 3

5 years ago
Posted patch 1070614-mn (obsolete) — Splinter Review
Attachment #8492639 - Flags: review?(neil)
Comment on attachment 8492637 [details] [diff] [review]
1070614-im

Thanks!
Attachment #8492637 - Flags: review?(florian) → review+
(Assignee)

Comment 5

5 years ago
Posted patch 1070614-mn v2Splinter Review
Small nit from Neil.
Attachment #8492639 - Attachment is obsolete: true
Attachment #8492639 - Flags: review?(neil)
Attachment #8492664 - Flags: review?(neil)
Attachment #8492664 - Flags: review?(neil) → review+
Attachment #8492638 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 6

5 years ago
Thanks.
Keywords: checkin-needed
Duplicate of this bug: 1072907

Updated

5 years ago
Duplicate of this bug: 1048521
(Assignee)

Updated

5 years ago
Blocks: 826732
https://hg.mozilla.org/comm-central/rev/53b401928f08
https://hg.mozilla.org/comm-central/rev/b03be9fe6acd
https://hg.mozilla.org/comm-central/rev/acbcfef22bd3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
(Assignee)

Updated

4 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.