Closed Bug 1072035 Opened 6 years ago Closed 3 years ago

Try to make CSS hacks more robust

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

35 Branch
All
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Margaret, Unassigned)

References

Details

(Whiteboard: shovel-ready)

Looks like Bing changed their CSS and the header is visible. I can update the hack, but this demonstrates that it would be good to find a way to address bug 1059984.
Hm... I can't reproduce this now. But I swear I saw it! I'll keep this open for the time being in case anyone else runs into this.
It seems like this isn't actually a problem, but I'm going to morph this bug to be about trying to be more defensive when it comes to these CSS hacks.

We can keep the existing CSS we're injecting, since that seems to work, but we should also explore whether or not we can do things like hiding certain element types, rather than relying on ids to not change.

It also wouldn't be too much work to add some more CSS for the other search plugins we ship (right now we're only doing this for google/yahoo/bing). We could also add better support for tablets, where the CSS for some of the providers currently doesn't work.
Assignee: margaret.leibovic → nobody
Priority: P1 → --
Summary: Bing CSS hack is broken → Try to make CSS hacks more robust
Whiteboard: shovel-ready
Blocks: 1064325
This is an ex-Search Activity now (bug 1221344).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.