Closed Bug 1073340 Opened 7 years ago Closed 7 years ago

[Usage][Cost Control] Data usage limit can't be set to 0.07 GB/MB

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 affected, b2g-v2.2 verified)

RESOLVED FIXED
2.1 S6 (10oct)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- verified
b2g-v2.1 --- affected
b2g-v2.2 --- verified

People

(Reporter: shinglyu, Assigned: mai)

References

Details

Attachments

(6 files)

# Summary: 
  The "data usage limit" can't be set to 0.07, all other values from 0.01 to 0.09 works fine.

# Steps:
  * Open the Cost Control App, go throught the FTU settings is necessary.
  * Open the settings (top-right corner)
  * Enable "Data use alert", and click to set the "When use is above" setting.
  * In the number input box, type "0.07".

# Expected:
  0.07 can be set, just like any other value (e.g. 0.01, 0.06 or 0.08).

# Actual:
  The input box is marked red (invalid value), 0.07 can not be saved.

# Other notes:
   * 0.01 through 0.09 are all fine, except 0.07.
   * 1.07, 10.07, 700, 7, 7.0 all works fine.
# Repoduction Frequency:
  Always

# Build version:
  Gaia      86905e14c3ff06a0e6952ba635b6066ad2eea6b4
  Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/572b666c54bd
  BuildID   20140925160208
  Version   34.0a2
  ro.build.version.incremental=27
  ro.build.date=Thu Sep  4 14:59:02 CST 2014
Attached file patch v1.0
Hi Salva,
would you mind reviewing the patch?
Regards Marina
Attachment #8499371 - Flags: review?(salva)
Assignee: nobody → mri
Comment on attachment 8499371 [details] [review]
patch v1.0

Thank you Marina. The patch is almost ok but we need to include tests here and add the 0.07 case as a regression test. Ask for my review once you add the tests and review the comments on GitHub.
Attachment #8499371 - Flags: review?(salva)
Comment on attachment 8499371 [details] [review]
patch v1.0

Salva, 
you're right, sorry for missing the test. Updated the pr with your comments.

Marina
Attachment #8499371 - Flags: review?(salva)
Comment on attachment 8499371 [details] [review]
patch v1.0

Nice work. You have a little comment on the PR. Thank you!
Attachment #8499371 - Flags: review?(salva) → review+
MAster: 470826d13ae130a5c3d572d1029e595105485fb0
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Marina Rodríguez [:mai] from comment #6)
> Comment on attachment 8499371 [details] [review]
> patch v1.0
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #):Feature
> [User impact] if declined: The user cannot put the limit 0.07, the problema
> is a decimal overflow
> [Testing completed]: Yes
> [Risk to taking this patch] (and alternatives if risky): Low risk
> [String changes made]: Yes

This is a mistake. There is a new regular expression but there is not any new UI string to translate.
Attachment #8499371 - Flags: approval-gaia-v2.1?(release-mgmt)
Comment on attachment 8499371 [details] [review]
patch v1.0

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Feature
[User impact] if declined: The user cannot put the limit 0.07, the problema is a decimal overflow
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]:No
Attachment #8499371 - Flags: approval-gaia-v2.1?(release-mgmt)
Comment on attachment 8499371 [details] [review]
patch v1.0

Not bad enough.
Attachment #8499371 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1-
Duplicate of this bug: 1091918
Have a similar problem: On 2.0.0.0-prerelease on a Flame, I cannot set 1200 MB as usage limit. When I enter that value, then the entry field's background turns red and the "Done" button becomes disabled.
This is not a bug. You can not enter four digit amounts.
Duplicate of this bug: 1095364
Attached file pull request for v2.0
This is the PR for v2.0. Code changes are the same with the previous patch except there is one line difference in the test file. Thank you.
Attachment #8539098 - Flags: review?(salva)
[Blocking Requested - why for this release]: Per comment 14 and given it is the same code, I was wondering why the patch is not simply uplifted to v2.0?
blocking-b2g: --- → 2.0?
Comment on attachment 8539098 [details] [review]
pull request for v2.0

Oh, I see the difference. But I still think we need the blocking 2.0 flag for this. If you get it, ask for my review again.
Attachment #8539098 - Flags: review?(salva)
[Triage] support the idea to have this fix for 2.0.
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8539098 [details] [review]
pull request for v2.0

Thanks! r? for v2.0.
Attachment #8539098 - Flags: review?(salva)
This got denied for v2.1 as "not bad enough" but now it's blocking v2.0? That seems...odd. Anyway, you'll need to request Gaia approval before anything can land on the release branches.
Flags: needinfo?(marina.rodrigueziglesias)
Target Milestone: --- → 2.1 S6 (10oct)
Fabrice, in comment 9, you deny the approval for 2.1. As you can see in comment 17, the bug has been marked as 2.0+ I'm requesting Marina to fill approval for 2.0. In case we get it, could you grant 2.1 approval as well? What do you think?

Thank you.
Flags: needinfo?(fabrice)
Sorry, the patch for v2.0 comes from yifan.

Yifan, could you ask for 2.0 aproval before merging, please?
Flags: needinfo?(marina.rodrigueziglesias) → needinfo?(yliao)
Comment on attachment 8539098 [details] [review]
pull request for v2.0

LGTM. Anyway, remember to ask for approval and let Fabrice provide his feedback about 2.1.
Attachment #8539098 - Flags: review?(salva) → review+
Comment on attachment 8539098 [details] [review]
pull request for v2.0

Thank you!

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): This bug
[User impact] if declined: Data usage limit can't be set for certain values
[Testing completed]: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=c748ade42d3c
[Risk to taking this patch] (and alternatives if risky): No
[String changes made]: No
Flags: needinfo?(yliao)
Attachment #8539098 - Flags: approval-gaia-v2.0?(bbajaj)
[Blocking Requested - why for this release]:

wesly, I don't think this is any new regression or a severe enough bug that we will block a release for, at this point. I don't think we should be blocking 2.0+ on this so I re-noming it for you to go through this isssue and minus it.
blocking-b2g: 2.0+ → 2.0?
Flags: needinfo?(wehuang)
(In reply to Salvador de la Puente González [:salva] from comment #20)
> Fabrice, in comment 9, you deny the approval for 2.1. As you can see in
> comment 17, the bug has been marked as 2.0+ I'm requesting Marina to fill
> approval for 2.0. In case we get it, could you grant 2.1 approval as well?
> What do you think?
> 
> Thank you.

I still stand by my opinion, which is that we should not backport that anywhere.
Flags: needinfo?(fabrice)
Hi Kai-Zhen,
The bug has been reported by partner per bug 1095364. 2.0M+. Thanks!
blocking-b2g: 2.0? → 2.0M+
Flags: needinfo?(kli)
This bug has been failed verified on Flame v2.2.
See attachments: verify_2.2_1435.MP4 and logcat_2.2_1435.txt
Reproduce rate: 5/5

STR:
1.Open Usage app.
2.Tap Settings icon.
3.Try to input "0.07" to set "Data usage limit".
**The input box is marked red, and can't input "0".

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.194842
FW-Date         Mon Jan 12 19:48:52 EST 2015
Bootloader      L1TC000118D0

-------------------------------
This bug has been successfully verified on Woodduck 2.0.
See attachment: verified_v2.0m.mp4.
Reproduce rate: 0/5

Woodduck 2.0 build:
Gaia-Rev        ddb406ebdb34ca6717eda14297dea98f26f1f412
Gecko-Rev       e5f7072da9a640b8e63d3e25741e99f48d8a431b
Build-ID        20150113050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421096736
FW-Date         Tue Jan 13 05:06:01 CST 2015
Flags: needinfo?(echang)
See Also: → 1121383
Attachment #8539098 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0-
(In reply to bhavana bajaj [:bajaj] from comment #24)
> [Blocking Requested - why for this release]:
> 
> wesly, I don't think this is any new regression or a severe enough bug that
> we will block a release for, at this point. I don't think we should be
> blocking 2.0+ on this so I re-noming it for you to go through this isssue
> and minus it.

Hi Bhavana:

Ok, for this one we can fix it in 2.0m instead. Thanks for the suggestion.
Flags: needinfo?(wehuang)
This bug has been successfully verified on today's Flame v2.2.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5.

Flame 2.2 build: 
Gaia-Rev        e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/75a462a58d7a
Build-ID        20150121002607
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150121.040751
FW-Date         Wed Jan 21 04:08:02 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(echang)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/10131/
QA Whiteboard: [MGSEI-Triage+]
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.