Closed Bug 1085496 Opened 5 years ago Closed 5 years ago

[Lockscreen] Many locales: SIM card number is overlapping service provider text on lockscreen

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: rmead, Assigned: mnjul)

References

Details

(Keywords: regression, Whiteboard: LocRun2.1-2)

Attachments

(2 files)

Attached image 2014-10-20-13-37-14.png
Description:
While on lockscreen, the text in the upper left corner that tells you what SIM card you have active(ex: SIM 1), overlaps the text right next to it that tells you who the SIM cards provider is(ex: AT&T).
   
Prereq: Have a SIM card inserted in the device and set language to Danish.

Repro Steps:
1) Update a Flame device to BuildID: 20141020001201
2) Navigate to homescreen and enter correct SIM pin if required.
3) Tap power button twice to bring up lockscreen and observe.
  
Actual:
SIM and provider text overlap each other.
  
Expected: 
SIM and provider text are properly spaced.
  

Flame 2.1(319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141020001201
Gaia: 2904ab80816896f569e2d73958427fb82aebaea5
Gecko: 12dc9b782f2a
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: screenshot
This issue was NOT an issue on Flame 2.0 (319mb)

The SIM and provider text on the lockscreen was not overlapping.


Flame 2.0 (319mb)(Full Flash)

Device: Flame 2.0 
Build ID: 20141020000206
Gaia: 9c7dec14e058efef81f2267b724dad0850fc07e4
Gecko: c17df9fe087d
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

This is a regression. Requesting to block 2.1 (Danish is a shipping locale)
blocking-b2g: --- → 2.1?
Keywords: regression
Duplicate of this bug: 1085589
Dutch also affected (shipping locale as well). Making this bug generic and not locale specific.
Summary: [2.1][l10n][Component] Danish: SIM card number is overlapping service provider text on lockscreen → [2.1][l10n][Component] Many locales: SIM card number is overlapping service provider text on lockscreen
Flags: needinfo?(firefoxos-ux-bugzilla)
This bug is also happening in Basque(eu).
QA Whiteboard: [QAnalyst-Triage?]
Component: da / Danish → Gaia::System::Lockscreen
Product: Mozilla Localizations → Firefox OS
Summary: [2.1][l10n][Component] Many locales: SIM card number is overlapping service provider text on lockscreen → [Lockscreen] Many locales: SIM card number is overlapping service provider text on lockscreen
This is a regression, as others have stated, and is not expected.
Flags: needinfo?(firefoxos-ux-bugzilla)
QA Contact: ckreinbring
Triage: regression, blocking.
Assignee: nobody → jlu
blocking-b2g: 2.1? → 2.1+
Attached file Patch (PR @ GitHub)
Proposed patch (without having looked into regression window) to fix what I observed.
Attachment #8508583 - Flags: review?(gweng)
Regression window
Last working
BuildID: 20140729170208
Gaia: c527178b78a5bc85b76f89d6ba7f0bb464963b79
Gecko: f61a27b00e05
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140730035508
Gaia: 25e998814ba89f30fe44cd2fdfbb44d160a04641
Gecko: 55c4d770f88b
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: c527178b78a5bc85b76f89d6ba7f0bb464963b79
Gecko: 55c4d770f88b
Broken Gaia / Working Gecko = Repro
Gaia: 25e998814ba89f30fe44cd2fdfbb44d160a04641
Gecko: f61a27b00e05
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/c527178b78a5bc85b76f89d6ba7f0bb464963b79...25e998814ba89f30fe44cd2fdfbb44d160a04641

B2G Inbound
Last working
BuildID: 20140729224005
Gaia: cc5af5e8130ad81fda59b49d8213fbd67e1a0ddd
Gecko: 447fd3d98aa4
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140729232704
Gaia: 1dd9769ebfc90ce02dca843dedd3e8a173a0454c
Gecko: e86cab5a966c
Platform Version: 34.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: cc5af5e8130ad81fda59b49d8213fbd67e1a0ddd
Gecko: e86cab5a966c
Broken Gaia / Working Gecko = Repro
Gaia: 1dd9769ebfc90ce02dca843dedd3e8a173a0454c
Gecko: 447fd3d98aa4
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/cc5af5e8130ad81fda59b49d8213fbd67e1a0ddd...1dd9769ebfc90ce02dca843dedd3e8a173a0454c
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by Bug 1020779 - can you take a look Rudy?
Blocks: 1020779
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(rlu)
Flags: needinfo?(jmitchell)
Flags: needinfo?(dharris)
QA Contact: ckreinbring
(In reply to Joshua Mitchell [:Joshua_M] from comment #10)
> Broken by Bug 1020779 - can you take a look Rudy?

The window is incorrect -- that bug only touches keyboard. Since we already got a fix let's not spend time to find the window again.
No longer blocks: 1020779
Flags: needinfo?(rlu)
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #12)
> The offending style was added all the way back in bug 921390
> https://github.com/mozilla-b2g/gaia/blame/
> 9546ac7fa18538c0d6b0192c0fb5fedd08de7e5b/apps/system/style/lockscreen/
> lockscreen.css#L214
> Which is unlikely to be the cause .... :-/

Yes, I found out that yesterday too and discussed with Greg. We thought that there probably had been some CSS rules that overrode the offending rule, and only got removed recently, thus making the offending rule be really offending.

With that said, the regression findings didn't seem to find anything meaningful -- I guess we'll just proceed with my patch.
Comment on attachment 8508583 [details] [review]
Patch (PR @ GitHub)

R+ because I saw the result is what we expect to fix. And it's only a CSS fix.
Attachment #8508583 - Flags: review?(gweng) → review+
To further elaborate on my comment 13 -- as this is a regression + 2.1-blocking bug, I decided to propose a fix that fixes what I see as the bug even though we didn't find a meaningful regressing patch. It of course would be great if we could find out the root cause.

Anyway, tree is closed right now and my original PR didn't trigger a Try run, so let's wait...
Argghh, I got what's wrong. The specific SIM X string was not translatable until bug 1033585. As it became translatable and longer localized strings were added, the fixed width became problematic.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8508583 [details] [review]
Patch (PR @ GitHub)

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #): bug 1033585 made the string under topic translatable, and translated strings were not properly styled by the CSS rule authored in bug 921390.

[User impact] if declined: Bad UX: In locales where "SIM 1" is translated to be longer than in English, the translated "SIM 1" string overlaps with Carrier name, in lockscreen.

[Testing completed]: Yes, manual test & TBPL.

[Risk to taking this patch] (and alternatives if risky): Minimal, as this is just a CSS change.

[String changes made]: None
Attachment #8508583 - Flags: approval-gaia-v2.1?
Verified the bug is fixed on master build 2.2 but still reproduces on 2.1

SIM car number is no longer overlapping a provider name when changing language to "Danish", checked on many locales 

Device: Flame 2.2 Master
BuildID: 20141024040202
Gaia: d893a9b971a0f3ee48e5a57dca516837d92cf52b
Gecko: a5ee2769eb27
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Adding verifyme for 2.1 verification once the patch has been uplifted.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8508583 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Issue verified fixed on Flame 2.1

Actual Results: When language is set to Danish, Dutch, and Basque the SIM Card number is not overlapping the service provider.

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.