(App-grouping) Moving last icon out of bottom / top group edge cases.

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mushi, Assigned: cwiiis)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master affected)

Details

(Whiteboard: [systemsfe] polish)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Case 1: When moving the last app out of the bottom group of the homescreen the user should not be able to create a new group below it (essentially recreating the group the app was just in). 

Case 2: When moving the last app out of the top group of the homescreen the user should not be able to create a new group above it (essentially recreating the group the app was just in). 

Don't show the visual hint at the bottom/top of the homescreen respectively for these edge cases.
(Assignee)

Updated

3 years ago
Assignee: nobody → chrislord.net
Blocks: 1086514
(Assignee)

Updated

3 years ago
Blocks: 1067435
No longer blocks: 1086514
(Assignee)

Updated

3 years ago
No longer blocks: 1069699
(Assignee)

Updated

3 years ago
Whiteboard: [systemsfe] → [systemsfe] polish
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1109948
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1116082
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
Created attachment 8544623 [details] [review]
Don't allow redundant moves between groups
Attachment #8544623 - Flags: review?(kgrandon)
Attachment #8544623 - Flags: review?(crdlc)
Comment on attachment 8544623 [details] [review]
Don't allow redundant moves between groups

LGTM, thanks a lot for your work
Attachment #8544623 - Flags: review?(crdlc) → review+
(Assignee)

Comment 5

3 years ago
Merged: https://github.com/mozilla-b2g/gaia/pull/27158
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Attachment #8544623 - Flags: review?(kgrandon)
Blocks: 1131344
This issue is cannot be verified fixed on Flame 3.0 due to bug 1131344 being open. I will try to verify this bug again once the dependencies have been resolved
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
No longer blocks: 1131344
Depends on: 1131344
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Verified

Build ID               20150224162516
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150224.200438
Firmware Date          Tue Feb 24 20:04:49 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: --- → verified
You need to log in before you can comment on or make changes to this bug.