crash in @0x0 | mozilla::net::SpdySession31::CleanupStream(mozilla::net::SpdyStream31*, tag_nsresult, mozilla::net::SpdySession31::rstReason)

RESOLVED FIXED

Status

()

Core
Networking: HTTP
--
critical
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash})

36 Branch
All
Android
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36 affected)

Details

(crash signature)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-c1c265eb-e7a9-4ced-adcf-59ed02141027.
=============================================================
(Reporter)

Updated

4 years ago
Component: General → Networking
Product: Firefox for Android → Core
Version: Firefox 36 → 36 Branch
(Reporter)

Comment 1

4 years ago
I crashed with this signature randomly while just closing a tab. I can't reproduce it.
(Reporter)

Updated

4 years ago
Component: Networking → Networking: HTTP
I believe this was caused by bug 865314
Blocks: 865314
Signature is similar to bug 1089790  which was duped to bug 1089638, which makes sense given comment 2.

Comment 4

4 years ago
Bughunter sees

Assertion failure: false (AddStream duplicate transaction pointer), at /mozilla/builds/nightly/mozilla/netwerk/protocol/http/SpdySession31.cpp:358

with stack

mozilla::net::SpdySession31::AddStream mozilla::net::nsHttpConnection::AddTransaction mozilla::net::nsHttpConnection::Activate mozilla::net::nsHttpConnectionMgr::DispatchTransaction mozilla::net::nsHttpConnectionMgr::ProcessSpdyPendingQ on win, mac, linux on almost 200 urls.

Here is an example, but I can't reproduce it locally on fedora 20: https://play.google.com/store/apps/details?id=com.totaltexto.bancamovil

Tomcat and I will try to find a more reproducible case.
thanks :bc, but I think we have a strong feeling at the root cause here so you probably don't need to spend a lot of time on it. (comment 2)
Duplicate of this bug: 1089766
close this based on 
https://bugzilla.mozilla.org/show_bug.cgi?id=865314#c30
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Blocks: 1090238
You need to log in before you can comment on or make changes to this bug.