onDeletePages notifiers should batch notifications

RESOLVED DUPLICATE of bug 937560

Status

()

defect
RESOLVED DUPLICATE of bug 937560
5 years ago
4 years ago

People

(Reporter: mak, Unassigned)

Tracking

unspecified
Points:
5
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
the initial implementation of onDeletePages won't be able to batch notifications due to API limitations.

We need to fix some dependencies before we can actually free all of its power.
Flags: qe-verify-
Flags: in-testsuite?
Flags: firefox-backlog+
Reporter

Updated

5 years ago
Summary: onDeletePages should batch notifications → onDeletePages notifiers should batch notifications
getObservers is already in so there's no reason to implement this in two-steps, after all.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 937560
Resolution: --- → DUPLICATE
Duplicate of bug: 937560
Reporter

Updated

4 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.