Last Comment Bug 1092209 - Log viewer: Display TinderboxPrint output alongside job details
: Log viewer: Display TinderboxPrint output alongside job details
Status: VERIFIED FIXED
:
Product: Tree Management
Classification: Other
Component: Treeherder: Log Viewer (show other bugs)
: ---
: All All
P4 normal
: ---
Assigned To: Jonathan French (:jfrench)
:
:
Mentors:
: 1102988 1179261 (view as bug list)
Depends on:
Blocks: 1182178
  Show dependency treegraph
 
Reported: 2014-10-31 09:16 PDT by Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4)
Modified: 2015-07-24 11:12 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
PR798 (46 bytes, text/x-github-pull-request)
2015-07-22 09:30 PDT, Jonathan French (:jfrench)
cdawson: review+
Details | Review | Splinter Review

Description User image Armen Zambrano - Back on March 27th [:armenzg] (EDT/UTC-4) 2014-10-31 09:16:44 PDT
If you load this view:
https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2833982&repo=try
you won't see this information:
reftest 1733/120/78 (this shows up in the summary of a job when you click on it)

Could we please add it in the treeherder log viewer?
Thanks!

PS=I love the view!
Comment 1 User image Ed Morley [:emorley] 2014-11-11 15:06:57 PST
Yeah this would be handy :-)
Comment 2 User image Ed Morley [:emorley] 2015-01-02 16:55:59 PST
*** Bug 1102988 has been marked as a duplicate of this bug. ***
Comment 3 User image Ed Morley [:emorley] 2015-07-01 09:08:31 PDT
*** Bug 1179261 has been marked as a duplicate of this bug. ***
Comment 4 User image Jonathan French (:jfrench) 2015-07-02 10:24:44 PDT
So among 'universal' job properties we currently display:

(Job Details Panel + Job Details Tab)
Result, Job, Machine, Build(*), Job Name(*), Request(*), Start, End, Duration(*), InspectTask(*)

(Logviewer)
Result, Job, Machine, Start, End

...(*) are values we could consider adding to Logviewer if we wanted match them more closely. We'd like to add InspectTask to Logviewer for dupe bug 1179261. Ryan/Wes do you think we should add and match everything, or cherry pick additional values above for Logviewer?

If I recall correctly we had consciously chosen to omit some things in Logviewer.
Comment 5 User image Wes Kocher (:KWierso) 2015-07-02 10:32:55 PDT
You could definitely do without the requested time. Duration can probably be skipped, too. Job Name would be nice to have.
Comment 6 User image Ed Morley [:emorley] 2015-07-02 10:35:17 PDT
This bug is about adding the contents of TinderboxPrint to the log viewer. Most of the properties listed in comment 4 are not tinderboxprints.
Comment 7 User image Ed Morley [:emorley] 2015-07-02 10:36:01 PDT
ie we want to add the things here:
https://treeherder.mozilla.org/api/project/mozilla-inbound/artifact/?job_id=11312936&name=Job+Info&type=json
Comment 8 User image Ted Mielczarek [:ted.mielczarek] 2015-07-02 11:00:44 PDT
From my dupe (bug 1102988), I asked for the links to blobber downloads. Things like minidumps are important when a log contains a crash, and we tend to paste logs into bugs, so clicking the log link should give you the ability to download things like that.
Comment 9 User image Jonathan French (:jfrench) 2015-07-02 11:32:38 PDT
Could we append the printlines to the existing header block, and support scrolling of that container? And reduce the font size further so that by default some job details may completely fit in the current space. 

Alternately, we could put the current info into a 'Job info' tab (the default landing experience), with an adjacent 'Job details' tab for the printlines - supporting scrolling if the contents are large. I think would result in more mouse interaction though.

I kind of like the first one, not sure how everyone else feels.
Comment 10 User image Ryan VanderMeulen [:RyanVM] 2015-07-02 13:23:46 PDT
First sounds OK to me.
Comment 11 User image Jonathan French (:jfrench) 2015-07-03 12:28:34 PDT
If I can get this working nicely I will assign myself :)
Comment 12 User image Jonathan French (:jfrench) 2015-07-15 21:40:23 PDT
Getting closer, so assigning.
Comment 13 User image Jonathan French (:jfrench) 2015-07-22 09:30:45 PDT
Created attachment 8637285 [details] [review]
PR798

Please see above PR for status and review.
Comment 14 User image Treeherder Bugbot 2015-07-22 12:18:56 PDT
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/d0bb90a2eefd49deb31349a7a6f5caa1d71d5069
Bug 1092209 - Add tinderbox lines to logviewer
Comment 15 User image Jonathan French (:jfrench) 2015-07-22 12:30:37 PDT
Marking fixed per above merge. If we need to add additional/separate content we could add it in a follow up bug I'm sure.
Comment 16 User image Jonathan French (:jfrench) 2015-07-24 11:12:16 PDT
Verified fixed on stage.

Note You need to log in before you can comment on or make changes to this bug.