Closed Bug 1092561 (iosfxa) Opened 5 years ago Closed 4 years ago

[META] IOS-91 - Cloud Services - Firefox Accounts

Categories

(Firefox for iOS :: Firefox Accounts, defect, P3)

All
iOS 7
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: mfinkle, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: meta)

The Firefox application on iOS must be tied to a Firefox Account. We need:
* A UI to allow logging into a Firefox Account
* A UI to manage aspects of the Firefox Sync service
Group: mozilla-employee-confidential
https://intranet.mozilla.org/Firefox/Project105/KeyFeatures#Tied_to_a_Firefox_Account says:

"I'm prompted to create a Firefox Account, something I haven't heard of before. After creating it, I'm encouraged to sign into the same account on my desktop.

Note that the sign-up story outside of Desktop is not good at this point. We can implement signup on a non-desktop device, but the part that stings is 'go to your email to verify your account' and the things that happen after that. For example if you click the verification link in Mail.app on your iPad, there is no easy way to get back back to the P105 app where you started the signup.

Could be a reason to move signups past v1.0?
I think "signups" should be considered secondary, perhaps even post-v1.0 since it requires more consideration and UX flow than just "sign in".
Flags: needinfo?(krudnitski)
I disagree. We're tasked to growing FxA (although to me, that's besides the point). We'll be targeting existing desktop users who - quite frankly - in majority won't have an existing FxA yet. We can't leave them hanging - that will be an incredibly poor experience (even more poor than figuring out how best to 'verify your account')
Flags: needinfo?(krudnitski)
(In reply to Karen Rudnitski [:kar] from comment #3)
> I disagree. We're tasked to growing FxA (although to me, that's besides the
> point). We'll be targeting existing desktop users who - quite frankly - in
> majority won't have an existing FxA yet. We can't leave them hanging - that
> will be an incredibly poor experience (even more poor than figuring out how
> best to 'verify your account')

We'll need to get the FxAccount UX people involved to help work through the challenges of "Sign Up" on iOS.
Depends on: 1094195
Depends on: 1094476
Depends on: 1094478
Depends on: 1094479
Depends on: 1096727
Depends on: 1097400
Depends on: 1101066
Depends on: 1101143
Depends on: 1104940
Group: mozilla-employee-confidential
Component: General → Firefox Accounts
Keywords: meta
OS: Linux → iOS 7
Product: Firefox for Android → Firefox for iOS
Hardware: x86_64 → All
Summary: (ios) [meta] Support logging into a Firefox Account → [meta] Support logging into a Firefox Account
Version: Trunk → unspecified
No longer depends on: 1094476
Alias: fxaios
Alias: fxaios → iosfxa
Blocks: iosv1
No longer blocks: ios
Summary: [meta] Support logging into a Firefox Account → [META] IOS-91 - Cloud Services - Firefox Accounts
Duplicate of this bug: 1127053
Priority: -- → P3
Duplicate of this bug: 1126999
Blocks: 1136250
No longer depends on: 1139057
No longer depends on: 1097400
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.