Closed Bug 1093867 Opened 7 years ago Closed 7 years ago

Chunk mochitest-gl on at least android 2.3

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jgilbert, Assigned: kmoir)

References

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4044])

Attachments

(2 files, 1 obsolete file)

The tests are taking too long, so we're hitting the global job timeout. To keep running this test, we need to split it.
Assignee: nobody → kmoir
Attached patch bug1093867bbconfigs.patch (obsolete) — Splinter Review
Attachment #8518223 - Flags: review?(gbrown)
Attachment #8518225 - Flags: review?(gbrown)
Attachment #8518225 - Flags: review?(gbrown) → review+
Comment on attachment 8518223 [details] [diff] [review]
bug1093867bbconfigs.patch

Review of attachment 8518223 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/mobile_config.py
@@ +1177,5 @@
>          'use_mozharness': True,
>          'script_path': 'scripts/android_emulator_unittest.py',
>          'extra_args': [
>              '--cfg', 'android/androidarm.py',
>              '--test-suite', 'mochitest-gl',

I think we need --test-suite mochitest-gl-1 now.

@@ +1189,5 @@
> +        'use_mozharness': True,
> +        'script_path': 'scripts/android_emulator_unittest.py',
> +        'extra_args': [
> +            '--cfg', 'android/androidarm.py',
> +            '--test-suite', 'mochitest-gl',

mochitest-gl-2, right?

@@ +1195,5 @@
> +        'blob_upload': True,
> +        'timeout': 2400,
> +        'script_maxtime': 14400,
> +    },
> +    ),                           

white-space here
Attachment #8518223 - Flags: review?(gbrown) → review-
ah, sorry for the oversight in the first patch
Attachment #8518223 - Attachment is obsolete: true
Attachment #8518244 - Flags: review?(gbrown)
Comment on attachment 8518244 [details] [diff] [review]
bug1093867bbconfigs-2.patch

Review of attachment 8518244 [details] [diff] [review]:
-----------------------------------------------------------------

That looks right now.
Attachment #8518244 - Flags: review?(gbrown) → review+
Attachment #8518225 - Flags: checkin+
Attachment #8518244 - Flags: checkin+
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4044]
Checked in code deployed to production
It looks like the new gl-1, gl-2 jobs are not showing up in tbpl/treeherder.
See Also: → 1095624
Depends on: 1095624
So the jobs are appearing in treeherder.  For now they show up as m1 and m2 but will reflect the correct ui once the patches in bug 1095624 are deployed to production for treeherder.
Status: NEW → RESOLVED
Closed: 7 years ago
Component: Canvas: WebGL → Platform Support
Flags: checkin+
Product: Core → Release Engineering
QA Contact: coop
Resolution: --- → FIXED
Blocks: 1142743
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.