disable full-screen mode (f11) fails

RESOLVED DUPLICATE of bug 103758

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 103758
17 years ago
17 years ago

People

(Reporter: S. Malling, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla1.0
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.5+) Gecko/20011110
BuildID:    2001111008

it is not possible to exit the full screen mode, once entered

Reproducible: Always
Steps to Reproduce:
1.enter full-screen by pressing f11
2.try pressing f11 again

Actual Results:  nothing happens

Expected Results:  go back to normal view
(Reporter)

Comment 1

17 years ago
actually not reproducible always...
adding ulr where you see the bug.
ps. if you do get stuck in full-screen mode, that is if your start-page has the
bug. just keep clicking url's till you get to a page that dosen't 
ex. go to www.mozilla.org and press f11

Updated

17 years ago
Severity: normal → major
Keywords: nsCatFood
morse
Assignee: hyatt → morse

Comment 3

17 years ago
Yes, I've seen this as well.  Seems like you have to click in the content area, 
and once you've done that, then f11 will exit the mode.  Don't know yet what is 
causing that.

Bug description is a bit inaccurate.  It says "not possible to exit full screen 
mode, once entered."  Of course you could always exit with the button on the 
toolbar.  More accurate wording is "not always possible to exit full screen mode 
with F11".  (Of course in modern skin you don't get that to see that 
button but that's another problem -- bug 109585).  Summary line said it 
correctly.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Comment 4

17 years ago
I have that problem on Linux, too, with yesterdays CVS build. I have to click in
the content area once, after that I can use F11 again to leave full window mode.

I have to click the content area often to make keyboard shortcuts work. This
might be a more general problem, we probably already have a bug on that.
OS: Windows ME → All

Comment 5

17 years ago
See bug 109584.  The cause of this problem is spelled out there (ben's comment 
#4).

Comment 6

17 years ago
*** Bug 111610 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
This is related to bug 68136, so reassigning.
Assignee: morse → ben
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 8

17 years ago
I think this is a symptom of bug 103758.  You always have to click once into the
window before it accepts keyboard input.  Full screen mode is going to get
backed out so it probably does not matter anyway.

*** This bug has been marked as a duplicate of 103758 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.