Closed Bug 1104407 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][BT] Can't call the last number via BT headset when there are two SIM cards inserted.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1021478
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Assigned: selee)

References

Details

Attachments

(5 files)

DEFECT DESCRIPTION:
 >Can't call the last number via BT headset when there are two SIM cards inserted.
 
  REPRODUCING PROCEDURES:
 1.Insert two SIM cards, go to settings->SIM manager->outgoing calls, select always ask;
 2.Connect with a BT stereo hesdset, and outgoing a call via BT headset;
 3.Then call the last number in call log via BT headset, but it prompt "no  network connetct",can't call last number.--KO
 
 ps: "bt" means blueteeth.
Attached image picture
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: Woodduck
Flags: needinfo?(fan.luo)
Attached video Verify.mp4
This bug can be reproed on Woodduck 2.0M and Flame 2.0, can't repro on Flame 2.1/2.2

On Woodduck 2.0M and Flame 2.0, after redial via BT heaset, device will show "no network connetct".

See the attachments: Verify.mp4 and logcatVerify.txt
Occurrence time:16:37
Occurrence rate:5/5

Repro STR:
1. Insert two SIM cards, go to settings->SIM manager->outgoing calls, select always ask;
2. Pair and connect BT headset
3. Press Home key
4. Redial via BT headset
**There is no response.
5. Launch Phone
**Device shows "no network connetct".

Found time:

Woodduck build:
Gaia-Rev        87b23fa81c3b59f2ba24b84f7d686f4160d4e7cb
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141125050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416863158
FW-Date         Tue Nov 25 05:06:35 CST 2014
------------------
Flame 2.0:
Gaia-Rev        124c2f85f1b956e9e8429dab5121de702a3bc197
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/fc90ac008cc1
Build-ID        20141124000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141124.034117
FW-Date         Mon Nov 24 03:41:27 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.1 build:
Gaia-Rev        8ae086c39011bc8842b2a19bb5267906fa22345a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebbd5c65c3c1
Build-ID        20141124094013
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141124.130744
FW-Date         Mon Nov 24 13:07:55 EST 2014
Bootloader      L1TC00011880
------------------
FLame2.2 build:
Gaia-Rev        aad40f6d6eb8f626c6a20db55b9f00d2e832f113
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/be4ba3d5ca9a
Build-ID        20141124100136
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141124.132512
FW-Date         Mon Nov 24 13:25:25 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
Hi Shawn,
Could you help to check the bug? Thanks!
blocking-b2g: --- → 2.0M?
Flags: needinfo?(shuang)
I checked this problem. It seems like it's not bluetooth issue but telephony feature bug.
Flags: needinfo?(shuang)
Flags: needinfo?(sku)
Blocks: Woodduck_P2
Dear mozilla:
 
   May i ask how is it going on?
Hi Shawn,
Could you please help to check the problem? Thanks!
Geko ril log is not enabled.

Please make sure [1] was set to true, and re-get log for me to check.

// Log command
adb logcat -b radio -b main -v threadtime > /tmp/1104407.log

Stop logging, attach /tmp/1104407.log onto bugzilla, ni?sku then.
Thanks!


[1] - http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_consts.js?from=ril_consts.js&case=true#17
Flags: needinfo?(sku) → needinfo?(sync-1)
Norry, could you please help get gecko ril log per comment 9? Please NI on me if you have any question.
Flags: needinfo?(fan.luo)
Attached file logcat
I have uploaded logcat of Flame 2.0
Found time:15:18
Please check it, thanks.

Flame 2.0 versions:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/2d0860bd0225
Build-ID        20141210000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141210.034839
FW-Date         Wed Dec 10 03:48:50 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(fan.luo)
shawn, could you please take a look at the new logcat? attachment 8534841 [details]
Flags: needinfo?(sku)
Flags: needinfo?(sync-1)
Operator report "normal call clearing" (16), need Gaia to check what to improve when receiving NormalCallClearingError.


Hi Luke:
 Could you please help check this error cause from Gaia's perspective?



12-11 15:18:10.944 I/Gecko   (  206): -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callDisconnected","call":{"state":2,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"10010","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false,"hangUpLocal":true,"failCause":"NormalCallClearingError"},"rilMessageClientId":0}

12-11 15:18:10.944 I/Gecko   (  206): TelephonyService: handleCallDisconnected: {"state":2,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"10010","numberPresentation":0,"name":null,"namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"isConference":false,"hangUpLocal":true,"failCause":"NormalCallClearingError"}
Flags: needinfo?(sku) → needinfo?(lchang)
Hi Sean,

This bug seems to be identical to bug 1094670. Since you are investigating that bug, could you also take a look at this and mark one of these bugs as a duplicate? Thanks.
Flags: needinfo?(lchang) → needinfo?(selee)
Duplicate of this bug: 1094670
Assignee: nobody → selee
Flags: needinfo?(selee)
Attached file PR for v2.0m
Hi Doug,

Here is my PR. Please help to review it. Thank you.
Attachment #8539985 - Flags: review?(drs.bugzilla)
blocking-b2g: 2.0M? → 2.0M+
Hi XingMing,
Can you try patch per comment 16?
Flags: needinfo?(xingming.yin.hz)
(In reply to Josh Cheng [:josh] from comment #17)
> Hi XingMing,
> Can you try patch per comment 16?

Hi:
  I will check it tomorrow.
Flags: needinfo?(xingming.yin.hz)
Comment on attachment 8539985 [details] [review]
PR for v2.0m

Instead of using this patch, we could uplift:
* bug 1061473
* bug 982163
* bug 1021478

If you choose not to uplift these, we should at the very least look at the tests here and copy some of them over.
Attachment #8539985 - Flags: review?(drs.bugzilla) → review-
Hi Seinlin, Josh,

For further explanation, the above 3 patches are tested on Woodduck v2.0m and the test result is PASS.

Thank you.
Hi Sean,
all 2.0M+.

Hi Kai-Zhen,
Can you help to land all of them on 2.0M? Thanks!
Flags: needinfo?(jocheng)
Done.
Flags: needinfo?(kli)
Thank you Sean, Thank you Kai-Zhen,

I will dup this to first bug since there is nothing to fix here. Thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: 1021478, 982163, 1061473
Resolution: --- → DUPLICATE
See Also: → 1021478, 982163, 1061473
Duplicate of bug: 1021478
blocking-b2g: 2.0M+ → ---
(In reply to Josh Cheng [:josh] from comment #17)
> Hi XingMing,
> Can you try patch per comment 16?

dear mozilla:
   it is pass!
此bug为克隆bug,源bug:
 
 http://bugzilla.tcl-ta.com/show_bug.cgi?id=834560
 
 已被关闭,请wei.deng关闭此bug
You need to log in before you can comment on or make changes to this bug.