Enable event-regions on all platforms

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: kats, Assigned: tnikkel)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Bug 928833 enabled it on B2G. I want to let it bake for a day or two and then enable it on all platforms.
Depends on: 1109677
Depends on: 1111055
Depends on: 1111059
Assignee: bugmail.mozilla → tnikkel
Depends on: 1107843
Depends on: 1118051
Depends on: 1127327
(Assignee)

Updated

4 years ago
Depends on: 1132371
(Assignee)

Comment 2

4 years ago
The bc1 failure in there seems to have been caused by something else, subsequent try pushes don't have it.
Depends on: 1147538
Depends on: 1107143
Depends on: 1108052
Depends on: 1148515
Depends on: 1071969
Depends on: 1131128
Depends on: 1131188
Depends on: 1147279
Depends on: 1147539
Blocks: 1013364
Note that event regions is hitched to APZ now so that if APZ is enabled, event regions gets auto-enabled even if the pref is false. However there are still some correctness issue with event regions (see dep bugs, although some of those are purely optimization) that are not covered by automated testing but will still need to be fixed.
Depends on: 1157484

Comment 4

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> Note that event regions is hitched to APZ now so that if APZ is enabled,
> event regions gets auto-enabled even if the pref is false. 

So Event Regions cannot be enabled without APZ? Then the pref should go.
Event regions can be enabled without APZ.
Since APZ is enabled everywhere now (on Nightly at least), this bug should be closed. I'm going to move the remaining open dependencies over to block bug 1157834 instead. I'll make that bug more general to cover any event-regions issues, whether they are perf or correctness.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 1071969, 1107143, 1108052, 1131128, 1147538, 1147539, 1157484
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.