[Email] Some already-painted DOM elements are repainted as black boxes at card animation completion then repainted correctly. On New Account Password page.

RESOLVED DUPLICATE of bug 1113435

Status

()

defect
RESOLVED DUPLICATE of bug 1113435
5 years ago
5 years ago

People

(Reporter: jthomas, Assigned: BenWa)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-1], )

Attachments

(2 attachments)

Description:
If the user navigates to the New Account page some black boxes appear when the hit boxes are rendered. 

Repro Steps:
1) Update a Flame to 20141126000203
2) Launch Email App
3) Enter Name and valid Email address.
4) Select Next
5) Observe rendering behaviour.

Actual:
Password hitbox has a black box rendering briefly.

Expected:
It is expected no rendering issues will occur. 

Flame 2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (Unknown)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 100%
See attached: Video & Logcat
Video: https://www.youtube.com/watch?v=75blKRbY1cU
Flags: needinfo?(dharris)
This issue does NOT occur on the Flame 2.1 kk Shallow Flash (319mb) 

Result: For the 2.1 no blackbox appears when the password hitbox is displayed. As for the 2.0 the password page is already located on the previous along with the Name and Email address. I did not mark the flags for the 2.0 because of this layout.

 Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Summary: [Email] Black boxes occur when user is on the New Account Password page. → [Email] Black boxes occurs when user is on the New Account Password page.
Moving to graphics for duping, etc.
Component: Gaia::E-Mail → Graphics
Product: Firefox OS → Core
Summary: [Email] Black boxes occurs when user is on the New Account Password page. → [Email] Some already-painted DOM elements are repainted as black boxes at card animation completion then repainted correctly. On New Account Password page.
[Blocking Requested - why for this release]:

The black boxes are very easy to see and this bug occurs when logging in with VALID log in info. This is also a regression. Nominating to block 2.2
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Issue seems to only occur with an outlook account. It doesn't occur with a gmail account because it brings user to a different password entering screen. I haven't tested with other email accounts.

Working on getting the window now.
QA Contact: pcheng
blocking-b2g: 2.1? → 2.2?
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141129095244
Gaia: 7119da7a86cd803840678ca3a6067e5622adc481
Gecko: ba93c0eb3cf7
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141129104444
Gaia: 7119da7a86cd803840678ca3a6067e5622adc481
Gecko: 756000f8f25c
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ba93c0eb3cf7&tochange=756000f8f25c

Caused by Bug 1097941.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Broken by bug 1097941 - Benoit can you please take a look.
Flags: needinfo?(jmercado) → needinfo?(bgirard)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Assignee: nobody → bgirard
blocking-b2g: 2.2? → 2.2+
Alright well the layer tree sent to the compositor is invalid.
Duplicate of this bug: 1106641
Depends on: 1112332
This reproduces on Settings App as well.  (Search, Homescreen, Notifications...)

See video: http://youtu.be/zl0KyKBRtw4
Issue can be seen when opening an email from inbox in Email app as well. On Flame 2.2.
I'm waiting for inbound to land bug 1112332.
Flags: needinfo?(bgirard)
Status: NEW → ASSIGNED
This appears to be a culling issue, not a paint heuristics problem.
Depends on: 1085223
No longer depends on: 1112332
This appears to be fixed on the latest nightly, guessing it was fixed by bug 1113435 if it's culling.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1113435
You need to log in before you can comment on or make changes to this bug.