Going into landscape mode in task manager & tab view distorts previews

RESOLVED DUPLICATE of bug 1118390

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1118390
4 years ago
4 years ago

People

(Reporter: RJ, Assigned: sfoster)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected)

Details

(Whiteboard: [2.2-flame-reduced-run][systemsfe], 2x-uxnom, ux-most-wanted-nov2014, URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8531783 [details]
logcat_20141203_1647.txt

Description:
in landscape mode window previews break in show windows view in browser 


Repro Steps:
1) Update a Flame to 20141203040207
2) Launch a page or two in browser 
3) Tap the menu button > tap show windows 
4) Move phone into landscape mode 


Actual:
Broken previews 


Expected:
non broken landscape previews 

Environmental Variables:
Device: Flame 2.2
Build ID: 20141203040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0



Repro frequency:100%
See attached:logcat, video clip:https://www.youtube.com/watch?v=wUhQRAHwbno&feature=youtu.be
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
issue was not implemented in  2.1 flame
Cannot go landscape in show windows view 
Flame 2.1 

Device: Flame 2.1 (319mb)(KitKat)(Full Flash)
Build ID: 20141203001205
Gaia: dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko: ebce587d2194
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Not nominating to block on this. The user can see the name of the website page, and the page opens properly when selected.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
blocking-b2g: 2.2? → 2.2+
Whiteboard: [2.2-flame-reduced-run] → [2.2-flame-reduced-run][systemsfe]
Whiteboard: [2.2-flame-reduced-run][systemsfe] → [2.2-flame-reduced-run][systemsfe], 2x-uxnom, ux-most-wanted-nov2014
Component: Gaia::Browser → Gaia::System::Window Mgmt
Sam, will you take a look?
Assignee: nobody → sfoster
(Assignee)

Comment 4

4 years ago
To clarify here, the screenshots show up, but they are portrait and get squished to fit the landscape shaped card. This is probably a dupe of bug 1054949, but I'll leave it open in case the browser window case needs different or special treatment
Blocks: 1111795
We are removing the landscape mode in 2.2
blocking-b2g: 2.2+ → ---
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1120858
(Assignee)

Updated

4 years ago
Summary: [Browser]Going into landscape mode in show windows break window previews → Going into landscape mode in task manager & tab view distorts previews
(Assignee)

Comment 7

4 years ago
We're locking task-manager/card view orientation in bug 1118390, which removes the possibility of screenshot distortion caused by the landscape layout
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118390
You need to log in before you can comment on or make changes to this bug.