Closed Bug 1108132 Opened 7 years ago Closed 2 years ago

Optionally wrap long lines in the debugger

Categories

(DevTools :: Debugger, defect, P3)

32 Branch
x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: peter.kehl, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Debug an .xul or similar in Browser ToolBox (former Browser Debugger). Have lines that are longer than the source code part of the debugger.


Actual results:

The source code is not wrapped, so you have to scroll to the right and back.


Expected results:

Wrap such lines (ideally: dynamically, i.e. wrap at white space only, do not split words). Even better: have an option to turn wrapping on/off.

This would be useful regardless of what source code line length Mozilla or anyone deems a 'standard'. I.e. you could have a line of eighty characters or less, but it wouldn't fit in the source code area, because of e.g. a small screen, a need to see wide stack trace or wide listing of variables/watches etc.
Component: Untriaged → Developer Tools
Component: Developer Tools → Developer Tools: Debugger
I agree this would be useful to have, especially since we want to evolve the debugger towards become more editor like in the future.
Blocks: dbg-frontend
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Browser ToolBox (Debugger) should [have an option to] wrap long lines → Optionally wrap long lines in the debugger
Easy horizontal scrolling with <shift>+mousewheel like proposed in Bug 1263105 would really help here.
Priority: -- → P3
Product: Firefox → DevTools

did we recently add support for a pref?

Flags: needinfo?(dwalsh)

Yes, this is currently available via the devtools.debugger.ui.editor-wrapping

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dwalsh)
Resolution: --- → FIXED
Blocks: 1565711
Blocks: 1565713
No longer blocks: 1565711
No longer blocks: 1565713
You need to log in before you can comment on or make changes to this bug.