Closed Bug 1109155 Opened 7 years ago Closed 7 years ago

[7" Tablet] Gridview doesn't show the last row completely on portrait

Categories

(Firefox for Android Graveyard :: General, defect, P1)

All
Android
defect

Tracking

(firefox36 fixed, firefox37 verified, fennec36+)

VERIFIED FIXED
Firefox 37
Tracking Status
firefox36 --- fixed
firefox37 --- verified
fennec 36+ ---

People

(Reporter: u421692, Assigned: mhaigh)

References

Details

Attachments

(4 files, 1 obsolete file)

Devices:
Samsung Galaxy Tab 2 (Android 4.2.2) ; Nexus 7 (Android 5.0.1)

Steps:
1. Open more tabs open than will fit on a single screen

Actual result:
Gridview doesn't show the last row completely on portrait

Note: It's basically the same issue as in bug 1100317, more padding is needed.
Priority: -- → P1
tracking-fennec: --- → ?
I suspect this is regression from bug 1098433. Taking.
Assignee: nobody → lucasr.at.mozilla
This may not be a regression and may just be bug 1104133 - see bug 1091587 for some of my testing/diagnosis attempts.

However, I was using strange layout params so it's possible I just screwed up my testing attempts.
Assignee: lucasr.at.mozilla → nobody
Assignee: nobody → mhaigh
Status: NEW → ASSIGNED
tracking-fennec: ? → 36+
Summary: [7' Tablet] Gridview doesn't show the last row completely on portrait → [7" Tablet] Gridview doesn't show the last row completely on portrait
The GridView seems to have an issue in determining it's own height when we use padding with ClipToPadding set to false.  The top padding seems to push the content down without the total height of the gridview increasing to accommodate, hence we have to make an allowance for that when setting the bottom padding.
Attachment #8544035 - Flags: feedback?(mark.finkle)
Comment on attachment 8544035 [details] [diff] [review]
Gridview doesnt show the last row completely on portrait

This might be caused by some bug in GridView that doesn't compensate for the width of the selection highlight. I guess we need to compensate for it manually.
Attachment #8544035 - Flags: feedback?(mark.finkle) → feedback+
Comment on attachment 8544035 [details] [diff] [review]
Gridview doesnt show the last row completely on portrait

Moving to r+
Attachment #8544035 - Flags: feedback+ → review+
https://hg.mozilla.org/mozilla-central/rev/07f515f6fb63
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Verified as fixed on latest Nightly on Nexus 7 (Android 5.0.1)
Status: RESOLVED → VERIFIED
Request uplift to 36 (beta), please.
Flags: needinfo?(mhaigh)
mcomella: my beta build is broken - any chance I can get you to sanity check this for uplift to beta for me?
Flags: needinfo?(mhaigh) → needinfo?(michael.l.comella)
(In reply to Martyn Haigh (:mhaigh) from comment #10)
> mcomella: my beta build is broken

Also broken.
Flags: needinfo?(michael.l.comella) → needinfo?(mhaigh)
Approval Request Comment
[Feature/regressing bug #]:
Last row of the tabs in the new tablet code isn't shown completely

[User impact if declined]:
Users will not be able to see the bottom of the last line of tabs in the new tablet grid view when there are enough tabs to fill the screen. 

[Describe test coverage new/current, TreeHerder]:
Has been working on 37 for a few weeks.

[Risks and why]: 
Minimal risk - we only change the padding in this patch so the only possibility is that the padding is still incorrect.

[String/UUID change made/needed]:
None
Attachment #8556531 - Attachment is obsolete: true
Flags: needinfo?(mhaigh)
Attachment #8557979 - Flags: approval-mozilla-beta?
Attachment #8557979 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attached image last row behavior.png
Tested with:
Device: Nexus 7 (Android 5.0.1)
Build: Firefox for Android 36 Beta 6
I opened 3 x 4 tabs to fit the screen.
On 36 Beta 6, in portrait mode, to reveal the last row completely you have to scroll. A space is displayed between tabs and the bottom of the screen
On 38 latest Nightly and Aurora, in portrait mode, you do not have to scroll to reveal the last row.
Shouldn't the behavior be consistent?
Verified as fixed in Firefox 37 Beta 1;
Device: Google Nexus 7 (Android 5.0.2).
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.