Create a new test case for the switching to camera from gallery and back

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: njpark, Assigned: njpark)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

5 years ago
This bug is to automate https://moztrap.mozilla.org/manage/case/3620/ where it tests the app switching from camera app to gallery app
Assignee

Updated

5 years ago
Assignee: nobody → npark
Whiteboard: fxosqa-auto-s4 → fxosqa-auto-s5
Assignee

Updated

5 years ago
QA Whiteboard: fxosqa-auto-s6
Whiteboard: fxosqa-auto-s5
Assignee

Updated

5 years ago
Summary: Create a new test case for the switching to camera from gallery → Create a new test case for the switching to camera from gallery and back
Assignee

Comment 1

5 years ago
This script tests the app switching between gallery and camera.  While writing this test, I realized tests/endurance/test_endurance_gallery_camera.py is obsolete (and won't pass).  Should we trim these test cases?
Attachment #8536799 - Flags: review?(martijn.martijn)
Attachment #8536799 - Flags: review?(florin.strugariu)
I don't think we own the endurance tests--think that's Rob Wood's. Rob said something about those being deprecated at this point. I've NI'd him for more details.
Flags: needinfo?(rwood)
Comment on attachment 8536799 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26796

Some remarks and questions I added in the pull request.
I'm not saying I'm necessarily right with these questions, but if you could answer them (or Florin), then I'm fine.
Attachment #8536799 - Flags: review?(martijn.martijn) → review-
Comment on attachment 8536799 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26796

some small nit's
Attachment #8536799 - Flags: review?(florin.strugariu) → review-
Assignee

Comment 5

5 years ago
Comments are incorporated
Attachment #8536799 - Attachment is obsolete: true
Attachment #8537250 - Flags: review?(martijn.martijn)
Yes that is correct, at this point the endurance tests are not being maintained or expanded.

IMO to have any real value, they would need to be overhauled drastically. i.e. Besides updating to work with the latest gaia changes, the test framework should use the get_about_memory tool to grab memory info for each app (instead of just b2g-ps and using the RSS value for the main b2g process), re-evaluate the usefulness of each test, force garbage collection first, etc. So this would be potentially be a large project. Also, there may be other tests already running that provide more value, even if these tests were overhauled (i.e. the *_memory tests that are posting to DataZilla).

Most of the endurance tests were developed from existing functional gaia-ui tests, which are still running.
Flags: needinfo?(rwood)
Assignee

Updated

5 years ago
Attachment #8537250 - Flags: review?(florin.strugariu)
Assignee

Comment 8

5 years ago
(In reply to Martijn Wargers [:mwargers] (QA) from comment #3)
> Comment on attachment 8536799 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26796
> 
> Some remarks and questions I added in the pull request.
> I'm not saying I'm necessarily right with these questions, but if you could
> answer them (or Florin), then I'm fine.

All of your comments are incorporated in the latest fix
Assignee

Updated

5 years ago
Blocks: 1112227
Comment on attachment 8537250 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26796

Two small nits that need to be fixed (found with pep8, you should use that too on files you change), but it looks great to me.
I run it locally 10 times without failures.
Attachment #8537250 - Flags: review?(martijn.martijn) → review+
Comment on attachment 8537250 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26796

Let's fix those 2 PEP8 nits
Attachment #8537250 - Flags: review?(florin.strugariu) → review+
Duplicate of this bug: 1110099
Assignee

Comment 12

5 years ago
Will squash commits and let you know once the try results are posted
Assignee

Updated

5 years ago
QA Whiteboard: fxosqa-auto-s6 → [fxosqa-auto-s6]
Assignee

Updated

5 years ago
Blocks: 1112758
Assignee

Updated

5 years ago
No longer blocks: 1112758
Assignee

Updated

5 years ago
Blocks: 1112824
Assignee

Updated

5 years ago
No longer blocks: 1112824
No-Jun it looks like you have some issues with the commit :(

https://github.com/mozilla-b2g/gaia/pull/26796/commits

Github says:  viorelaioia authored 3 days ago npark-mozilla committed 22 hours ago 

Is it OK to merge it like this?

The code is looks good and ready to merge
Flags: needinfo?(gmealer)
Flags: needinfo?(dave.hunt)
Assignee

Comment 15

5 years ago
i think it happened when i fetched the master and squashed commits, it took the author name of first diff of new master if I can guess correctly.  But code itself is okay.  If this is an issue and you need me to create a new branch and manually copy over the code changes, let me know.
After IRC talk merged: https://github.com/mozilla-b2g/gaia/commit/09618e086b2723ab5fa3b9af9da04c4a2fccb497
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gmealer)
Flags: needinfo?(dave.hunt)
Resolution: --- → FIXED
Depends on: 1118338
You need to log in before you can comment on or make changes to this bug.