Bug 1114863 (yoruba-keyboard)

Add Yoruba (yo) keyboard to Firefox OS - multiple branches

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: delphine, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-, feature-b2g:3.0?)

Details

Attachments

(3 attachments)

Request to add Yoruba (yo) locale to Firefox OS
[Blocking Requested - why for this release]:
Requested for 2.0 and onwards. Thus nominating
blocking-b2g: --- → 2.0?
Flags: needinfo?(bbajaj)

Comment 2

4 years ago
[Blocking Requested - why for this release]:

[Triage] Considering current 2.0 timing and the need from partner, nom. to 2.1 (or even 2.2?) instead for consideration.
blocking-b2g: 2.0? → 2.1?
Clearing blocking no, refer to comment in : https://bugzilla.mozilla.org/show_bug.cgi?id=1114866
blocking-b2g: 2.1? → ---
Flags: needinfo?(bbajaj)
Alias: yoruba-keyboard
Adding localizer who might be able to help with keyboard input. thanks!
Flags: needinfo?(soki2ng)
Since no news from localizer, flagging:
* Bruce so he can help drive this forwards
* Peiying so she can plug in Rubric, so they can help with giving feedback and input on this
Flags: needinfo?(pmo)
Flags: needinfo?(bhuang)
+ Devon and Ian, we need expertise and advice from Rubric.
Flags: needinfo?(pmo)
According to Wikipedia, Benin uses a different orthography for Yoruba. Which version are we using across the system? Thanks.
Flags: needinfo?(bhuang) → needinfo?(lebedel.delphine)

Comment 8

4 years ago
Hi All,

According to our Yoruba linguists the Yoruba keyboard is complete. 

Thanks,
Devon
Hi Bruce. Sorry I'm not an expert at this and can't advise here! However, Devon from Rubric is and can advise. 
Devon: in comment 8 you say the keyboard is complete. But there is no keyboard layout in the bug to refer to, or anything else that anyone could review. Can you please give more input into what keyboard for Yoruba is acceptable? thanks
Flags: needinfo?(lebedel.delphine) → needinfo?(devon.bezuidenhout)

Comment 10

4 years ago
I am traveling today so have not spoken to Devon about this; but you could look at the following resources:
http://www.tavultesoft.com/keyboarddownloads/%7BE3D25DA8-5C38-412D-8EA2-B3F818C9059A%7D/SIL%20Unicode%20Keyboard%20Chart%20for%20Africa%20using%20deadkeys.pdf

http://gate2home.com/Yoruba-Keyboard
http://virtualkeyboard.biz/yoruba

Devon are these the keyboards the translator confirmed were OK?

Comment 11

4 years ago

(In reply to ian.henderson from comment #10)
> I am traveling today so have not spoken to Devon about this; but you could
> look at the following resources:
> http://www.tavultesoft.com/keyboarddownloads/%7BE3D25DA8-5C38-412D-8EA2-
> B3F818C9059A%7D/
> SIL%20Unicode%20Keyboard%20Chart%20for%20Africa%20using%20deadkeys.pdf
> 
> http://gate2home.com/Yoruba-Keyboard
> http://virtualkeyboard.biz/yoruba
> 
> Devon are these the keyboards the translator confirmed were OK?

Hello Ian & others,

The translator confirmed that the keyboards as per both URL's are complete.
 
Regarding comment 7 we are using the Nigerian version.  The translator confirmed that the orthography for Benin is the same as for Nigeria, except where diacritical marks are not used and sometimes the intonation may be different.
Flags: needinfo?(devon.bezuidenhout)

Comment 12

4 years ago
This keyboard is confirmed complete: http://virtualkeyboard.biz/yoruba
Bruce: I think we have all the information we need here to move on with this. Can you help drive forward please?
Flags: needinfo?(bhuang)
Any updates on this please? 
Blocking 2.1 as per the mana. Please let us know if you need anything else (keyboard layout confirmed on comment 12). thanks
blocking-b2g: --- → 2.1+
I would need someone's help to create a layout spec (just as we have in bug 1114864) to start the implementation.
Assignee: nobody → rlu
Updated spec here: https://drive.google.com/open?id=11K6zvJ4J2P76l8RwYBwKDMSbKtGjXjTpwNj1Gx02Nn0&authuser=0

I had to combine some of the letters since we're not supporting combination keys for the diacritical marks yet, so those keys will be a bit loaded.  We can revisit adding that functionality as a separate feature if needed.
Flags: needinfo?(bhuang)
Created attachment 8605089 [details] [review]
[gaia] RudyLu:keyboard/Bug1114863-yoruba_keyboard > mozilla-b2g:master
Comment on attachment 8605089 [details] [review]
[gaia] RudyLu:keyboard/Bug1114863-yoruba_keyboard > mozilla-b2g:master

The layout is ready.
Tim, could you help review it? 

Arky, not sure if we have Yoruba community to help, but if we do, please give feedback on this.

Thanks.
Attachment #8605089 - Flags: review?(timdream)
Attachment #8605089 - Flags: feedback?(hitmanarky)
Attachment #8605089 - Flags: review?(timdream) → review+
Arky: any update on this please? Nigerian languages are coming up really soon. thanks!
Rudy: can you (or someone else) please get this landed? I don't think we should wait for input from Arky at this point. thanks! :)
Flags: needinfo?(rlu)
Found some possible Yoruba native speakers to review the keyboard layout in comment 18.
Leye, Femi Bayo, Stephen: could you please give your feedback?
Devon: can you also help confirm the layout in comment 18 is acceptable?
thanks
Flags: needinfo?(stevetech20)
Flags: needinfo?(odumuyiwaleye)
Flags: needinfo?(mavel22k)
Flags: needinfo?(devon.bezuidenhout)

Comment 22

4 years ago
Hello Delphine,
Sorry for my delayed response.
How can we give feedback on the keyboard layout in comment 18?
I followed the link but can't see anything to give feedback on.
Flags: needinfo?(odumuyiwaleye)
Sure! So when you click on the "attachment 8605089 [details] [review]" link on comment 18, it brings you to github. There you can see under Rudy's comment box, there is a "Bug 1114863 - Add Yoruba keyboard layout" link (it's in small, in between that comment box and the box where it says "
lightsofapollo commented on May 13"). 
Click on that. It brings you to this page: https://github.com/RudyLu/gaia/commit/443d8c0bea13fe83bec6d02dc95d0865c1e64368
You can cross-check that against https://docs.google.com/spreadsheets/d/11K6zvJ4J2P76l8RwYBwKDMSbKtGjXjTpwNj1Gx02Nn0/edit#gid=799063133
thanks!
Flags: needinfo?(odumuyiwaleye)
let me know if you need more help and we can go over this by email ;)

Comment 25

4 years ago
Thanks for providing more info on the issue. I am currently going through the page and would let you know if I encounter any issue. You could also contact me via email: odumuyiwaleye@yahoo.com.
Flags: needinfo?(odumuyiwaleye)

Comment 26

4 years ago
Created attachment 8632682 [details]
Tonal marks.doc

Hello Delphine,

We received feedback from our Yo translator regarding the Yo keyboard layout. Please find it attached.

Please let me know if you have any questions.

Regards,
Devon
Flags: needinfo?(devon.bezuidenhout) → needinfo?(lebedel.delphine)
Thanks for the feedback Devon. Tim: now that Rudy is gone, do you know who could help create a patch taking into account feedback in comment 26?
Odumuyiwa from Yoruba community could help review it. thanks!
Flags: needinfo?(lebedel.delphine) → needinfo?(timdream)
This is what I am seeing

https://docs.google.com/viewer?url=https://bugzilla.mozilla.org/attachment.cgi?id=8632682

It's unclear what need to be done here. Does this means we should remove the keys highlighted in yellow in the document?
Assignee: left.lu → timdream
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)

Comment 29

4 years ago
Just got this!

I checked the yoruba keys out against the layout and found out that not all alphabets were addressed. Alphabet like 'n' could have little diversification in yoruba language.

Also, there are only three diversification for yoruba alphabet 'A', six for yoruba alphabet 'E', three for yoruba alphabet 'I', six for yoruba alphabet 'O', and three for yoruba alphabet 'U'(assuming case insensitivity).

I wish i understood how to edit the code on 'github'. If editing is possible, someone should please let me in on that.

Thanks
(In reply to Stephen from comment #29)
> Just got this!
> 
> I checked the yoruba keys out against the layout and found out that not all
> alphabets were addressed. Alphabet like 'n' could have little
> diversification in yoruba language.
> 
> Also, there are only three diversification for yoruba alphabet 'A', six for
> yoruba alphabet 'E', three for yoruba alphabet 'I', six for yoruba alphabet
> 'O', and three for yoruba alphabet 'U'(assuming case insensitivity).
> 
> I wish i understood how to edit the code on 'github'. If editing is
> possible, someone should please let me in on that.
> 
> Thanks

Hi Stephen, thanks for the feedback!!

If you want, you could definitely learn how to submit code through GitHub, but just to speed up the pace, it would be great if you could simply copy this file, edit it, and upload to this bug by using the "Add attachment" button on top.

https://github.com/RudyLu/gaia/blob/keyboard/Bug1114863-yoruba_keyboard/apps/keyboard/js/layouts/yo.js

Would that be something you would be able to help? It would be better if you do that so I don't put any wrong characters there. Thanks.
[Blocking Requested - why for this release]:

Hi Vance,
Do we still need this for 2.1/2.1S? Should we make this 2.5+?
Thanks!
blocking-b2g: 2.1+ → 2.5?
Flags: needinfo?(vchen)
I don't think this one is needed for 2.1/2.1S, let make it 2.5+ 

Thanks
Flags: needinfo?(vchen)
Stephen, could you respond to comment 30?

Comment 34

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to queue) from comment #33)
> Stephen, could you respond to comment 30?

Yeah, comment 30 helps except for the fact that i'm not sure about where the "Add attachment button" is because I didn't see any
Flags: needinfo?(stevetech20)
(In reply to Stephen from comment #34)
> (In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to
> queue) from comment #33)
> > Stephen, could you respond to comment 30?
> 
> Yeah, comment 30 helps except for the fact that i'm not sure about where the
> "Add attachment button" is because I didn't see any

The is a link on this page, on Bugzilla (not GitHub) labeled with "Add an attachment" in which you could upload your updated |yo.js| on to here. If you could do that that would save us some time go and forth on fixing Rudy's incomplete patch.

Thanks.
Flags: needinfo?(stevetech20)

Comment 36

4 years ago
Created attachment 8640399 [details]
yo.js

The attached file, yo.js,contains the reviewed yoruba alphabets.

Hope it helps!
Flags: needinfo?(stevetech20)
Stephen,

I can't take your changes because you have deleted too many regular alphabets -- we need them so the Yoruba keyboard can be occasionally used when code switch to English.

Also, it seems your editor mess up with the encoding. I am seeing question marks following many characters and I suspect they are diacritics. Please set your encoder to UTF-8 when opening and saving the file. Thanks.
Flags: needinfo?(stevetech20)

Comment 38

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to queue) from comment #37)
> Stephen,
> 
> I can't take your changes because you have deleted too many regular
> alphabets -- we need them so the Yoruba keyboard can be occasionally used
> when code switch to English.
> 
> Also, it seems your editor mess up with the encoding. I am seeing question
> marks following many characters and I suspect they are diacritics. Please
> set your encoder to UTF-8 when opening and saving the file. Thanks.

By "you have deleted too many regular alphabets", do you mean regular alphabets in English or regular alphabets in Yoruba?

Regard the encoder, I'll work on that asap
Flags: needinfo?(stevetech20)
(In reply to Stephen from comment #38)
> (In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to
> queue) from comment #37)
> > Stephen,
> > 
> > I can't take your changes because you have deleted too many regular
> > alphabets -- we need them so the Yoruba keyboard can be occasionally used
> > when code switch to English.
> > 
> > Also, it seems your editor mess up with the encoding. I am seeing question
> > marks following many characters and I suspect they are diacritics. Please
> > set your encoder to UTF-8 when opening and saving the file. Thanks.
> 
> By "you have deleted too many regular alphabets", do you mean regular
> alphabets in English or regular alphabets in Yoruba?
> 

Regular alphabets in English, notably, I don't see Q, C, X ...

I don't know the alphabet set Yoruba is using, but I suppose a Yoruba keyboard obviously should contain these keys.

> Regard the encoder, I'll work on that asap

Thanks!
Flags: needinfo?(stevetech20)

Comment 40

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to queue) from comment #39)
> (In reply to Stephen from comment #38)
> > (In reply to Tim Guan-tin Chien [:timdream] (slow response; please ni? to
> > queue) from comment #37)
> > > Stephen,
> > > 
> > > I can't take your changes because you have deleted too many regular
> > > alphabets -- we need them so the Yoruba keyboard can be occasionally used
> > > when code switch to English.
> > > 
> > > Also, it seems your editor mess up with the encoding. I am seeing question
> > > marks following many characters and I suspect they are diacritics. Please
> > > set your encoder to UTF-8 when opening and saving the file. Thanks.
> > 
> > By "you have deleted too many regular alphabets", do you mean regular
> > alphabets in English or regular alphabets in Yoruba?
> > 
> 
> Regular alphabets in English, notably, I don't see Q, C, X ...
> 
> I don't know the alphabet set Yoruba is using, but I suppose a Yoruba
> keyboard obviously should contain these keys.
> 
> > Regard the encoder, I'll work on that asap
> 
> Thanks!

Oh!
Some English  alphabets actually, are not in the Yoruba alphabets sets but I'll include them in case there is a switch to Enhlish.

Thanks
Flags: needinfo?(stevetech20)

Comment 41

4 years ago
Wilfred, is this a 2.5 requirement?
Flags: needinfo?(wmathanaraj)
(In reply to Stephen from comment #40)
> Oh!
> Some English  alphabets actually, are not in the Yoruba alphabets sets but
> I'll include them in case there is a switch to Enhlish.
> 
> Thanks

Stephen, any update?
Flags: needinfo?(stevetech20)
Triage conclusion: this isn't a blocker. It should be a feature.
blocking-b2g: 2.5? → -
feature-b2g: --- → 3.0?
Deassigning since there is no action item for me here.
Assignee: timdream → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(left.lu)
Flags: needinfo?(wmathanaraj) → needinfo?(aaime)

Comment 45

3 years ago
Deassigning since there is no action item for me here.
Flags: needinfo?(stevetech20)
Flags: needinfo?(soki2ng)
Flags: needinfo?(mavel22k)
Flags: needinfo?(aaime)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.