Closed Bug 1115180 Opened 5 years ago Closed 5 years ago

Get test_cost_control_data_alert_mobile.py re-enabled

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: martijn.martijn, Assigned: martijn.martijn)

References

Details

Attachments

(5 files, 2 obsolete files)

This is a follow-up from bug 1097605.
I got test_cost_control_data_alert_mobile.py working locally, but on Jenkins, it is timing out in connect_to_cell_data.

There might be something wrong with the credentials in the lab devices, I don't know.
Anyone of you have an idea what needs to be done to get this enabled?

This is working locally for me (although there might be an intermittent failure lurking in the test, need to investigate that).
Assignee: nobody → martijn.martijn
Flags: needinfo?(jlorenzo)
Flags: needinfo?(florin.strugariu)
Talked to njpark on irc, only a few of the devices in the lab have data connection enabled.
So I should try this out with the manifest.ini file.
Flags: needinfo?(jlorenzo)
Flags: needinfo?(florin.strugariu)
Ok, this was the intermittent failure I was sometimes getting:
seconds


Traceback (most recent call last):
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
    testMethod()
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/tests/functional/cost_control/test_cost_control_data_alert_mobile.py", line 46, in test_cost_control_data_alert_mobile
    browser = search.go_to_url('http://www.mozilla.org/')
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/apps/search/app.py", line 29, in go_to_url
    return search_panel.go_to_url(url)
  File "/Users/mwargers/B2G/gaia_clean/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/search_panel.py", line 60, in go_to_url
    Wait(self.marionette).until(lambda m: self.keyboard.is_keyboard_displayed)
  File "/Users/mwargers/.virtualenvs/gaia-py-latest/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 135709ms

The Browser app then fails to show up.
With this patch, I haven't seen the failure mentioned in comment 3, yet.
Also, this makes it wait a little longer for the page to load (when you have a very slow 2G connection).
(In reply to Martijn Wargers [:mwargers] (QA) from comment #4)
> With this patch, I haven't seen the failure mentioned in comment 3, yet.

Although, I can't really see why this would work.
(In reply to Martijn Wargers [:mwargers] (QA) from comment #2)
> Talked to njpark on irc, only a few of the devices in the lab have data
> connection enabled.
> So I should try this out with the manifest.ini file.

Did this now with: https://github.com/mozilla-b2g/gaia/pull/27015
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/519/
Sorry, did something wrong in the previous run, here a new one:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/520/
I still get timeouts in connect_to_cell_data.

I'm out of ideas on what to do. How does this work for the other tests that use cell data? (like test_browser_cell_data.py for instance)
Flags: needinfo?(jlorenzo)
Flags: needinfo?(florin.strugariu)
This issue is due to bug 1114955. We can't activate cell data on master for a couple of days.
Depends on: 1114955
Flags: needinfo?(jlorenzo)
QA Whiteboard: [fxosqa-auto-s7][fxosqa-auto-points=4]
Flags: in-qa-testsuite?(martijn.martijn)
Flags: needinfo?(florin.strugariu)
Depends on: 1118049
Bug 1114955 is fixed, but now there is bug 1118049 that prevents this test from being re-enabled.
Plussing this since it's currently being worked on.
Flags: in-qa-testsuite?(martijn.martijn) → in-qa-testsuite+
Resetting back to in-qa-testsuite? per decision this morning. Note that this is still not needed when adding the QA Whiteboard flags, which are generally more expressive.
Flags: in-qa-testsuite+ → in-qa-testsuite?
Bug 1118049 is fixed, I think we can re-enable test_cost_control_data_alert_mobile.py.
Martin, are you working on this? Can you update the PR (if needed), in order to get this test enabled? Thanks!
Flags: needinfo?(martijn.martijn)
Attached file cost_control (obsolete) —
Yes, this can be re-enabled, I think. It works locally fine here.
Attachment #8541312 - Attachment is obsolete: true
Flags: needinfo?(martijn.martijn)
Attachment #8552527 - Flags: review?(viorela.ioia)
Comment on attachment 8552527 [details] [review]
cost_control

The patch looks good, but there are merge conflicts. Can you fix them and ask me for review again? Thanks!
Attachment #8552527 - Flags: review?(viorela.ioia) → review-
Attached file cost_control2
Ok, updated patch, this should be mergeable.
Attachment #8552527 - Attachment is obsolete: true
Attachment #8553090 - Flags: review?(viorela.ioia)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Teri, I noticed this was disabled in your automation report:
Disabled] test_cost_control_data_alert_mobile.py - Bug 1061698 - Need ability to work in the shadow root/shadow DOM

This is the bug that enabled it on master, this should be possible to backport to 2.2.
Flags: needinfo?(twen)
Got the info from Cynthia, that we need to fix the bug 1141447 or we will fail on test_cost_control_data_alert_mobile.py
Depends on: 1141447
Attachment #8582914 - Flags: review?(echang)
Comment on attachment 8582914 [details] [review]
[gaia] teriwen:gaia-costcontrol > mozilla-b2g:v2.2

Hi Viorela, please help review this on v2.2.
Flags: needinfo?(twen)
Attachment #8582914 - Flags: review?(echang) → review?(viorelaioia)
Comment on attachment 8582914 [details] [review]
[gaia] teriwen:gaia-costcontrol > mozilla-b2g:v2.2

Ok, bug 1141447 landed on v2.2, so it's only a matter of turning on this test then, right? r+
Attachment #8582914 - Flags: review?(viorelaioia) → review+
For some reason, the taskcluster seems to be running lots of tests, and it fails a couple of times, Martijn, have you seen anything like that?
https://github.com/mozilla-b2g/gaia/pull/29128
https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=443d687446cc52cbcda19e90e6ef8c17f0002aac
Flags: needinfo?(martijn.martijn)
Afaik, taskcluster is currently unreliable (because of bug 1147176?).
I hit this problem myself in bug 1146877 and John in bug 1139083.
Flags: needinfo?(martijn.martijn)
Blocks: 1155747
It seems like Treeherder try for v2.2 is green now, so the v2.2 pull request can be checked in now?
Flags: needinfo?(echang)
Hi Edward, Please help with this, thank you.
Flags: needinfo?(echang) → needinfo?(edchen)
Flags: needinfo?(edchen)
Attachment #8606823 - Flags: review?(martijn.martijn)
Comment on attachment 8606823 [details] [review]
Re-enable test_cost_control_data_alert_mobile.py

https://github.com/mozilla-b2g/gaia/commit/5212c658a651e04d6d84dfc1bce06b499c0d0d96
Attachment #8606823 - Flags: review?(martijn.martijn) → review+
Flags: in-qa-testsuite? → in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.