Closed Bug 1118284 Opened 7 years ago Closed 7 years ago

Water surface from WebGL Water animation not displayed correctly.

Categories

(Core :: Canvas: WebGL, defect)

35 Branch
All
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1125445
Tracking Status
firefox35 --- unaffected
firefox36 --- affected
firefox37 --- affected

People

(Reporter: VarCat, Unassigned)

References

Details

(Keywords: regression, Whiteboard: gfx-noted)

Attachments

(1 file)

Environment:

FF 35RC
Build Id:20150105205925
OS: Win 8 x32, Win 7 x64

STR:

1. Go to http://madebyevan.com/webgl-water/

Issue:
The surface of the water is not correctly displayed.

Regression Range:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1735ff2bb23e&tochange=b85c260821ab

First bad = 2014-10-03
I'll guess bug 1048108, but I'll try to narrow down the regression range first.
Whiteboard: gfx-noted
Does this happen on nightly as well?
Flags: needinfo?(catalin.varga)
Error: Rendering to floating-point textures is required but not supported - is displayed when using FF 37 Nightly latest build
Flags: needinfo?(catalin.varga)
The animation is not working at all on Nightly 37.
(In reply to Catalin Varga [QA][:VarCat] from comment #3)
> Error: Rendering to floating-point textures is required but not supported -
> is displayed when using FF 37 Nightly latest build

Yes, I get the same thing - even though IE runs just fine.
Flags: needinfo?(jgilbert)
Dan may have fresher thoughts about this.
Flags: needinfo?(jgilbert) → needinfo?(dglastonbury)
Regarding:  Error: Rendering to floating-point textures is required but not supported
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d909e1fe5d13&tochange=b459d10124a8

Triggered by: Bug 1102667
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115816
The 2 bugs are different they even have different regression windows.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Flags: needinfo?(dglastonbury)
So, there are a couple of issues here and a bit of a chicken and egg problem.

The history of rendering to floating point textures in WebGL is a bit of a mess. Historically, enabling OES_texture_float has also enabled rendering to textures. This is incorrect.

To fix this, WEBGL_color_buffer_float extension was added; check OES_texture_float allows using floating point texture to be read, WEBGL_color_buffer_float allows using floating point texture to be written.

There's two solutions required:
1. Working with the demo author to get their code to be correct. ie. Check for the correct extension. I have a mock up of changes to get the demo working on my local machine in FF and Chrome. (Attached as water.zip)
2. The extensions WEBGL_color_buffer_float and EXT_color_buffer_half_float are draft and hidden behind webgl.enable-draft-extensions pref, which is false by default. Jeff has recently landed removing the draft status of the extensions, so in nightly builds, the extensions appear without the need to enable webgl.enable-draft-extensions.
Right. I've also requested uplift for color_buffer_float, so aurora36 should have them.

35 (currently beta) and before will have the old implicitly-activated functionality.
So, it worked before because we were letting OES_texture_float enable rendering to floating point texture?

Once we do all of our changes, we still need the author to make the changes, right?
Dupe of bug 1081497, no?
(In reply to Loic from comment #14)
> Dupe of bug 1081497, no?

This demo has been fixed by bug 1125445.
Catalin, could you test it's fully fixed on your side with the latest Nightly and dupe it, please?
Flags: needinfo?(catalin.varga)
I checked the animation:

FF 38
Build Id:20150129030202

and it looks fixed i'll mark it as dupe of 1125445 .
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(catalin.varga)
Resolution: --- → DUPLICATE
Duplicate of bug: 1125445
You need to log in before you can comment on or make changes to this bug.