In-content Preferences, Text color of some text-link is not consistent. And it is difficult to discover them because no underline and low contrast.

VERIFIED FIXED in Firefox 38

Status

()

Firefox
Preferences
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: jaws)

Tracking

Trunk
Firefox 38
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8546139 [details]
screenshot

See attached screenshot.

I notice the problem when I test another Bug 1119441.

Steps to reproduce:
1. in-content preferences

Actual Results:
In-content Preferences, 
Text color of some text-link is not consistent.  
And it is difficult to discover them because no underline and low contrast.

Expected Results:
Text color of some text-link should be consistent. 
It should be easy discoverable (Ex. provide underline or more high-contrast.)
(Reporter)

Comment 1

3 years ago
And hover effect is not consistent
Looks like we can remove the rules from:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/preferences/preferences.css#89
http://mxr.mozilla.org/mozilla-central/source/browser/themes/linux/preferences/preferences.css#93
http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/preferences/preferences.css#191

for .inline-link.

As for the contrast and the underline:
Philipp, are you OK with us adding text-decoration:underline; to all links that share this common.css styling across the browser (http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/shared/in-content/common.inc.css#392) and also using a darker color (#00539F?) ?
Flags: needinfo?(philipp)
I talked with Stephen over IRC and got the following answers:

We should add the text-decoration:underline on link hover, and use #178ce5 as the darker color.
Flags: needinfo?(philipp)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> Looks like we can remove the rules from:

On further note, we shouldn't remove those lines as they were just added in bug 1106792. We should work with those lines or around them.
Created attachment 8552794 [details] [diff] [review]
Patch

The presence of the namespace decreased the specificity of the selector to the point where the windowed preferences' styles were overriding.

I never thought a namespace would decrease the specificity. I tested this with the windowed preferences and it doesn't regress there.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8552794 - Flags: review?(gijskruitbosch+bugs)

Comment 6

3 years ago
Comment on attachment 8552794 [details] [diff] [review]
Patch

Review of attachment 8552794 [details] [diff] [review]:
-----------------------------------------------------------------

I'll buy that for a dollar. Thanks!
Attachment #8552794 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
renamed 1119472 -> 1119472.patch
applying 1119472.patch
patching file toolkit/themes/shared/in-content/common.inc.css
Hunk #1 FAILED at 382
1 out of 1 hunks FAILED -- saving rejects to file toolkit/themes/shared/in-content/common.inc.css.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir
errors during apply, please fix and refresh 1119472.patch

jaws: could you take a look at this ? Thanks!
Flags: needinfo?(jaws)
Keywords: checkin-needed
This patch was based off of a patch that hadn't landed yet, but has landed now. I just pulled latest and applied this patch and it applied with no failures. Can you please try again?
Flags: needinfo?(jaws)
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: x86_64 → All
Created attachment 8554641 [details] [diff] [review]
Patch for checkin
Attachment #8552794 - Attachment is obsolete: true
Attachment #8554641 - Flags: review+
https://hg.mozilla.org/integration/fx-team/rev/3ab0e70121c9
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/3ab0e70121c9
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
QA Contact: camelia.badau
Verified fixed on Windows 7 64bit and Ubuntu 13.10 32bit using Firefox 38 Beta 6 (buildID: 20150420134330).

I still see the issue on Mac OSX 10.9.5 using Firefox 38 Beta 6 (buildID: 20150420134330): text color of some text-link is not consistent (see "Privacy" tab -> text-link from "History" section). Should I reopen this bug?
Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)

Comment 13

3 years ago
This was fixed on Windows, though, and remains fixed on beta. I'd prefer a new bug for the OSX issue, which is also less severe than the windows issue in the screenshot here.
Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(camelia.badau)
(In reply to :Gijs Kruitbosch (mostly away until May 5th) from comment #13)
> This was fixed on Windows, though, and remains fixed on beta. I'd prefer a
> new bug for the OSX issue, which is also less severe than the windows issue
> in the screenshot here.

I filled bug 1159707 for the OSX issue. 

Marking this bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
Flags: needinfo?(camelia.badau)
You need to log in before you can comment on or make changes to this bug.