Closed Bug 1121316 Opened 5 years ago Closed 5 years ago

[System2][Screen cleanup] Move ActionMenu into SystemDialog or AppWindow

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
2.2 S12 (15may)

People

(Reporter: alive, Assigned: apastor)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

ActionMenu is an orphan module now - it is having its own resize / home policy. The problem is we want to deprecate any #screen.locked rule consumer and it is one of them. The better way to maintain the sizing is having a manager to control the size in javascript instead of touching screen element.
Assignee: nobody → apastor
Comment on attachment 8598092 [details] [review]
[gaia] albertopq:1121316-action-menu-refactor > mozilla-b2g:master

Still tests to be added, but Alive, could you please take a first look to see if I understood what you meant correctly? Thanks!
Attachment #8598092 - Flags: feedback?(alive)
Whiteboard: [systemsfe]
Comment on attachment 8598092 [details] [review]
[gaia] albertopq:1121316-action-menu-refactor > mozilla-b2g:master

WOW, thanks for doing this! I left some comments but basically it's nice.

About the naming: I think if we have ActionMenu(which is not a dialog), we should rename SystemDialogManager to SystemUserInterfaceManager or whatever afterwards since it's not only managing dialogs but also menus.

Alos, we could remove the ActionMenu hijack in HierarchyManager if it's now managed by SystemDialogManager which is already under HierarchyManager.

One thing I am worry about is what SystemDialog and ActionMenu conflict - for example, is there a case that SIMPINDialog and ActivityMenu will show at the same time..? But we could refine this later, I guess.
Attachment #8598092 - Flags: feedback?(alive) → feedback+
Comment on attachment 8598092 [details] [review]
[gaia] albertopq:1121316-action-menu-refactor > mozilla-b2g:master

Fixed the tests and the naming comments you left.

I tried the case you were mentioning (SIM dialog when an activity action menu is visible) and the SIM is shown in top of it, so it should work fine.

Thanks!
Attachment #8598092 - Flags: review?(alive)
Comment on attachment 8598092 [details] [review]
[gaia] albertopq:1121316-action-menu-refactor > mozilla-b2g:master

Well done, thanks for the work!
Attachment #8598092 - Flags: review?(alive) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Depends on: 1161943
Blocks: 1163524
Blocks: 1163953
Depends on: 1165853
Target Milestone: --- → 2.2 S12 (15may)
Depends on: 1221377
You need to log in before you can comment on or make changes to this bug.