Closed Bug 1121907 Opened 5 years ago Closed 5 years ago

[flatfish] Fix build break by Werrors in flatfish

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1123072

People

(Reporter: dliang, Assigned: _AtilA_)

References

Details

Attachments

(2 files, 1 obsolete file)

There are some build breaks by enable Werror in flatfish, create this bug for tracking.
Attachment is the patch to avoid build break by Werror
See Also: → 1121869
See Also: → 1121900
Hi Danny,
I started to work in bug 1122932 because of the build errors. Some of them can be fixed by just upgrading the toolchain to a newer one, and other would need a little more work. My plan is ti migrate the toolchain first and fix the remaining errors later.

If you are ok with it, I can take this bug too.
(In reply to Juan Gomez [:_AtilA_] (UTC+0) from comment #2)
> Hi Danny,
> I started to work in bug 1122932 because of the build errors. Some of them
> can be fixed by just upgrading the toolchain to a newer one, and other would
> need a little more work. My plan is ti migrate the toolchain first and fix
> the remaining errors later.
> 
> If you are ok with it, I can take this bug too.

Sounds great, I also suspect some build errors are caused by toolchain. I am happy if you can help on this. Thank you very much.
Comment on attachment 8550956 [details] [diff] [review]
0001-Bug-1121907-Fix-build-errors-with-warnings-as-errors.patch

Review of attachment 8550956 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/bluetooth/bluedroid/BluetoothHALHelpers.h
@@ +201,1 @@
>      CONVERT(BT_PROPERTY_REMOTE_RSSI, PROPERTY_REMOTE_RSSI),

Instead of repeating this twice, please remove the comma from this line, move the #if to the next line and add the comma before the next CONVERT.  Then you can get rid of the #else.
Attachment #8550956 - Flags: review+
Attachment #8551506 - Flags: review?(ehsan) → review+
Assignee: nobody → atilag
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → DUPLICATE
Duplicate of bug: 1123072
You need to log in before you can comment on or make changes to this bug.