[Flame][Browser]The frame of Youtube video can't be displayed, it only have voice or you can't continue to play.

RESOLVED FIXED

Status

()

Core
Audio/Video: Playback
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Lance(leave from Mozilla), Assigned: alfredo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8551176 [details]
logcat_321.txt

[1.Description]:
[Flame][v2.2][Browser]After you back to Youtube video page from share page, the video can't display the frames, it only have voice or you can't continue to play.
Found time:03:21
See attachment:321.mp4 and logcat_321.txt

[2.Testing Steps]: 
1.Launch Browser.
2.Go to Youtube.com.
3.Tap a video to play.
4.Tap the share icon under video, share it to SMS.
5.Then do not save the message, and back to Youtube.

[3.Expected Result]: 
5.After you back to Youtube, the video should pause, and tap play icon the video play normally.

[4.Actual Result]: 
5.The video prompt "Video loading Stopped.". Sometimes, it only have voice, but doesn't have frames.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.035516
FW-Date         Sun Jan 18 03:55:27 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8551178 [details]
321.MP4

Comment 2

3 years ago
Hi, Lance,

Can it be reproduced on the other branches (v2.1 & v2.0)?
Flags: needinfo?(liuke)
(Reporter)

Comment 3

3 years ago
(In reply to William Hsu [:whsu] from comment #2)
> Hi, Lance,
> 
> Can it be reproduced on the other branches (v2.1 & v2.0)?

Hi William,

This bug has been verified to fail on latest Flame 2.0, 2.1 build.

Steps:
1.Launch Browser.
2.Go to Youtube.com.
3.Tap a video to play.
4.Tap the share icon under video, share it to SMS.
5.Then do not save the message, and back to Youtube.

Expected Result: 
5.After you back to Youtube, the video should pause, and tap play icon the video play normally.

Actual Result: 
5.The video prompt "Video loading Stopped.". Sometimes, it only have voice, but doesn't have frames.

Fail rate:3/5

Flame 2.0 version:
Gaia-Rev        736933b25ded904f0cb935a0d48f1f3cf91d33ad
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6c9aefc84244
Build-ID        20150119000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.033618
FW-Date         Mon Jan 19 03:36:29 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 version:
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150119001222
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150119.035259
FW-Date         Mon Jan 19 03:53:10 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(liuke) → needinfo?(whsu)
(Reporter)

Updated

3 years ago
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected

Comment 4

3 years ago
(In reply to Lance from comment #3)
> (In reply to William Hsu [:whsu] from comment #2)
> > Hi, Lance,
> > 
> > Can it be reproduced on the other branches (v2.1 & v2.0)?
> 
> Hi William,
> 
> This bug has been verified to fail on latest Flame 2.0, 2.1 build.
> 

Hi, Lance,

Thanks for the help.
I think this is a legacy bug since you can reproduce this bug on v2.0 & v2.1 & v2.2.
Flags: needinfo?(whsu)
(Reporter)

Comment 5

3 years ago
The bug still exist in latest Flame 3.0.

Steps:
1.Launch Browser.
2.Go to Youtube.com.
3.Tap a video to play.
4.Tap the share icon under video, share it to SMS.
5.Then do not save the message, and back to Youtube.

Expected Result: 
5.After you back to Youtube, the video should pause, and tap play icon the video play normally.

Actual Result: 
5.The video prompt "Video loading Stopped.". Sometimes, it only have voice, but doesn't have frames.

Fail rate:3/5

Flame 3.0 version:
Build ID               20150226010233
Gaia Revision          7894b929f1b0394f3c997f72a6482bc7813e758d
Gaia Date              2015-02-25 20:50:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dd6353d61993
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150226.043500
Firmware Date          Thu Feb 26 04:35:10 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: --- → affected
Flags: needinfo?(whsu)

Comment 6

3 years ago
[Blocking Requested - why for this release]:

Thanks Lance.

Bad user experience.
I suggest to fix it on v3.0 branch.
blocking-b2g: --- → 3.0?
Flags: needinfo?(whsu)
Dale, can you take a look?
blocking-b2g: 3.0? → 3.0+
Flags: needinfo?(dale)
Whiteboard: [systemsfe]
Ill take, its currently on a very long list though
Flags: needinfo?(dale)
Assignee: nobody → dale
So yup, I can reproduce but I have absolutely no idea what the cause of this would be. The behavior is on purpose we are specifically showing a 'loading stopped' message, it seems like it should pause when it goes into the background. 

Anthony, do you know what would cause / how to fix this? or if not who should be taking a look at it, cheers
Flags: needinfo?(ajones)
Alfredo - any thoughts?
Flags: needinfo?(ayang)
(Assignee)

Comment 11

2 years ago
It fails to retrieve metadata. Firefox can reproduce this problem too. It could be something strange on this video's container. I'll check container parser later.


2015-07-01 02:24:15.527936 UTC - 494895104[12477c420]: Decoder=11b57f400 Change machine state from NONE to DECODING_METADATA
2015-07-01 02:24:15.527971 UTC - 494895104[12477c420]: Decoder=11b57f400 Changed mNextFrameStatus to NEXT_FRAME_UNAVAILABLE
2015-07-01 02:24:15.528103 UTC - 494895104[12477c420]: Decoder=11b57f400 Dispatching AsyncReadMetadata
2015-07-01 02:24:15.542740 UTC - 611295232[12477c7b0]: Creating Apple AudioToolbox decoder
2015-07-01 02:24:15.542752 UTC - 611295232[12477c7b0]: Audio Decoder configuration: audio/mp4a-latm 44100 Hz 2 channels 16 bits per channel
[Child 62466] WARNING: NS_ENSURE_TRUE(IsSupportedVideoMimeType(mInfo.mVideo.mMimeType)) failed: file /Users/Alfredo/mozilla/mozilla-central/dom/media/MediaFormatReader.cpp, line 444
[Child 62466] WARNING: Decoder=11b57f400 Decode metadata failed, shutting down decoder: file /Users/Alfredo/mozilla/mozilla-central/dom/media/MediaDecoderStateMachine.cpp, line 2234
2015-07-01 02:24:15.542867 UTC - 494895104[12477c420]: Decoder=11b57f400 Change machine state from DECODING_METADATA to ERROR
[Child 62466] WARNING: Decoder=11b57f400 Decode error, changed state to ERROR: file /Users/Alfredo/mozilla/mozilla-central/dom/media/MediaDecoderStateMachine.cpp, line 2134
2015-07-01 02:24:15.542913 UTC - 494895104[12477c420]: Decoder=11b57f400 Changed mNextFrameStatus to NEXT_FRAME_AVAILABLE
2015-07-01 02:24:15.552063 UTC - 1943143168[112e62070]: Decoder=11b57f400 NotifyDownloadEnded, status=0
2015-07-01 02:24:15.552091 UTC - 1943143168[112e62070]: 124bd7800 Network state changed to IDLE
2015-07-01 02:24:15.630232 UTC - 1943143168[112e62070]: Decoder=11b57f400 ChangeState LOADING => ENDED
2015-07-01 02:24:15.630271 UTC - 1943143168[112e62070]: 124bd7800 Network state changed to EMPTY
2015-07-01 02:24:15.630282 UTC - 1943143168[112e62070]: 124bd7800 ChangeDelayLoadStatus(0) doc=0x124b90000
2015-07-01 02:24:15.630377 UTC - 611295232[12477c7b0]: Decoder=11b57f400 Change machine state from ERROR to SHUTDOWN
2015-07-01 02:24:15.630397 UTC - 611295232[12477c7b0]: Decoder=11b57f400 MediaDecoderStateMachine::Reset
2015-07-01 02:24:15.630448 UTC - 611295232[12477c7b0]: Decoder=11b57f400 Shutdown started
Flags: needinfo?(ayang)
Resetting since this is in core media
Assignee: dale → nobody
Component: Gaia::Browser → Audio/Video
Product: Firefox OS → Core
Whiteboard: [systemsfe]
Component: Audio/Video → Audio/Video: Playback
Alfredo, 
Are you available to take this bug?
Flags: needinfo?(ajones) → needinfo?(ayang)
(Assignee)

Updated

2 years ago
Assignee: nobody → ayang
Flags: needinfo?(ayang)
(Assignee)

Updated

2 years ago
Depends on: 1152236
(Assignee)

Updated

2 years ago
Depends on: 1192694
No longer depends on: 1152236
(Assignee)

Comment 14

2 years ago
I can't reproduce it on latest b2g37_v2_2 with build id 20150817032503.
Set "qawanted" to check if this bug can be seen in Flame 2.5 or not.
Keywords: qawanted
QA is currently blocked by bug 1196064 on master. We cannot attempt the STR until 1196064 is fixed.

Also I checked Flame 2.2 and issue is still occurring on this build:

Device: Flame 2.2
BuildID: 20150818032504
Gaia: 335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gecko: c29970d16372
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Assignee)

Comment 17

2 years ago
I can produce this problem now. I found it can be reproduced only if you tap 'SMS'. If you tap other app like 'Facebook', it can't be reproduced.

The root cause is video element doesn't enter 'dormant' mode when SMS popup. You can hear the audio is still playing when it happens. This behaviour likes another bug 1072874.

This problem is fixed in bug 1144132. I can't reproduce this bug in FxOS 2.5.
Can QA confirm it?
As I said at comment 16, we're currently blocked on master by bug 1196064 which was duped to bug 1192703, to be fixed, before we can test this. Haven't you noticed that SMS isn't being properly opened when you attempted the repro on master?
I've verified fixed bug 1192703, and can now test this bug.

This issue is no longer occurring on latest master. After step 5 of comment 0 STR, video automatically resumes playing. Note that this isn't the expected behavior at comment 0 either, but this could be due to bug 1196643 that videos auto play without user initiation.

Issue does NOT occur on:
Device: Aries 2.5
BuildID: 20150826051728
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: f61c3cc0eb8b7533818e7379ccc063b611015d9d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150826030209
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: f61c3cc0eb8b7533818e7379ccc063b611015d9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+], [QAnalyst-Triage?]
status-b2g-master: affected → unaffected
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [MGSEI-Triage+], [QAnalyst-Triage?] → [MGSEI-Triage+], [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Per comment 19, 
This issue is gone.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.