Closed Bug 1126580 Opened 5 years ago Closed 5 years ago

[Calendar][Text Selection] Tapping an event page makes the whole text selected.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED DUPLICATE of bug 1120347
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

()

Details

(Whiteboard: [2.2-bug-bash])

Attachments

(1 file)

[Calendar][Text Selection] Tapping an event page makes the whole text selected.

Description:
When the user taps on any text area on an event page, the whole text is selected (without carats and copy/paste bubble). The text should not be selected unless the user long-press on a word.

Pre-requisite: Calendar app has at least 1 event created.

Repro Steps:
1) Update a Flame to 20150127002504.
2) Open Calendar app.
3) Select an event created.
4) Tap on the screen anywhere around the text below the header.

Actual:
The whole text on the screen (except header) is selected.

Expected:
Nothing happens, unless the user long-presses on a specic word.

Environmental Variables:
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150127002504
Gaia: 80d5b797fd0497a7e3337b7798a21b2e1219681a
Gecko: 01bf1516a65b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 10/10
See attached: video clip, logcat
adding qawanted for branch check.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
Blocks: 1126602, 1126603
No longer blocks: 1126603
This issue also reproduces on Flame Master.

Result: The whole text is selected on an event screen when tapping the text area.
This issue also reproduces on Flame Master.

Result: The whole text is selected on an event screen when tapping the text area.

Environmental Variables:
Device: Flame 3.0 (319mb, full flash)
Build ID: 20150127010228
Gaia: b02ec9713e6de8d96c6954d2c0dfd0442b0656ac
Gecko: 38e4719e71af
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

---------------------------------------------------
Text Selection is not supported on v2.1. Unable to repro.

Environmental Variables:
Device: Flame 2.1 (319mb, full flash)
Build ID: 20150127001307
Gaia: d98bbe9d2bfdb53e80dc1ab1572bd05938a85526
Gecko: c255879afaf5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
No longer blocks: 1126602
Gerry, can you take a look at this please? This seems minor but I want to make sure.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(gchang)
This is a bug. NI developers to investigate more.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][textselection]
Flags: needinfo?(gchang)
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
Broken new feature, nominate as 2.2?
blocking-b2g: --- → 2.2?
Status: NEW → RESOLVED
blocking-b2g: 2.2? → ---
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120347
QA Whiteboard: [QAnalyst-Triage+][textselection] → [QAnalyst-Triage+][COM=Text Selection]
You need to log in before you can comment on or make changes to this bug.