[Settings] [Sound] Tone menus (Ringtones, Alerts, Manages Tones) have selectable text / blue text carets.

VERIFIED FIXED in 2.2 S9 (3apr)

Status

enhancement
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: pdahiya)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
Settings > Sound menu should follow text selection rules - Tones menu's should not be selectable

Repro Steps:
1) Update a Flame to 20150129010239
2) Go to Settings > Sound > Any Tone Menu (Ringtones, Alerts, Manage Tones)
3) Long press on text

Actual:
Text is selectable, blue text carets appear, sometimes off to the side (not around text)

Expected:
Text will not be selectable, or at least carets / text selection will be limited to a single line

Environmental Variables:
Device: Flame 3.0
Build ID: 20150129010239
Gaia: 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko: 6bfc0e1c4b29
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 5/5
See attached: Logcat, Video: http://youtu.be/iNrAchu-rl4
-----------------------------------------------------------------------------

This issue also occurs on Flame 2.2 (v18d-1), Flame 2.2 (v18d); Text Selection was not implemented in 2.1

evice: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full-Flashed)
Build ID: 20150128002506
Gaia: cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko: d824c65a6a2b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18d
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Duplicate of this bug: 1127716

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Text Selection]

Updated

4 years ago
blocking-b2g: --- → 2.2?

Comment 2

4 years ago
This should be blocking as the text should not be selectable.
Component: Gaia::Settings → Gaia::Ringtones
blocking-b2g: 2.2? → 2.2+

Comment 3

4 years ago
Howie,

afaik, this was not part of the gaia list of changes for Text Selection for 2.2. See meta bug: https://bugzilla.mozilla.org/showdependencytree.cgi?id=1092944. So, perhaps text selection disabling is not done for some of the settings functions such as Ringtones, Alerts etc.

I don't see this in the Settings App changes either and not in the spec: 

https://bugzilla.mozilla.org/show_bug.cgi?id=1094009
https://bug1094009.bugzilla.mozilla.org/attachment.cgi?id=8517186

Is the disabling text selection for some of the settings a release blocker? Can it wait for next release?

Thanks
Hema
Severity: normal → enhancement
Flags: needinfo?(hochang)
Flags: needinfo?(bbajaj)

Comment 4

4 years ago
Punam,

Could you take this up and see if you can disable text selection for sounds settings (ringtones/alerts/tones) -- lets first get this into master and test? 

Jim is out, if you need any help ping him on email.

Thanks
Hema
Flags: needinfo?(pdahiya)
(In reply to Hema Koka [:hema] from comment #3)
> Howie,
> 
> afaik, this was not part of the gaia list of changes for Text Selection for
> 2.2. See meta bug:
> https://bugzilla.mozilla.org/showdependencytree.cgi?id=1092944. So, perhaps
> text selection disabling is not done for some of the settings functions such
> as Ringtones, Alerts etc.
> 
> I don't see this in the Settings App changes either and not in the spec: 
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1094009
> https://bug1094009.bugzilla.mozilla.org/attachment.cgi?id=8517186
> 
> Is the disabling text selection for some of the settings a release blocker?
> Can it wait for next release?
> 
> Thanks
> Hema

I thought this was a miss from the spec of text selection for 2.2 and since this is a new feature for 2.2 and on looking the video it looked nasty.

Hmm from your comments seem like the other areas where text selection disabling isn't done, in which case it should be fine to let this go and we'd just be in status quo with other areas.

I'll NI UX on feedback/comments if this should block and be certain that other areas are in the same state and confirm the spec for 2.2. Happy to revisit in 3.0.

Comment 6

4 years ago
Actually Settings App disabled the text selection, but you're right some panels under it may be missed. The spec defines general non-selectable area (p.3) unless there's per app specific behavior (p.5-).

If other panels are in the same state we can discuss blocking decision here (all blocks or revisit in 3.0). If most of the panels are now non-selectable, we should still block this one.

ni QA for status in other panels.
Flags: needinfo?(hochang) → needinfo?(gchang)
afaik, most of the panels under Settings are non-selectable including value selector, list item, and context menu.
Flags: needinfo?(gchang)
(Assignee)

Comment 8

4 years ago
Assigning myself to investigate and fix
(Assignee)

Updated

4 years ago
Assignee: nobody → pdahiya
Flags: needinfo?(pdahiya)
(Assignee)

Comment 10

4 years ago
Comment on attachment 8580085 [details] [review]
[gaia] punamdahiya:Bug1127529 > mozilla-b2g:master

Hi Jim

Please review attached PR that by default do not allow user text selection for Ringtones, Alerts and Manage Tones panels under Settings.

Thanks!
Attachment #8580085 - Flags: review?(squibblyflabbetydoo)

Updated

4 years ago
See Also: → 1144796
Flags: needinfo?(bbajaj)
Comment on attachment 8580085 [details] [review]
[gaia] punamdahiya:Bug1127529 > mozilla-b2g:master

I'm pretty sure you can use `html` instead of `*` for your CSS selectors here. That should have better performance.
Attachment #8580085 - Flags: review?(squibblyflabbetydoo) → review-
(Assignee)

Comment 12

4 years ago
NI Jim for help test css selector performance. See bug 1144796
(Assignee)

Comment 13

4 years ago
Comment on attachment 8580085 [details] [review]
[gaia] punamdahiya:Bug1127529 > mozilla-b2g:master

Setting review flag on PR updated with review feedback.
Attachment #8580085 - Flags: review- → review?(squibblyflabbetydoo)

Updated

4 years ago
Attachment #8580085 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#OMScV2G5QtCaPS51zalwvw

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

4 years ago
Comment on attachment 8580085 [details] [review]
[gaia] punamdahiya:Bug1127529 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression
[User impact] if declined: Ringtone and Alerts panel under settings will have text selectable and blue text carets appear on long press 
[Testing completed]: On master
[Risk to taking this patch] (and alternatives if risky):Very low
[String changes made]:None
Attachment #8580085 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8580085 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on Flame Master and 2.2.

Result: Ringtones and alert sounds are not selectable.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150402063750
Gaia: f37be8b44cb7c3a147b9615ab76743b760f08eeb
Gecko: 35046df9df1f
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150401162503
Gaia: 1ceca464053dee4a8bf10ea5abeef724d68c2ff2
Gecko: 427b4da96714
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.