[Messages] bubble, caret shown in attachment oversize warning page

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: echang, Assigned: steveck)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-CP-bug-bash])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
*** Steps to Reproduce
1. Attach an oversized attachment in Messages
NEED STR 

*** Expected Results
Caret not shown
Bubble not shown

*** Actual Results
Caret shown on top of OK button
Bubble shown, Messages can be selected


*** Reproduction Frequency: 5%

*** Version
Serial: e47cd843 (State: device)
Build ID               20150129003432
Gaia Revision          6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gaia Date              2015-01-29 06:34:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/5e6fac01a72f
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150129.042943
Firmware Date          Thu Jan 29 04:29:53 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 1

4 years ago
Created attachment 8556835 [details]
2015-01-30-09-49-34.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Messages]
Keywords: steps-wanted
blocking-b2g: --- → 2.2?
(Assignee)

Comment 2

4 years ago
Please note the repeoduce rate is quite low(5%), and the STR  is still unknow. Hi Eric, is this bug could be reproduced manually, or could only reproduce in MTBF test?
Flags: needinfo?(echang)
(Reporter)

Comment 3

4 years ago
Manual test from bug bash today..

1. Attach an oversize file.
2. Warning pops up.
3. Long tap on "Messages".
4. Bubble shown.

5. Long tap on the left corner of the button, and slide up.
6. Caret shown.

I think the reproduce rate should be 90% with this STR.
Flags: needinfo?(echang)
Keywords: steps-wanted
Triage: Per comment 3, the steps are not that edgy. We were able to reproduce this issue multiple times. This bug should be fixed by Feature Complete.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 5

4 years ago
I think some widgets are missing the user-select: none, will provide some general solution for all widgets.
Also occurring in master so marking "status-b2g-v3.0" as affected.

Environmental variables:
Flame 3.0 device
Build Id: 20150130082956
Gecko: 8e96000
Gaia: 21829dd
Platform version: 38.0a1
status-b2g-master: --- → affected

Updated

4 years ago
Blocks: 1128421
No longer blocks: 1023688

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Messages] → [COM=Gaia::SMS]
(Assignee)

Updated

4 years ago
Assignee: nobody → schung
Depends on: 1129356
(Assignee)

Comment 7

4 years ago
This issue should be fixed once Bug 1127658 landed.
(Assignee)

Comment 8

4 years ago
Mark fixed since patch for bug 1127658 already landed and the it also fixed this issue as well.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
QA Whiteboard: [COM=Gaia::SMS] → [COM=Gaia::SMS][COM=Text Selection]
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The oversized attachement message cannot be selected with text selection.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150312002501
Gaia: 572d60e0a440ee4af50bc6b6adad8876eadbdb4d
Gecko: 244e6ba3c20e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Gaia::SMS][COM=Text Selection] → [COM=Gaia::SMS][COM=Text Selection][QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::SMS][COM=Text Selection][QAnalyst-Triage?] → [COM=Gaia::SMS][COM=Text Selection][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.