[Flame][Email]Folder list will be shown when navigating through account settings.

RESOLVED DUPLICATE of bug 1137203

Status

()

defect
RESOLVED DUPLICATE of bug 1137203
4 years ago
4 years ago

People

(Reporter: lulu.tian, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted video video.MP4
[1.Description]:
According to comment 27 in Bug 1109315, this bug is filed.
[Flame v2.1&v2.2][Email] When the user navigates through the settings for an email account, the user will see the folder list as the setting pages slide in and out.
Found time:v2.1: 10:13, v2.2: 10:27
See attachment:video.MP4 and logcat_v2.2_1027.txt and logcat_v2.1_1013.txt

[2.Testing Steps]: 
1. Launch the Email app.
2. Log in with a valid username and password.
3. Tap the drawer icon -> settings gear icon.
4. Tap the email account button and observe the screen.

[3.Expected Result]: 
4. When entering and exiting the settings pages,  nothing will shown underneath except for the previous settings page.

[4.Actual Result]: 
4. When entering and exiting the settings pages, the list of email folders will be briefly visible.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        63f291df9b9ad8498fb8fc7fb8bf070524406a5c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/70b8982a523d
Build-ID        20150202001432
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.035318
FW-Date         Mon Feb  2 03:53:29 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/be206fa2fb60
Build-ID        20150202002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.035604
FW-Date         Mon Feb  2 03:56:15 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
1. The mem of Flame 2.1/2.2 devices are 319 MB.
2. Tap the Add Account button at step 4, the list of email folders will be briefly visible on Flame v2.2
(Reporter)

Comment 1

4 years ago
(Reporter)

Comment 2

4 years ago
I am seeing this on master now too, and filed bug 1128784 as it seems to be a general app issue. I am not sure how deduping wants to work, if this is for tracking just the 2.2 or 2.1 issues. For a while, the issue was fixed on master, but started to notice last week it showing up again on master.
Component: Gaia::E-Mail → Layout
Product: Firefox OS → Core
See Also: → 1128784
(Reporter)

Comment 4

4 years ago
Hi Eric,
This issue can be repro on latest build of Flame 2.1/2.2, I have uploaded the logcat of v2.1, could you help with it? Thanks!
STR:
1. Launch the Email app.
2. Log in with a valid username and password.
3. Tap the drawer icon -> settings gear icon.
4. Tap the email account button and observe the screen.
**When entering and exiting the settings pages, the list of email folders will be briefly visible.
See attachment:logcat_v2.1_1829.txt
Rate:5/5

Flame 2.1 build:
Build ID               20150215001204
Gaia Revision          e8eba437af02820f74d122aec83b6001df6f89e3
Gaia Date              2015-02-13 05:26:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9d04f9149ca4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040742
Firmware Date          Sun Feb 15 04:07:53 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 build:
Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040852
Firmware Date          Sun Feb 15 04:09:03 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(echang)
(Reporter)

Updated

4 years ago
QA Whiteboard: [MGSEI-Triage+]

Comment 5

4 years ago
Eric is out of office, I will help with it.
This bug is a duplicate of bug 1128784. However, the issue is noticeable, and impacts user experience, nominate blocking for tracking and deduping.

Updated

4 years ago
blocking-b2g: --- → 2.2?
Duplicate of this bug: 1128784

Comment 7

4 years ago
Triage is blocking based on the fact that this is obvious, repros at a high rate, is poor UX and was previously a regression.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(echang)
I'm not able to reproduce this on the latest nightly build, even before bug 1137203 landed, so it might have been fixed by one of Benoit's changes earlier this month. However, bug 1137203 improves it further in that it properly pre-renders the panel before sliding it into place. So I'm going to dupe this to bug 1137203 based on that being the last thing we fixed, and so once that gets uplifted everything should be fixed everywhere.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137203
You need to log in before you can comment on or make changes to this bug.