[Flame][Dialer]The record shows "911" instead of "Emerengcy number".

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: nefzaoui)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
Posted image call_log.png
[1.Description]:
According to comment 5 in Bug 1129339, this bug is filed.
[Flame v2.2][Dialer]When you make a call to "911", the record shows "911" instead of "Emerengcy number".
Found time:09:40
See attachment:call_log.png and logcat_0940.txt

[2.Testing Steps]: 
1. Launch Phone app.
2. Make a call to "911" and hang up the call.
3. Navigate to Call log screen.

[3.Expected Result]: 
3. The record should show "Emerengcy number".

[4.Actual Result]: 
3. The record shows "911" instead of "Emerengcy number".

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150204002509
Gaia Revision          a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gaia Date              2015-02-04 00:41:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8669c26fd4a5
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.035932
Firmware Date          Wed Feb  4 03:59:42 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted file logcat_0940.txt
Hi Sue, Could you also check this on v2.1 and master, thank you.
Flags: needinfo?(lulu.tian)
(Reporter)

Comment 3

4 years ago
Posted image v3.0.png
Hi Eric,
This issue can be repro on Flame 3.0, the record shows "911" instead of "Emerengcy number".
See attachment:v3.0.png
Rate:5/5

Flame 3.0 build:
Build ID               20150204010225
Gaia Revision          dfebaaa8aab43470f482d09d71137bab840c3ae9
Gaia Date              2015-02-03 18:49:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.043856
Firmware Date          Wed Feb  4 04:39:07 EST 2015
Bootloader             L1TC000118D0

-------------------------------------------------------------------

This issue can not be repro on Flame 2.1, the record shows "Emerengcy number".
See attachment:v2.1.png
Rate:0/5
Flame 2.1 build:
Build ID               20150204002437
Gaia Revision          17bf14f12e43043654498330d610d469b8b55e64
Gaia Date              2015-02-03 05:19:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/bdebcc47ec7a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.035620
Firmware Date          Wed Feb  4 03:56:31 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(lulu.tian) → needinfo?(echang)
(Reporter)

Comment 4

4 years ago
Posted image v2.1.png
(Reporter)

Updated

4 years ago
Thank you.
Set 2.2?
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)
ni to Beatriz to confirm the certification requirements on this. Thanks!
Flags: needinfo?(beatriz.rodriguezgomez)
(In reply to Noemí Freire (:noemi) from comment #6)
> ni to Beatriz to confirm the certification requirements on this. Thanks!
Thanks for asking. Yes, emergency calls must be recognized properly. This would be a cert blocker. Please fix it.
Flags: needinfo?(beatriz.rodriguezgomez)
I had been noticing this bug when I was doing the window for bug 1129339. I've confirmed its window also applies to this bug.

b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150126135000
Gaia: b02ec9713e6de8d96c6954d2c0dfd0442b0656ac
Gecko: 38e4719e71af
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150126141259
Gaia: ef8b81a65a80fbfa019c5d70dd5916594837ebf7
Gecko: 3086135dda95
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: b02ec9713e6de8d96c6954d2c0dfd0442b0656ac
Gecko: 3086135dda95

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: ef8b81a65a80fbfa019c5d70dd5916594837ebf7
Gecko: 38e4719e71af

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/b02ec9713e6de8d96c6954d2c0dfd0442b0656ac...ef8b81a65a80fbfa019c5d70dd5916594837ebf7

Caused by the patch for Bug 1102340.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Ahmed, can you take a look at this please? Looks like the work done on Bug 1102340 might have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(nefzaoui)
(Assignee)

Comment 10

4 years ago
Taking.
Thanks for letting me know.
Assignee: nobody → nefzaoui
Flags: needinfo?(nefzaoui)
(Assignee)

Updated

4 years ago
Attachment #8560135 - Flags: review?(drs.bugzilla)
Triage meeting: blocking as is a regression and the user experience is totally broken.
blocking-b2g: 2.2? → 2.2+
See Also: → 1129839
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129339
Verify me once bug 1129339 lands.
Keywords: verifyme
Comment on attachment 8560135 [details] [review]
[PullReq] anefzaoui:bug-1129765-1 to mozilla-b2g:master

This doesn't completely fix the issue. I missed this and posted a fix myself in bug 1129339.
Attachment #8560135 - Flags: review?(drs.bugzilla) → review-
(Reporter)

Comment 16

4 years ago
Posted image verify.png
This issue has been verified successfully on Flame v3.0
STR:
1. Launch Phone app.
2. Make a call to "911" and hang up the call.
3. Navigate to Call log screen.
**The record shown as "Emerengcy number".
See attachment:verify.png
Rate:0/5

Flame 3.0 build:
Build ID               20150214010227
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a7c177546ca0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.043959
Firmware Date          Sat Feb 14 04:40:10 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Comment 17

4 years ago
Leave "verifyme" for v2.2
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
(Reporter)

Comment 18

4 years ago
Posted image verify_v2.2.png
This issue has been verified successfully on Flame v2.2
STR:
1. Launch Phone app.
2. Make a call to "911" and hang up the call.
3. Navigate to Call log screen.
**The record shown as "Emerengcy number".
See attachment:verify_v2.2.png
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.