Regression: Full-Screen video playback exhibits a status-bar shown in Android 4.0 and in 4.4+ a status-bar grey background shown

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: mcomella)

Tracking

(Blocks: 1 bug, {regression, reproducible})

38 Branch
ARM
Android
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox35 affected, firefox36 affected, firefox37 affected, firefox38 affected, firefox39 unaffected, fennec37+)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Currently on full-screen, in Android 4.0 the status-bar will be shown and in Android 4.4+ a grey status bar will appear.

This is very similar to bug 1074924. Perhaps for a period of time it was fixed but it has regressed.

I can reproduce this on all channels. 

Currently with this alongside bug 1098390 makes our full-screen experience poor.

  
Steps to reproduce 

  http://people.mozilla.org/~atrain/mobile/tests/test.mp4
  Enter full-screen

  or 

  http://davidwalsh.name/demo/fullscreen.php
(Reporter)

Comment 1

4 years ago
I don't see .setStatusBarTintEnabled(!fullscreen) calls in code. Why/Where was this removed?
(Reporter)

Comment 2

4 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> I don't see .setStatusBarTintEnabled(!fullscreen) calls in code. Why/Where
> was this removed?

Looks like it got refactored.

Is this called still? https://dxr.mozilla.org/mozilla-central/source/mobile/android/base/util/ActivityUtils.java#19
Is this similar to Bug 1032179?
Sounds similar to me. NI to Aaron
Flags: needinfo?(aaron.train)
(Reporter)

Comment 5

4 years ago
(In reply to Teodora Vermesan (:TeoVermesan) from comment #3)
> Is this similar to Bug 1032179?

Nope
Flags: needinfo?(aaron.train)
Let's try to address this sooner than later
Assignee: nobody → michael.l.comella
tracking-fennec: ? → 37+
(Reporter)

Comment 7

4 years ago
Video from my Nexus 6 (5.0.1): http://people.mozilla.org/~atrain/mobile/1132984.mp4
I can repro on my N9, with Lollipop.

I can't repro on my N4/7 with 4.4.

Aaron, can you repro on any pre-Lollipop devices?
Flags: needinfo?(aaron.train)

Comment 9

4 years ago
I can reproduce it on a Sony Xperia Sola (Android 4.0.4) and on a Samsung
Galaxy Tab 3 (Android 4.4.2), both updated to the latest firmware.

This bug didn't exist in Firefox 34. I also downgraded to Firefox 34 to
confirm it after experiencing it in Firefox 35. I tried Firefox Nightly too
and the regression is still there.

In case it matters both devices have hardware buttons (back, home, menu).

I am attaching screenshots.

Comment 10

4 years ago
Created attachment 8567471 [details]
Fullscreen normal behavior (Firefox 34, Android 4.4).png

Comment 11

4 years ago
Created attachment 8567472 [details]
Fullscreen regression (Firefox 35, Android 4.4).png

Comment 12

4 years ago
Created attachment 8567473 [details]
Fullscreen video (Firefox 35, Android 4).png
I'm going to blame bug 1056002, which landed in 35.
Blocks: 1056002
(Reporter)

Updated

4 years ago
Flags: needinfo?(aaron.train)
Keywords: regressionwindow-wanted
The backout of bug 1056002 fixed this for me on my N9, the only device I can repro on (granted, it's Lollipop).

Nikos, this change should be in tomorrow's Nightly. Can you reproduce?
Flags: needinfo?(nmzbza2014)

Comment 15

4 years ago
I just installed the latest nightly (39.0a1) and the bug is fixed in both devices. Fullscreen is working correctly again. Thank you!

When will the fix reach the stable release? Firefox 39 or earlier?
Flags: needinfo?(nmzbza2014)
WORKSFORME by the backout of bug 1056002.

(In reply to Nikos Asimakis from comment #15)
> When will the fix reach the stable release? Firefox 39 or earlier?

We intend to fix this in Firefox 37+ (Beta).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → unaffected
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.