Closed Bug 1134658 Opened 10 years ago Closed 9 years ago

Reader mode icon looks bad with lightweight themes

Categories

(Firefox Graveyard :: Reading List, defect, P3)

All
Windows 7

Tracking

(firefox38 verified, firefox39 verified)

VERIFIED FIXED
Firefox 39
Tracking Status
firefox38 --- verified
firefox39 --- verified

People

(Reporter: bob, Unassigned)

References

Details

(Whiteboard: [fixed by bug 1140345])

Attachments

(2 files)

The reader mode icon doesn't use transparency and looks bad when using a lightweight theme
Status: UNCONFIRMED → NEW
Ever confirmed: true
The darker the theme is, the more you see it.

The icon should have a transparent background.

I was unable to see the bug on Mac OSX, maybe because the transparency on the URL bar is handled differently.
Component: Theme → Reading List
(In reply to Flore Allemandou [:flore] from comment #1)
> I was unable to see the bug on Mac OSX, maybe because the transparency on
> the URL bar is handled differently.

I was unable to replicate this issue on Mac OS X 10.9.5 and Ubuntu 14.04 (x64), I believe this is Windows only.
Flags: qe-verify+
Hmmm, yeah... My previous comment was not clear.
The screenshot I uploaded showing the bug was done on a windows 7 computer (at work). I checked on my imac (at home) and could not see this bug (even when zooming), but I was not sure if it did not exist or just that I could not see it.

Sorry for being not clear.
P3 because it's pretty obvious as primary UI and LWTs are popular. Also, this probably looks really bad on the DevEdition with a black theme?
Priority: -- → P3
Looking at chrome://browser/skin/reader-mode-16@2x.png / chrome://browser/skin/reader-mode-16.png, they do indeed have a white background. We need versions of these two icons with a transparent background. Should just be a simple image swap.
Blocks: 795981
Flags: needinfo?(mmaslaney)
There is an image attached to bug 1135351 that should fix this too.
That would be attachment 8575382 [details], I guess? Can we (a) get that as a PNG in @1x and @2x flavors, and (b) what's the new blue version of the icon for? We currently over have the white/orange version to indicate if reader mode is active or not.
(In reply to Justin Dolske [:Dolske] from comment #9)
> Can we (a) get that as a PNG in @1x and @2x flavors,

Where would this help? Isn't the SVG icon we are currently using better to handle various dpi settings?

> and (b) what's the new blue version of the icon for?

The active state (between the mousedown and mouseup events).
Flags: needinfo?(mmaslaney)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 1140345]
Target Milestone: --- → Firefox 39
Depends on: 1140345
Verified fixed on Nightly 39.0a1 (2015-03-29) and Aurora 38.0a2 (2015-03-29), using Windows 7 (x64), Ubuntu 14.04 (x64) and Mac OS X 10.9.5, with the Developer Edition and several other lightweight (persona) themes.
Status: RESOLVED → VERIFIED
QA Contact: andrei.vaida
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: