WebRTC sharing notifications fail to open from the global indicator when the Hello window has been detached

VERIFIED FIXED in Firefox 38

Status

Hello (Loop)
Client
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Assigned: florian)

Tracking

unspecified
mozilla40
Points:
2
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox38 verified, firefox39 fixed, firefox40 fixed)

Details

Attachments

(2 attachments)

Affected builds:
- Latest Nightly
- Latest Aurora

Affected OS`s:
- Windows 7 64-bit
- Windows 8 64-bit
- Mac OS X 10.9.5
- Ubuntu 14.04 32-bit

STR:
1. Start a conversation
2. Detach Hello conversation window
3. From global indicator select one item (webcam)

4. Attach the conversation window
5. From global indicator select one item or more

6. Detach Hello conversation window

Actual results:
At step 3 the pop-up is misplaced
At step 5 nothing happens
After the second detachment the pop-ups appear.
I believe "global indicator" referred tp is the top-of-screen "you're sharing mic and/or webcam" indicator.  Note this is Loop/Hello, so the doorhanger popped up isn't the normal urlbar doorhanger
Component: WebRTC → Client
Product: Core → Loop
Version: Trunk → unspecified

Updated

3 years ago
Duplicate of this bug: 1151730
(Assignee)

Comment 3

3 years ago
This looks related to bug 1107967 (fixed several months before this bug was reported though :-/).
(Assignee)

Updated

3 years ago
Summary: Inconsistent behavior with webrtc pop-ups → WebRTC sharing notifications fail to open from the global indicator when the Hello window has been detached
(Assignee)

Comment 4

3 years ago
Created attachment 8589690 [details] [diff] [review]
Patch

The notifications didn't open correctly because the 'owner' property wasn't updated correctly when swapping the browsers. This happened because _swapBrowserNotifications from PopupNotifications.jsm was called with ourBrowser and otherBrowser reversed.
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8589690 - Flags: review?(mixedpuppy)
Comment on attachment 8589690 [details] [diff] [review]
Patch

run through try?
Attachment #8589690 - Flags: review?(mixedpuppy) → review+
(Assignee)

Comment 7

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/d9fca27fc251
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+

Updated

3 years ago
Iteration: --- → 40.1 - 13 Apr
https://hg.mozilla.org/mozilla-central/rev/d9fca27fc251
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Assignee)

Comment 9

3 years ago
Comment on attachment 8589690 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: WebRTC sharing UI for Hello.
[User impact if declined]: WebRTC sharing indicator impossible to open from the global sharing indicator for the Hello chat window if the chat window has been detached and reattached.
[Describe test coverage new/current, TreeHerder]: QA will verify.
[Risks and why]: Low, the patch is a one-liner.
[String/UUID change made/needed]: none.
Attachment #8589690 - Flags: approval-mozilla-beta?
Attachment #8589690 - Flags: approval-mozilla-aurora?
status-firefox38: --- → affected
status-firefox39: --- → affected
Comment on attachment 8589690 [details] [diff] [review]
Patch

Should be 38 beta 3 (or 4)
Attachment #8589690 - Flags: approval-mozilla-beta?
Attachment #8589690 - Flags: approval-mozilla-beta+
Attachment #8589690 - Flags: approval-mozilla-aurora?
Attachment #8589690 - Flags: approval-mozilla-aurora+
QA Contact: bogdan.maris
Created attachment 8600875 [details]
Screenshot showing the tiny pop-up

Verified that the initial issue is fixed on Ubuntu only.
I can`t verify this fix on Windows because of bug 1137602, and I found a new behavior on Mac (tiny and unusable pop-up):

1. From conversation click for eg. webcam icon
2. Detach conversation
3. Click icon 
(This happens if icons from Mac menubar are used as well)

Note:
I can only reproduce this on Mac and I seem to only reproduce on builds after this fix.

Should I log a new bug or reopen this one?
Flags: needinfo?(florian)
(Assignee)

Comment 14

3 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #13)
> Created attachment 8600875 [details]
> Screenshot showing the tiny pop-up

Did you move the detached window around between a retina and a non-retina screen?

> Should I log a new bug or reopen this one?

New bug please.
Flags: needinfo?(florian)
Depends on: 1161023
(In reply to Florian Quèze [:florian] [:flo] from comment #14)
> (In reply to Bogdan Maris, QA [:bogdan_maris] from comment #13)
> > Created attachment 8600875 [details]
> > Screenshot showing the tiny pop-up
> 
> Did you move the detached window around between a retina and a non-retina
> screen?

Nope, I did not move the detached window at all and I don`t have a retina display (using a iMac 21.5 inch Late 2013)
 
> > Should I log a new bug or reopen this one?
> 
> New bug please.

Logged bug 1161023.

Closing this as verified fixed then.
Status: RESOLVED → VERIFIED
status-firefox38: fixed → verified
Verification on Beta should be enough - removing qe-verify flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.