Closed Bug 1137968 Opened 5 years ago Closed 4 years ago

[B2G] Create Ukrainian keyboard

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master verified)

VERIFIED FIXED
2.2 S14 (12june)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- verified

People

(Reporter: delphine, Assigned: luigitedone)

References

Details

(Keywords: verifyme)

Attachments

(5 files, 1 obsolete file)

We are working on adding Ukrainian to Firefox OS to builds (see Bug 1137822)
Once it's up, we will need a keyboard.
Artem: do you have any input on the keyboard layout please? thanks!
Flags: needinfo?(a.polivanchuk)
The keyboard should be based on a slight modification of Russian Standard Layout, often also have the Russian Standard ("Windows") layout marked on it.
Flags: needinfo?(a.polivanchuk)
This keyboard should be used for Ukrainian: http://virtualkeyboard.biz/ukrainian
Assignee: nobody → luigitedone
Is the ё required? If yes, can assign it as an alternate value for the letter е?
Flags: needinfo?(a.polivanchuk)
No, "ё" is not required. This is a Russian alphabet letter.
Flags: needinfo?(a.polivanchuk)
Attached image Proposed layout
This is the proposed layout for the Ukrainian keyboard. Is it ok?
Flags: needinfo?(a.polivanchuk)
Yes, this is correct layout.
Just one more thing: is the letter "ґ" exists in it?
Flags: needinfo?(a.polivanchuk)
Yes, it appears when you press the letter г.
Ok, no more questions at the moment.
Attachment #8603724 - Flags: review?(dflanagan)
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

Thanks for this patch, Luigi.  There have been enough changes to the keyboard since I last worked on it that I no longer feel comfortable reviewing a patch like this.

Rudy: can you take this review, or find a reviewer for it?
Attachment #8603724 - Flags: review?(dflanagan) → review?(rlu)
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

This looks good but has some nits to be addressed.
Please help take a look at my comments on the pull request.

Please let me know if you need me to follow up to do the modification.
Thanks.
Attachment #8603724 - Flags: review?(rlu) → feedback+
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

Patch updated, let me know if it's ok.
Attachment #8603724 - Flags: review?(rlu)
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

Hi,

Just leave some comments on the pull request, please help take a look and set review flag again?
Thank you.
Attachment #8603724 - Flags: review?(rlu)
Attachment #8603724 - Flags: review?(rlu)
Artem, I'm using this reference for ordinal numbers, however I cannot find a similar approach in iOS and Android keyboards. Is it correct? http://intranet.tdmu.edu.ua/data/kafedra/internal/in_mow/lectures_stud/en/nurse/bsn/ptn/4/Ukrainian%20language/%E2%84%96%2009.%20Numerals.%20Dates.%20Ordinal%20numbers.htm

With this patch, when you long press on a number, it suggests the following ordinal numbers:

0: º
1: 1-ий,1-а,1-е,1-і
2: 2-ий,2-а,2-е,2-і
3: 3-ій,3-я,3-є,3-і
4: 4-ий,4-а,4-е,4-і
5: 5-ий,5-а,5-е,5-і
6: 6-ий,6-а,6-е,6-і
7: 7-ий,7-а,7-е,7-і
8: 8-ий,8-а,8-е,8-і
9: 9-ий,9-а,9-е,9-і
Flags: needinfo?(a.polivanchuk)
Flags: needinfo?(a.polivanchuk)
Yes, I haven't seen such approach in different keyboards on my Android also. Usually, when you long press on a number, it suggests nothing. Some keyboards could suggest fractional numbers or other options.

For EN keyboard this method looks ok. But how it will looks for UK with 4 suggestions for 1 number?

In this case it would be better the following:

1: 1-й,1-а,1-е,1-і
2: 2-й,2-а,2-е,2-і
3: 3-й,3-я,3-є,3-і
4: 4-й,4-а,4-е,4-і
5: 5-й,5-а,5-е,5-і
6: 6-й,6-а,6-е,6-і
7: 7-й,7-а,7-е,7-і
8: 8-й,8-а,8-е,8-і
9: 9-й,9-а,9-е,9-і

-ий >> -й
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

As Artem suggested, I would recommend we remove those alternatives for numbers.

Or if you want to keep them, we should be fix the overflow issue that I saw when longpressing on "4" - "7", that is an existing bug in our implementation, not caused by your patch.
However, we should not land this as is, or it would cause an obvious UI bug that is blocking.

Thanks.
Attachment #8603724 - Flags: review?(rlu)
As I see, Russian layout doesn't have such alternatives https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/ru.js

So, I think it's better to remove them too, because it could cause the worsening of usability.
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

I updated the patch as suggested, it should be ok now.
Attachment #8603724 - Flags: review?(rlu)
Comment on attachment 8603724 [details] [review]
[gaia] ltedone:Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

This looks much better, I have added some comments.
Please address those and then I'll handle the test part for this to land.

Thanks.
Attachment #8603724 - Flags: review?(rlu) → review+
Done!
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#BugAERaXQDKTFBTYWpHuKA

The pull request failed to pass integration tests. It could not be landed, please try again.
The PR failed. Can you spot the problem?
Flags: needinfo?(rlu)
Comment on attachment 8612110 [details] [review]
[gaia] RudyLu:ltedone-Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

Carry forward the r+.
Flags: needinfo?(rlu)
Attachment #8612110 - Flags: review+
Attachment #8603724 - Attachment is obsolete: true
Hmm, seems autolander is disabled right now.
I'll try to land this myself.
Keywords: checkin-needed
Manually land this to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/45afe9b99481d768d90a74a5322389f5873d844f

Thanks!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Can we get approval to land this on 2.2 as well? This should be low risk, and would let us do an l10n sign-off on Ukrainian locale on 2.2 (localizer has worked hard on getting this locale ready on time for 2.2 sign-off). I know we're past code complete but it would be a shame to get this in considering how low risk this is
Flags: needinfo?(jocheng)
Hi Delphine,
I agree with you as this only add new keyboard layout.

Hi luigitedone,
Could you help to raise 2.2 Uplift request?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(luigitedone)
blocking-b2g: --- → 2.2+
Comment on attachment 8612110 [details] [review]
[gaia] RudyLu:ltedone-Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New feature, a new keyboard layout.
[User impact] if declined: The Ukrainian users cannot use the keyboard layout.
[Testing completed]: Yes, manually.
[Risk to taking this patch] (and alternatives if risky): Low, just a new keyboard layout and won't be built in if not explicitly specified. 
[String changes made]: N/A
Attachment #8612110 - Flags: approval-gaia-v2.2?
For keyboard layout patches landing to v2.2, we would need branch specific modifications due to some build test differences.
Flags: needinfo?(luigitedone)
(thanks so much all!! :D)
Attachment #8612110 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Comment on attachment 8612110 [details] [review]
[gaia] RudyLu:ltedone-Bug_1137968-Create_Ukrainian_keyboard > mozilla-b2g:master

Waiting for 2.2 branch patch.
Attachment #8612110 - Flags: approval-gaia-v2.2+ → approval-gaia-v2.2?
Flags: needinfo?(rlu)
Attached file Patch for v2.2
Flags: needinfo?(rlu)
This issue is verified fixed on the latest 3.0 Flame Nightly build.

Actual Results: The Ukranian Keyboard is available.

Environmental Variables:
Device: Aries 3.0
BuildID: 20150626120208
Gaia: 8a1e4ae522c121c5cacd39b20a5386ec9055db82
Gecko: 56e207dbb3bd
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (3.0) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
Verifyme keyword for checking this when 2.2 is merged.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comment on attachment 8626489 [details] [review]
Patch for v2.2

Approving branch patch for 2.2.
Attachment #8626489 - Flags: approval-gaia-v2.2+
Attachment #8612110 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2-
Hi!
How can I test it on the device?
Currently I have Boot2Gecko 2.2.0.0-prerelease installed, but there is no Ukrainian keyboard available.
This should have landed on 2.2 as per comment 38. Asking QA to take a look into this.
:JMercado: could you please take a look at 2.2? This bug was closed as verified before being checked on that branch as well, it seems. THanks!
Flags: needinfo?(jmercado)
The Ukranian keyboard is not enabled on 2.2 Flame.  Normal procedure is to mark overall status of the bug as verified when it is verified fixed on master.  This probably needs a new bug written instead, but if you would like to keep the work in one bug that's fine too.

Environmental Variables:
Device: Flame 2.2
BuildID: 20151019032501
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 6b4e563acaf9
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(jmercado) → needinfo?(lebedel.delphine)
Attached image Punctuation marks
Quick access to punctuation marks by long tap on dot key is missing from the keyboard.
Not sure what's requested from here, so taking out the ni.
Artem: have you tried flashing the keyboard for 2.2, to check how it looks? 
If there are issues with the keyboard either on 2.2, 2.5 or master, please file new bugs for those. thanks :)
Flags: needinfo?(lebedel.delphine)
You need to log in before you can comment on or make changes to this bug.