Add margin to the left side of the remote video container in the standalone client

VERIFIED FIXED in Firefox 39

Status

P2
normal
Rank:
25
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

unspecified
mozilla39
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox39 verified)

Details

(Whiteboard: [screensharing][UX bug])

Attachments

(2 attachments)

During the Window/ tabsharing feature review the issue was raised that the remote video stream hugs the left side of the tab/ window too much.

Sevaan noted that adding a margin/ padding if 10px would make it look much better.
Flags: qe-verify+
Flags: firefox-backlog+
Created attachment 8574732 [details]
10px Left Margin
Created attachment 8575315 [details] [diff] [review]
Patch v1: add a margin of 10px to the left side of the remote video stream
Attachment #8575315 - Flags: review?(standard8)
Attachment #8575315 - Attachment description: bug-1141128-leftMargin.patch → Patch v1: add a margin of 10px to the left side of the remote video stream
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 38.3 - 23 Feb
Points: --- → 1

Comment 3

4 years ago
Per Gavin's request - just updating bugs that carried over before they were 100% resolved to the next iteration.
Iteration: 38.3 - 23 Feb → 39.2 - 23 Mar

Updated

4 years ago
Rank: 25

Updated

4 years ago
Whiteboard: [screensharing][UX bug]
Comment on attachment 8575315 [details] [diff] [review]
Patch v1: add a margin of 10px to the left side of the remote video stream

Review of attachment 8575315 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #8575315 - Flags: review?(standard8) → review+
Target Milestone: mozilla38 → ---
https://hg.mozilla.org/mozilla-central/rev/289f3a6723bc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Duplicate of this bug: 1131104
QA Contact: bogdan.maris
I tested this fix across platforms (Windows 7 64-bit, Mac OS X 10.9.5 and Ubuntu 14.04 32-bit) on latest Nightly. I noticed that the padding only applies when the sharing is active, not before entering the conversation and after leaving it. Is this the intended behavior?
Flags: needinfo?(mdeboer)
Hi Bogdan, I'm afraid this bug is not yet verifiable, because this fix is only available when the standalone client is updated on 'hello.firefox.com'.
So this is not part of the UI inside Firefox.

That said, I think it'd be good leave a note in the bugs that went into the standalone client once an update is released, so that the verification process can be kicked off from then on.
Flags: needinfo?(mdeboer)
Mark, please see comment 9. Is this feasible with the current release automation? Or can I file a bug to get this done at some point?
Flags: needinfo?(standard8)
(In reply to Mike de Boer [:mikedeboer] from comment #9)
> Hi Bogdan, I'm afraid this bug is not yet verifiable, because this fix is
> only available when the standalone client is updated on 'hello.firefox.com'.
> So this is not part of the UI inside Firefox.

This should, however, be verifiable on the development server - set your loop.server pref to "https://loop-dev.stage.mozaws.net/v0" (I recommend doing this in a separate profile).

> That said, I think it'd be good leave a note in the bugs that went into the
> standalone client once an update is released, so that the verification
> process can be kicked off from then on.

I think generally I'd prefer verification against the development servers - as then we can find issues before it hits production.

Generally it hits development within an hour of the bug being marked as "fixed".

That said, it might also be good to see if we can automatically comment on the bug for when it goes to production anyway. That way we can have tracking for future, to know exactly when a bug shipped. Its conceivable that we could roll this into automation that ops are already working on. Getting bug 1050295 would probably also help this work.

Might be worth thinking a little bit more about the exact flow that we want before we file bugs though.
Flags: needinfo?(standard8)
(In reply to Mark Banner (:standard8) from comment #11)
> (In reply to Mike de Boer [:mikedeboer] from comment #9)
> > Hi Bogdan, I'm afraid this bug is not yet verifiable, because this fix is
> > only available when the standalone client is updated on 'hello.firefox.com'.
> > So this is not part of the UI inside Firefox.
> 
> This should, however, be verifiable on the development server - set your
> loop.server pref to "https://loop-dev.stage.mozaws.net/v0" (I recommend
> doing this in a separate profile).
> 
> > That said, I think it'd be good leave a note in the bugs that went into the
> > standalone client once an update is released, so that the verification
> > process can be kicked off from then on.

Thanks Mark, I changed the value of loop.server and I verified that this issue is fixed on Windows 8.1 64-bit, Mac OS X 10.9.5 and Ubuntu 14.04 32-bit using latest Nightly.
Status: RESOLVED → VERIFIED
status-firefox39: fixed → verified
Depends on: 1153418
You need to log in before you can comment on or make changes to this bug.