Bioshock Ininite command video is distorted when setting quality to 1080p

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Todd Brais, Unassigned)

Tracking

({regression})

38 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox36 unaffected, firefox37 unaffected, firefox38 fixed, firefox39 fixed)

Details

(Whiteboard: betabreakers-fx38, URL)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8578795 [details]
Vito_DxDiag.txt

Describe the issue you're reporting in great detail, including some of the following information:

* Operating system
* Processor make and model
* Graphics card make and model
Steps to Reproduce:
1. Navigate to URL: https://www.youtube.com/watch?v=hicBgE6XndM
2. Change video resolution to 1080p
3. Start to play the YouTube video, and observe that video is scrambled
(Reporter)

Comment 1

3 years ago
Created attachment 8578799 [details]
fx38_zito_defaultdriver_support.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8578800 [details]
fx38_zito_defaultdriver_memory.json
(Reporter)

Comment 3

3 years ago
* Operating system
* Processor make and model
 *  Graphics card make and model
Actual: When the user clicks on YouTube (see below), and changes the video resolution to 1080p; the video will become scrambled

Steps to Reproduce:
1. Navigate to URL: https://www.youtube.com/watch?v=hicBgE6XndM
2. Change video resolution to 1080p
3. Start to play the YouTube video, and observe that video is scrambled
(Reporter)

Comment 4

3 years ago
Created attachment 8578803 [details]
BioShock Infinite Command Deck_1080p.jpg
(Reporter)

Updated

3 years ago
QA Whiteboard: betabreakers-fx38
Whiteboard: betabreakers-fx38
Hi Todd, can you please update to the latest NVidia driver and see if this continues to reproduce? I'm not able to reproduce this on my Razerblade laptop which uses a combination Intel/NVidia setup.

[Tracking Requested - why for this release]: this looks pretty ugly and still needs investigation.
status-firefox36: --- → ?
status-firefox37: --- → ?
status-firefox38: --- → affected
tracking-firefox38: --- → ?
tracking-firefox39: --- → ?
Flags: needinfo?(tbrais)
I managed to reproduce this on a Windows 7 PC with an NVidia 8600 GT card. I have no specific steps to reproduce other than playing with some of the videos on https://wiki.mozilla.org/QA/Platform/Graphics/Firefox_38#Tests. Eventually the Bioshock video shows the artifacting.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(tbrais)
This reproduces easily now. All I have to do is load https://www.youtube.com/watch?v=hicBgE6XndM on this machine and change the quality to 1080p HD. This does not reproduce in Firefox 37 but does in Firefox 38/39.
status-firefox36: ? → unaffected
status-firefox37: ? → unaffected
status-firefox39: --- → affected
Keywords: regression
Further information, turning off dxva does not work around this bug. I'll see if I can get a pushlog.
Last Good: 2015-01-29 [6bfc0e1c4b29]
First Bad: 2015-01-30 [29b05d283b00]
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6bfc0e1c4b29&tochange=29b05d283b00
Duplicate of this bug: 1144411
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #9)
> Last Good: 2015-01-29 [6bfc0e1c4b29]
> First Bad: 2015-01-30 [29b05d283b00]
> Pushlog:
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=6bfc0e1c4b29&tochange=29b05d283b00

Can you get the regression window on the inbound builds?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #11)
> Can you get the regression window on the inbound builds?

I have tried more than 20 different mozilla-inbound builds from 2015-01-01 to 2015-03-23 and cannot get this to reproduce. I have no idea why this doesn't reproduce in inbound builds but does in nightly builds.
(In reply to Ralph Giles (:rillian) from comment #13)

Thanks for the builds, Ralph.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ac87588c73e does not reproduce this bug.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=37a80e26297b does not reproduce this bug.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bb038c6435db does not reproduce this bug.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=66a748c75da3 does not reproduce this bug.

I then went back and tried the builds from comment 9 (the mozilla-central regression window) and this bug no longer reproduces their either. I have no idea why this machine can no longer reproduce this bug as nothing has changed in the last 24 hours.
Todd, can you please test the builds from comment 13? I can't get this to reproduce anymore.
Flags: needinfo?(tbrais)
Tracking for 38 and 39 since this sounds reproducible and is a recent regression.
tracking-firefox38: ? → +
tracking-firefox39: ? → +
(In reply to Liz Henry (:lizzard) from comment #16)
> Tracking for 38 and 39 since this sounds reproducible and is a recent
> regression.

FWIW, I don't think this is reliably reproducible as given by my recent comments. We're depending on the reporter, Todd, for any future testing.
Talked with lmandel and he said that there is a meeting scheduled to work on this. I'll keep tracking it for 39 for now.
Anthony, did you get any news from Todd (maybe on another channel)? Thanks.
Flags: needinfo?(anthony.s.hughes)
(In reply to Sylvestre Ledru [:sylvestre] from comment #19)
> Anthony, did you get any news from Todd (maybe on another channel)? Thanks.

I've not heard back from Todd yet but I sent him an email just now. I suspect he'll report back if/when he has something. At this stage, this bug is largely unactionable from a QA standpoint.
Flags: needinfo?(anthony.s.hughes)
(Reporter)

Comment 21

3 years ago
Anthony > I'm having trouble finding the the actual download file with the builds that are listed in comment # 13. Is there a trick to this? Thanks

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #20)
> (In reply to Sylvestre Ledru [:sylvestre] from comment #19)
> > Anthony, did you get any news from Todd (maybe on another channel)? Thanks.
> 
> I've not heard back from Todd yet but I sent him an email just now. I
> suspect he'll report back if/when he has something. At this stage, this bug
> is largely unactionable from a QA standpoint.
Flags: needinfo?(tbrais)
It looks like the builds no longer exist. Ralph, can you rebuild these?
Flags: needinfo?(giles)
(Reporter)

Comment 25

3 years ago
This bug as it was originally written does not occur as of 4/14/2014. The Bio shock video (https://www.youtube.com/watch?v=hicBgE6XndM) is not distorted when setting resolution in 1080p. However the video starts to become a little laggy when scrubbing the video forward. Furthermore if the user loads the following video links in the background (see below; as listed on the Wiki page)
• https://www.youtube.com/watch?v=Jp59FElhOTwhttps://www.youtube.com/watch?v=79ImZE0K7xchttps://www.youtube.com/watch?v=7SRTEXSpcyI
And then selects to view the Bio shock video with a 1080p resolution; the video will become extremely laggy
Ralph, what do you think we should do here? Thanks
Flags: needinfo?(giles)
If we can no longer reproduce the video corruption, I think we should close this. Lag is a different issue and should be a new bug.
Flags: needinfo?(giles)
Marking this RESOLVED WORKSFORME based on comment 25. Todd, please file a new bug for the "lag" issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Anthony and Todd, I'm not clear from the comments what version you were testing on. 

Todd, is this WFM on all channels? Or were you testing Firefox 40? If this isn't an issue anymore I'd like to drop tracking for 38 and 39.
status-firefox39: affected → ---
tracking-firefox39: + → ---
Flags: needinfo?(tbrais)
Flags: needinfo?(anthony.s.hughes)
Ah, I didn't mean to drop the flags until I heard back. Sorry for the extra mail.
status-firefox39: --- → affected
tracking-firefox39: --- → +
I'll let Todd clarify his comment 25 but I believe you can stop tracking this for all branches.
Flags: needinfo?(anthony.s.hughes)
Looking back at this, Anthony it looks like you wanted Todd to file a new bug. Can you do that? I have heard that the folks from betabreakers don't read bugmail. Here I think I'll go with it being fixed and drop the tracking. If you feel the new bug needs tracking, please nominate it.
status-firefox38: affected → fixed
status-firefox39: affected → fixed
tracking-firefox38: + → ---
tracking-firefox39: + → ---
Flags: needinfo?(tbrais)
(In reply to Liz Henry (:lizzard) from comment #32)
> Looking back at this, Anthony it looks like you wanted Todd to file a new
> bug. Can you do that?

I would prefer it if Todd filed the bug since he is the one that reported the issue.
(Reporter)

Comment 34

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #31)
> I'll let Todd clarify his comment 25 but I believe you can stop tracking
> this for all branches.

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #33)
> (In reply to Liz Henry (:lizzard) from comment #32)
> > Looking back at this, Anthony it looks like you wanted Todd to file a new
> > bug. Can you do that?
> 
> I would prefer it if Todd filed the bug since he is the one that reported
> the issue.

This bug has already been reported as issue # https://bugzilla.mozilla.org/show_bug.cgi?id=1144272
AND
https://bugzilla.mozilla.org/show_bug.cgi?id=1144378
You need to log in before you can comment on or make changes to this bug.