Closed Bug 1146168 Opened 7 years ago Closed 7 years ago

Find bar no longer opens with autostart or with / or ' keys

Categories

(SeaMonkey :: Find In Page, defect)

defect
Not set
normal

Tracking

(seamonkey2.33 affected, seamonkey2.34 fixed, seamonkey2.35 fixed, seamonkey2.36 fixed)

RESOLVED FIXED
seamonkey2.36
Tracking Status
seamonkey2.33 --- affected
seamonkey2.34 --- fixed
seamonkey2.35 --- fixed
seamonkey2.36 --- fixed

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Bug 1052992 moved the find bar's event listeners into the system event group. This means that FAYT's key event listeners always trigger first, so you can only start the find bar with Ctrl+F or via the Edit menu. Porting bug 1052992 to FAYT will fix this.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8581321 - Flags: review?(philip.chee)
Comment on attachment 8581321 [details] [diff] [review]
Proposed patch

Do remember to backport to comm-aurora and comm-beta
Attachment #8581321 - Flags: review?(philip.chee) → review+
Pushed comm-central changeset ab136acc0d9c.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.36
Comment on attachment 8581321 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 1052992
User impact if declined: Findbar doesn't start correctly
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8581321 - Flags: approval-comm-beta?
Attachment #8581321 - Flags: approval-comm-aurora?
Attachment #8581321 - Flags: approval-comm-beta?
Attachment #8581321 - Flags: approval-comm-beta+
Attachment #8581321 - Flags: approval-comm-aurora?
Attachment #8581321 - Flags: approval-comm-aurora+
Comment on attachment 8581321 [details] [diff] [review]
Proposed patch

In case we need 2.33.2
[Approval Request Comment]
Regression caused by (bug #): Bug 1052992
User impact if declined: Findbar doesn't start correctly
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #8581321 - Flags: approval-comm-release?
Duplicate of this bug: 1151757
Duplicate of this bug: 1154736
Duplicate of this bug: 1160417
Comment on attachment 8581321 [details] [diff] [review]
Proposed patch

> In case we need 2.33.2
Attachment #8581321 - Flags: approval-comm-release? → approval-comm-release-
You need to log in before you can comment on or make changes to this bug.