Closed Bug 1147456 Opened 5 years ago Closed 5 years ago

"View -> Page Info: Copy any information from list does not modify clipboard

Categories

(SeaMonkey :: Page Info, defect)

SeaMonkey 2.33 Branch
defect
Not set

Tracking

(seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed)

RESOLVED FIXED
seamonkey2.37
Tracking Status
seamonkey2.35 --- fixed
seamonkey2.36 --- fixed
seamonkey2.37 --- fixed

People

(Reporter: seamonkey+bug, Assigned: philip.chee)

References

Details

(Keywords: regression)

User Story

http://hg.mozilla.org/releases/comm-release/rev/296caff83861 SeaMonkey 2.35
http://hg.mozilla.org/releases/comm-beta/rev/74ae5c4b4b21    SeaMonkey 2.36
http://hg.mozilla.org/comm-central/rev/74ae5c4b4b21          SeaMonkey 2.37

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 SeaMonkey/2.35a2
Build ID: 20150323013001

Steps to reproduce:

Clicking "View Page Info -> Links -> Copy Link(s)" on a web site copied the selected link(s) to the clipboard in Seamonkey-2.32.1 and before, but stopped working with Seamonkey-2.33 and Seamonkey-2.33.1 (tested on Linux 64-bit and Windows Server 2008 64-bit).


Actual results:

the clipboard stays empty


Expected results:

the selected link(s) should be copied to the clipboard
REPRODUCIBLE with EN-US Seamonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Default Theme) on German WIN7 64bit:

1. Select a word on this page with double click  ► richtclick ► copy (context menu)
2. Menu 'View ► Page info ► Links (TAB)
3. Rightclick arbitrary hyperlink in list with URL starting with "http"
   ► Copy hyperlink(s)
4. Switch to arbitrary text editor page or to an other open Browser Window 
5. Paste with 'Rightclick  ► Paste' or <control+v>
   Expected: hyperlink pasted
   Actual:  Word from step 1 pasted
OS: Linux → All
Summary: Regression: "View Page Info -> Links -> Copy Link(s)" stopped working with Seamonkey 2.33 → "View Page Info -> Links -> Copy Link(s)" does not copy link URL to clipboard
Also any other copy attempt for any other listed information in other TABs like "Media" will reach clipboard.

I did not find a DUP with <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=DUPs1147456&list_id=12125161>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: "View Page Info -> Links -> Copy Link(s)" does not copy link URL to clipboard → "View -> Page Info: Copy any information from list does not modify clipboard
> Error: ReferenceError: gClipboardHelper is not defined
> Source File: chrome://navigator/content/pageinfo/pageInfo.js
> Line: 1372

pageInfo.js:

> function doCopy(isLinkMode)
> {
>   if (!gClipboardHelper)
>     return;
See Firefox Bug 1095036 - Fix broken copy context menu in Page Info
Assignee: nobody → philip.chee
Blocks: 611388
Status: NEW → ASSIGNED
Hardware: x86_64 → All
See Also: → 1095036
Bug 1147456 - "View -> Page Info: Copy any information from list does not modify clipboard

See Firefox Bug 1095036 - Fix broken copy context menu in Page Info

> -try {
> -  const gClipboardHelper = Components.classes["@mozilla.org/widget/clipboardhelper;1"].getService(Components.interfaces.nsIClipboardHelper);
> -}

The vast majority of nsIClipboardHelper usage doesn't bother to try/catch. If it's going to throw I assume someone would have noticed it by now.

>  function doCopy(isLinkMode)
>  {
> -  if (!gClipboardHelper)
> -    return;
> -
>    var text = getSelectedItems(isLinkMode);
>  
> -  gClipboardHelper.copyString(text.join("\n"), gDocument);
> +  Components.classes["@mozilla.org/widget/clipboardhelper;1"]
> +            .getService(Components.interfaces.nsIClipboardHelper)
> +            .copyString(text.join("\n"), gDocument);

There's only one consumer so we don't need a global.
Attachment #8585684 - Flags: review?(neil)
Comment on attachment 8585684 [details] [diff] [review]
Patch v1.0 proposed fix.

I realised exactly what the regressing bug was just from the patch ;-)
Attachment #8585684 - Flags: review?(neil) → review+
http://hg.mozilla.org/comm-central/rev/74ae5c4b4b21
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.37
Duplicate of this bug: 1156122
Comment on attachment 8585684 [details] [diff] [review]
Patch v1.0 proposed fix.

[Approval Request Comment]
Regression caused by (bug #): Bug 611388
User impact if declined: Unable to copy any information in the Page Info window to the clipbpoard
Testing completed (on m-c, etc.): Baked on SeaMonkey 2.37, SeaMonkey 2.38 
Risk to taking this patch (and alternatives if risky): no risk fix breakages.
String changes made by this patch: None.
Attachment #8585684 - Flags: approval-comm-release?
Attachment #8585684 - Flags: approval-comm-beta?
(In reply to Philip Chee from comment #9)
> Comment on attachment 8585684 [details] [diff] [review]
> Patch v1.0 proposed fix.
> 
> [Approval Request Comment]
> Regression caused by (bug #): Bug 611388
> User impact if declined: Unable to copy any information in the Page Info
> window to the clipbpoard
> Testing completed (on m-c, etc.): Baked on SeaMonkey 2.37, SeaMonkey 2.38 
> Risk to taking this patch (and alternatives if risky): no risk fix breakages.
> String changes made by this patch: None.

Attachment #8585684 [details] [diff] - Flags: approval-comm-release?
Attachment #8585684 [details] [diff] - Flags: approval-comm-beta?
Flags: needinfo?(iann_bugzilla)
Flags: needinfo?(iann_bugzilla)
Attachment #8585684 - Flags: approval-comm-release?
Attachment #8585684 - Flags: approval-comm-release+
Attachment #8585684 - Flags: approval-comm-beta?
Attachment #8585684 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.