Closed Bug 1147823 Opened 5 years ago Closed 5 years ago

Drag & drop xpi file , Install Add-on From File do not work on Nightly39

Categories

(Toolkit :: Add-ons Manager, defect)

39 Branch
defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
mozilla39
Iteration:
39.3 - 30 Mar
Tracking Status
firefox38 --- unaffected
firefox39 + verified

People

(Reporter: alice0775, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Steps To Reproduce:
1. Open Add-on Manager Ctrl+Shft+A
2. Attempt to install an add-on
   Drag & drop a xpi file
   Install "Install Add-on From File" from gear icon at the top of the Add-on Manager

Actual Results:
Install the addon fails


Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=690cfd1cf842&tochange=74cf6d15cfdd

Suspect: Bug 1139656
Flags: needinfo?(dao)
Attached patch patchSplinter Review
Thanks for filing this
Assignee: nobody → dao
Status: NEW → ASSIGNED
Flags: needinfo?(dao)
Attachment #8583780 - Flags: review?(dtownsend)
Iteration: --- → 39.3 - 30 Mar
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Duplicate of this bug: 1147833
Tracking for 39. It would be good to have this land before Monday when we merge 39 to aurora. But if not we should uplift it later.
Duplicate of this bug: 1147645
(In reply to Liz Henry (:lizzard) from comment #3)
> Tracking for 39. It would be good to have this land before Monday when we
> merge 39 to aurora. But if not we should uplift it later.

Good to track but also worth noting that unless we get the additional UX changes for the new install flow we'll probably want to pref it off in 39, see bug 1148016
Comment on attachment 8583780 [details] [diff] [review]
patch

Review of attachment 8583780 [details] [diff] [review]:
-----------------------------------------------------------------

So this means local file installs will have no security delay. That seems ok.
Attachment #8583780 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/mozilla-central/rev/250512664b21
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
QA Contact: vasilica.mihasca
I was able to reproduce this issue on Firefox 39.0a1 (2015-03-26) using Windows 7 64-bit.

Verified fixed on Firefox 40.0a1 (2015-04-05) and Firefox 39.0a2 (2015-04-05) using Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.