Closed Bug 1150089 Opened 5 years ago Closed 5 years ago

a certain animated gif froze on Firefox 37 and later

Categories

(Core :: ImageLib, defect)

37 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox37 --- wontfix
firefox38 + wontfix
firefox39 + fixed
firefox40 + verified
firefox41 --- verified

People

(Reporter: alice0775, Assigned: seth)

References

Details

(Keywords: regression, Whiteboard: gfx-noted [bugday-20150715])

Attachments

(1 file)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

This is similar to Bug 680022 but different regression range.

Steps to reproduce:
1. Open attached animated gif

Actual Results:
Animated gif froze. It does not continue.
And refreshing(F5 or Shift+F5)  stalls the connection and takes down the whole browser.

Expected Results:
It should be animated forever.
nd refreshing(F5) should not stall.


Regression window
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=da5084c9e3e6&tochange=6e4dce410c27

Regressed by: Bug 1116719
Flags: needinfo?(seth)
Whiteboard: gfx-noted
[Tracking Requested - why for this release]: Tracked 38+ as this is a regression issue. It's already been brought to the attention of seth@mozilla.com.
Seth, can you help on this? thanks
Assignee: nobody → seth
I've already been looking at this. This is an OOM issue.

For release management purposes, you should know that fixing it without causing other regressions is seriously nontrivial. It's not clear that such a fix would be upliftable.
Bug 1079627 and bug 1116719 are unrelated to this issue. (There may have been a different issue in the past triggered by those bugs.)

Bug 1116716, which made us limit the amount of memory we allow animated images to allocate, is the cause of the GIF freezing. I'd rather have the GIF freeze than risk allowing large animated GIFs to crash the browser (which was possible before), so I'd say we're in a better position now than we were before. To fix this we need to:

- Make animated images decode in a streaming fashion.

- Allow discarding of animated images.

Both of those are pretty complicated changes.
No longer blocks: 1079627
We shouldn't be tracking this bug.
I am going to wontfix it for 37 & 38. However, we should have a fix for 39 or 40. A freezing browser does not leave a good impression...
(In reply to Sylvestre Ledru [:sylvestre] from comment #7)
> I am going to wontfix it for 37 & 38. However, we should have a fix for 39
> or 40. A freezing browser does not leave a good impression...

Unfortunately, we won't have a fix to allow the GIF to play back fully until well after 40. It's a major project; we have to be able to play back GIFs in a streaming fashion so large ones like this one don't require gigabytes of memory to play back.

I haven't been able to reproduce a crash resulting from these STR, but it sounds like the reporter has.Aalmost certainly the cause is that the animated GIF has already allocated a huge amount of memory, potentially putting us dangerously close to OOM. That memory would be freed after a while, once it expires out of the cache, but it will certainly increase our risk of crashing in the short term.

I'll file a bug about discarding the decoded image data more aggressively once we realize we're in this situation. That would be upliftable, and would be appropriate to track.

I continue to strongly feel that we shouldn't track *this* bug. There's no short term fix we could do that wouldn't put our users at the risk of more frequent OOM crashes, which is exactly why I put a cap on the amount of image memory we could allocate in the first place.
Duplicate of this bug: 1153527
Depends on: 1155332
Seth told me that it is not going to be fixed anytime soon. 
There is no point in tracking it forever, instead, we will track bug 1155332
Other possible duplicates of this bug: bug 1151383 and bug 1155482
Hello, I have the same problem with a page with 8 animated gifs :
http://www.nerisson.fr/#work/alexander-engzell



:(
(In reply to Andy K. [Wawuschel] from comment #12)
> All in Firefox is slow, pages will not load completely.
> The only thing that helps is to restart Firefox.

Yeah, that's due to memory issues. Bug 1155332 will resolve that part.
Depends on: 1161859
Actually this should be completely fixed by bug 1161859. Bug 1157954 revealed a serious issue in the way we were estimating the memory usage of animated images, which is causing Firefox to think it's near OOM when  it really isn't in this testcase.
Flags: needinfo?(seth)
Duplicate of this bug: 1151383
Just realized this one never got resolved. It should already be fixed in 39, 40, and 41. I'm currently trying to get the fix into a point release of 38.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1155482
Duplicate of this bug: 1151572
Duplicate of this bug: 1165331
Duplicate of this bug: 1163357
(In reply to Seth Fowler [:seth] from comment #17)
> Just realized this one never got resolved. It should already be fixed in 39,
> 40, and 41. I'm currently trying to get the fix into a point release of 38.

The tracking flags should be changed for status-firefox39 and status-firefox40 then.
Duplicate of this bug: 1177077
QA Whiteboard: [good first verify]
Reproduced with 40.0a1 (2015-04-01) (Build ID: 20150401030204) on Linux x64 by following comment 0's instruction!

The bug is fixed on Latest Aurora 41.0a2 (2015-07-15) (Build ID: 20150715004006) and

Latest Beta 40.0b3 (Build ID: 20150713153304)

Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
QA Whiteboard: [good first verify] → [good first verify][bugday-20150715]
Whiteboard: gfx-noted → gfx-noted [bugday-20150715]
I have reproduced this bug with Firefox Nightly 40.0a1(Build:20150401030204)on 
windows 8.1 pro x64 with the instructions from comment 0 .

Verified as fixed with Latest Firefox Aurora 41.0a2 (Build ID:20150711004006)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

Verified as fixed with Latest Firefox beta 40.0b3 (Build ID:20150713153304)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
[bugday-20150715]
As per Comment 24 and Comment 25, The bug is fixed now!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.