Last Comment Bug 1150882 - Lightning incorrectly unified after bug 1143163
: Lightning incorrectly unified after bug 1143163
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: Lightning 4.0.0.1
: x86 Mac OS X
-- critical (vote)
: 4.0.0.1
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
: 1150611 (view as bug list)
Depends on:
Blocks: tb-ltng-updateprob
  Show dependency treegraph
 
Reported: 2015-04-03 06:55 PDT by James Rome
Modified: 2015-10-17 09:13 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (2.51 KB, patch)
2015-04-05 02:43 PDT, Philipp Kewisch [:Fallen]
makemyday: review+
Details | Diff | Splinter Review

Description User image James Rome 2015-04-03 06:55:16 PDT
The only version of Lightning I can find that will install in Thunderbird 38 is 4.0b1. But when I start TB, I get:
Mismatched Lightning version
The binary component required for Lightning could not be loaded, likely because the wrong version combination is being used. You currently have Lightning 4.0b1 installed, but should be using a version from the 4.0 series.

Where do I get the right version?
Comment 1 User image Philipp Kewisch [:Fallen] 2015-04-03 09:44:53 PDT
Where did you get this version? 4.0b1 is correct, but I haven't yet tested nor uploaded it to AMO yet.
Comment 2 User image James Rome 2015-04-03 11:06:10 PDT
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/4.0b1-candidates/
the Mac version. But it is broken, and I need it to go along with TB 38. What is AMO?

Also, it would be really great if the Lightning version numbers tracked the TB version numbers. Presently, one must do trial and error to see which version will install with a given TB release.
Comment 3 User image Wayne Mery (:wsmwk, NI for questions) 2015-04-03 12:09:52 PDT
WFM with windows 32bit and http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/4.0b1-candidates/
Comment 4 User image James Rome 2015-04-03 12:13:59 PDT
The US English Mac version from there (the one I installed above, and reinstalled) is the one that gives the error message and does not work.
Comment 5 User image Philipp Kewisch [:Fallen] 2015-04-03 14:57:30 PDT
Unification failed after bug 1143163. I'll fix this manually for b1 and use this bug to fix the builds.
Comment 6 User image Philipp Kewisch [:Fallen] 2015-04-03 15:08:26 PDT
Please check AMO for the new version of 4.0b1
Comment 7 User image James Rome 2015-04-03 16:09:21 PDT
What and where is AMO?
Comment 8 User image Martin Schröder [:mschroeder] 2015-04-03 16:42:56 PDT
AMO = addons.mozilla.org => https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/
Comment 9 User image James Rome 2015-04-03 18:26:13 PDT
This version fixed it. But if you google Lightning nightlies, you get http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/4.0b1-candidates/, so you had better fix it too. I have been using Mozilla for decades now, and have never gone to the AMO site.
Comment 10 User image Philipp Kewisch [:Fallen] 2015-04-05 02:13:51 PDT
Yes, I will fix the packaging in this bug. Note that although the URL contains lightning/nightly, the 4.0b1-candidates directory is for *beta* candidates, hence the "b" in the version. If you want real nightly builds, you will have to get them from latest-comm-aurora or latest-comm-central in http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/
Comment 11 User image Philipp Kewisch [:Fallen] 2015-04-05 02:43:45 PDT
Created attachment 8588416 [details] [diff] [review]
Fix - v1
Comment 12 User image James Rome 2015-04-05 05:49:25 PDT
I looked there Philipp. But they had 4.2a1. The older comm-central ones also had a bad build for 4.0.
Comment 13 User image James Rome 2015-04-05 05:54:54 PDT
And I reiterate my pl;ea for Lightning numbering that corresponds to the Thunderbird version. The AMO page tells the user which version it is for, but the ftp page does not.
Comment 14 User image Stefan Sitter 2015-04-05 06:39:12 PDT
James, as a user of nightly test builds you should bookmark <https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions#Development_Snapshots>.
Comment 15 User image James Rome 2015-04-05 06:55:32 PDT
There are now at least three places to look for the nightlies. That needs unification also!
Comment 16 User image Philipp Kewisch [:Fallen] 2015-04-05 08:33:55 PDT
As you can see on the versions page, there are two different channels of nightly builds, and one beta build. All nightlys can be found on the ftp server, those from the aurora channel in the latest-comm-aurora directory and those from the central channel from latest-comm-central.

Candidate builds (not for public consumption, hence "candidate") for the betas are also found there, but the authoritative source for beta versions is addons.mozilla.org.

Calculating Lightning version numbers from Thunderbird numbers is not all that difficult, and there is also the versions page for lookups. The ftp server is not meant for conveying more information than the builds themselves, it is merely a data store. It also matches the same or similar layout as for Thunderbird and Firefox.
Comment 17 User image Philipp Kewisch [:Fallen] 2015-04-05 08:37:34 PDT
Pushed to comm-central changeset 91a89249303e
Comment 18 User image Philipp Kewisch [:Fallen] 2015-04-05 08:39:21 PDT
Backported to releases/comm-aurora changeset 2b9678fa786d
Comment 19 User image Philipp Kewisch [:Fallen] 2015-04-05 08:41:35 PDT
Backported to releases/comm-beta changeset 258245e8328d
Comment 20 User image James Rome 2015-04-05 16:09:24 PDT
I know I am beating a dead horse, but how does a user know the difference between Aurora and Comm Central?
And I was not referring to the 3 versions on the ftp site, I was referring to 
https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions#Development_Snapshots
and
https://addons.mozilla.org/en-US/thunderbird/addon/lightning/versions/
in addition to the ftp site.
Why not just ONE site?
Comment 21 User image Philipp Kewisch [:Fallen] 2015-04-06 09:55:57 PDT
I guess we could explain the differences on the versions page better. The latest changes go into central. After 6 weeks those changes are merged to aurora, 6 weeks later they go to beta. This mimics the Firefox release process, other than the fact that we don't do full releases every 6 weeks.

The ftp site is the data store for all builds, it is not meant to have a good user interface. Placing files here allows them to be distributed via the CDN given they are placed in the right directory. See the history of FTP for more details.

The addons site is what is commonly used to promote releases and beta builds, has better UI and visibility from within the add-ons manager. We cannot freely determine the layout and content of that page though, there are the same restrictions as for all other addons.

The developer.mozilla.org page just serves as a reference that can be quickly edited, it does not store the builds at all but rather links to them.

As you can see, each of the sites fulfills a unique need, there is no sensible way we could unite all three locations unless Mozilla leads by making changes for Firefox.

What builds you use is a matter of your stability requirements. Using the central builds might mean there will be a few days where the builds are broken if we break something with a patch. Aurora is more stable, reporting bugs on these builds will help us catch regressions early. If you are a power user or a bit more adventurous, this is ideal. Using the beta builds is much closer to release, it's a lot less likely there will be problems with these builds, there are usually not a lot of changes between beta and release builds. Use this if you are interested in reporting bugs early but don't consider yourself a power user.
Comment 22 User image Stefan Sitter 2015-04-10 07:39:47 PDT
*** Bug 1150611 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.