If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some cache-storage tests are unstable on Windows

RESOLVED DUPLICATE of bug 1151974

Status

Testing
web-platform-tests
RESOLVED DUPLICATE of bug 1151974
3 years ago
2 years ago

People

(Reporter: jgraham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

These tests are disabled due to timeouts:

/service-workers/cache-storage/window/cache-put.https.html
/service-workers/cache-storage/window/cache-storage.https.html
/service-workers/cache-storage/worker/cache-put.https.html
/service-workers/cache-storage/worker/cache-storage.https.html
I also ended up disabling cache-add.html and cache-delete.html on Windows and cache-match.html on both Linux 64 and Windows.

The logs when the tests failed often indicated that a file was locked:

TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/worker/cache-delete.https.html | Cache.delete called with a string URL - promise_test: Unhandled rejection with value: object "[Exception... "File error: Is locked" nsresult: "0x80520..."

Updated

3 years ago
Blocks: 1110144
See also bug 1154205

Updated

2 years ago
No longer blocks: 1110144
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151974
You need to log in before you can comment on or make changes to this bug.