Closed Bug 1154511 Opened 5 years ago Closed 5 years ago

Unable to cancel an incoming Hello (FxA) call

Categories

(Hello (Loop) :: Client, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1152197

People

(Reporter: rpapa, Unassigned)

Details

Attachments

(1 file)

Attached image ringing.png
-----------------
STR
-----------------

CALLER
1. Click on loop icon in browser
2. Click on New Contact
3. Add contact
4. Initiate video conversation with new contact
5. Observe call window appear with message "Connecting..." then "Ringing..."

CALLEE
6. Observe incoming call window appear
7. Click on "Cancel"
8. Observe call window disappear

CALLER
9. Observe window remain open indefinitely with "Ringing..." message (see attachement)
10. Press "Cancel" button
11. Cancel button does nothing
12. Call appears hung


-----------------
EXPECTED
-----------------

Callee hitting cancel should terminate "Ringing..." message on Caller's side

-----------------
ACTUAL
-----------------

Callee hitting cancel does not terminate "Ringing..." message on Caller's side
Why is this marked as dependent on/depending on various e10s bugs? What's the link with e10s here?
Flags: needinfo?(rpappalardo)
No longer blocks: e10s, 1099241, 1140313, 1141059
No longer depends on: 1137634, loop-e10s
Flags: needinfo?(rpappalardo)
Priority: P3 → --
Whiteboard: [e10s][Fx40]
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #1)
> Why is this marked as dependent on/depending on various e10s bugs? What's
> the link with e10s here?

sorry gavin. i cloned and forget to remove the deps.
fixed now
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1152197
You need to log in before you can comment on or make changes to this bug.