[l10n][First Time Experience]Bengali India: The "Deselect all" and "Select all" is displayed with truncation on "Facebook Friends" view.

VERIFIED FIXED in 2.2 S11 (1may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: yue.xia, Assigned: mikehenrty)

Tracking

({regression})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, [systemsfe], )

Attachments

(6 attachments)

Reporter

Description

4 years ago
Posted image {{total}.png
[1.Description]:
[110n][v2.2][First Time Experience]Bengali India: On "Import Contacts" screen, tap on "Facebook" and login to an account, select 1 friend, the "Deselect all" and "Select all" strings is displayed with truncation on "Facebook Friends" view.
See attachment: Deselect all Select all.png

[2.Testing Steps]: 
1. After flashing the phone or reset, select "Bengali India" language.
2. Tap "Next" until reaching the "Select a network" screen.
3. Connect to a network and then tap "Next" until reaching the "Import Contacts" screen 
4. Tap on "Facebook" and login to an account with some Friends 
5. Select 1 friend.

[3.Expected Result]: 
5. The "Deselect all" and "Select all" should not be truncated.

[4.Actual Result]: 
5. The "Deselect all" and "Select all"  is displayed with truncation.

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150421002501
Gaia Revision          828dd03a0e3b140d74b2e49355197df4d91d9227
Gaia Date              2015-04-20 18:28:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/36f72a3efb9b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.042925
Firmware Date          Tue Apr 21 04:29:36 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user (Unaffected)
Build ID               20150421001205
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150421.040717
Firmware Date          Tue Apr 21 04:07:27 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12257

[8. Note]:
1. This same problem  in different language need different RD to resolve.
2. In step 5, select some contacts and import them, after imported and go back to "Import Contacts" screen, the "{{total}" string is displayed under "Facebook" item. See attachment: {{total}.png
Reporter

Updated

4 years ago
See Also: → 969716
Reporter

Updated

4 years ago
Summary: [110n][First Time Experience]Bengali India: The "Deselect all" and "Select all" is displayed with truncation on "Facebook Friends" view. → [l10n][First Time Experience]Bengali India: The "Deselect all" and "Select all" is displayed with truncation on "Facebook Friends" view.
Biraj: is this because the string used is longer on 2.2 than 2.1?
If so can you shorten it? If not, we'll have to ask for a dev fix for this
thanks!
Flags: needinfo?(brnet00)
I checked on Transvision https://transvision.mozfr.org/?recherche=Deselect+all&repo=gaia&sourcelocale=en-US&locale=bn-IN&search_type=strings  and the string used is exactly the same on 2.1 and 2.2.
So this is in fact a regression, that most surely affects multiple locales. 
Nominating since this is a shipping locale
blocking-b2g: --- → 2.2?
Component: bn-IN / Bengali (India) → Gaia::First Time Experience
Flags: needinfo?(brnet00)
Keywords: regression
Product: Mozilla Localizations → Firefox OS
Asking for UX help on this! thanks
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 5

4 years ago
Regression gets a +.
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India → LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe]
Assignee: nobody → mhenretty
Reporter

Comment 6

4 years ago
Maybe the original screenshot is misleading, and actually, it is 2.2 English+2.2 bn-in, not 2.1 English+2.2bn-in.
To make it more clear, I have updated the screenshot with some labels on it: "2.2 english", "2.2 bn-in", "2.1 bn-in" on.
See attachment: Deselect all Select all_update.png
Thanks!
According to the STR in comment 0, this issue still exist on latest flame 2.1 user build in Greek language.

See attachment:Greek_Screenshot_Deselect all.png
Reproducing rate:10/10.

Device: Flame 2.2 user build (Affected)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035211
Firmware Date          Thu Apr 23 03:52:22 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user build (Unaffected)
Build ID               20150423001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6a68a038146a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035520
Firmware Date          Thu Apr 23 03:55:31 EDT 2015
Bootloader             L1TC000118D0
(In reply to Lancy from comment #7)
> According to the STR in comment 0, this issue still exist on latest flame
> 2.1 user build in Greek language.

Sorry for the wrong build info, this issue still exist on latest flame 2.2 user build in Greek language.
Reporter

Comment 9

4 years ago
According to the steps in comment 0, this issue still exist on latest build of Flame 2.2(user build) in Polish.
See attachment: Polish_DeselectAllSelectAll.png

Device: Flame user 2.1(Unaffected)
Build ID               20150423001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6a68a038146a
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035520
Firmware Date          Thu Apr 23 03:55:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user(Affected)
Build ID               20150423002502
Gaia Revision          b838d0e7c163e66660dcb6e387d8339944a7a30e
Gaia Date              2015-04-23 02:32:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8dce56574f28
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150423.035211
Firmware Date          Thu Apr 23 03:52:22 EDT 2015
Bootloader             L1TC000118D0
Reporter

Updated

4 years ago
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe] → LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe], MGSEI-l10n-1F-Polish
Reporter

Comment 10

4 years ago
Per comment 7, add the MGSEI-l10n-1F-Greek whiteboard tag.
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe], MGSEI-l10n-1F-Polish → LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe], MGSEI-l10n-1F-Polish, MGSEI-l10n-1F-Greek
Target Milestone: --- → 2.2 S11 (1may)
Let's wait for a fix here until we get the regression window from bug 1157173. The regressing bug will inform the fix here.
Ok, it looks like bug 1010675 caused this. We'll have to adjust our button paddings to match.
Comment on attachment 8598936 [details] [review]
[gaia] mikehenrty:bug-1157159-button-padding > mozilla-b2g:master

Kevin, will you take a look at this gaia_buttons fix? We recently changed how button padding worked in the platform (bug 1010675), so this will probably fix similar regressions in other places using gaia_buttons.
Attachment #8598936 - Flags: review?(kgrandon)
Comment on attachment 8598936 [details] [review]
[gaia] mikehenrty:bug-1157159-button-padding > mozilla-b2g:master

Thank you for tracking that down! Hopefully this won't have much fallout.
Attachment #8598936 - Flags: review?(kgrandon) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
The fix ended up being for the gaia popup dialog, which lives in the system and has more to do with window management than FTU.
Component: Gaia::First Time Experience → Gaia::System::Window Mgmt
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8598936 [details] [review]
[gaia] mikehenrty:bug-1157159-button-padding > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
A fix to button padding in the platform (bug 1010675), exposed the improper button padding in gaia here.
[User impact] if declined:
Certainly languages will show truncated text in buttons.

[Testing completed]:
Tested manually.

[Risk to taking this patch] (and alternatives if risky):
It is a css change that affects the gaia-buttons web component, so the fix will show up multiple places. It is relatively low risk though since it simply reduces button padding. Risk is stylistic only.

[String changes made]: none.
Attachment #8598936 - Flags: approval-gaia-v2.2?
Keywords: verifyme
Duplicate of this bug: 1155906
Attachment #8598936 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
The {{total}} issue needs to be filed separately. You're including two bugs in one.
Flags: needinfo?(yue.xia)
Issue verified fixed on Flame 2.2 and 3.0 

No truncation on Select All or Deselect All buttons in Bengali, Greek, or Polish.

Issue mentioned in notes section of comment 0 has been filed in a new bug 1161207

Device: Flame 2.2
Build ID: 20150504002502
Gaia: 8d14361337e608c8cdf165ea5034db5eda23b618
Gecko: cb7cb6597c91
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
Build ID: 20150504010202
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: dc5f85980a82
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(yue.xia) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Bengali India [systemsfe], MGSEI-l10n-1F-Polish, MGSEI-l10n-1F-Greek → LocRun2.2, [systemsfe],
You need to log in before you can comment on or make changes to this bug.