[Rocketbar][2.2] UI becomes blank after closing the browser on an Auth dialog

VERIFIED DUPLICATE of bug 1157128

Status

VERIFIED DUPLICATE of bug 1157128
4 years ago
3 years ago

People

(Reporter: apastor, Assigned: gandalf)

Tracking

({regression})

unspecified
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master unaffected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This is not hapening in 3.0. Not sure about other branches, but I can repro in 2.2.

STR:

1.- Open the browser
2.- Go to https://pvtbuilds.mozilla.org/pvt/mozilla.org
3.- The auth dialog will appear. Kill the browser (via cards view)
4.- Open the browser again

Expected:

The rocketbar is shown normally (with the Search word inside) and it doesn't disappear when collapsing it.

Actual:

The "Search" string is missing in the input and it dissapears when scrolling.

** Note that the rocketbar won't work at this point since bug 1150834 landing (that is being tracked in bug 1157432). The bug here is the the fact that the rocketbar rendering is different after Auth dialogs.
(Reporter)

Comment 1

4 years ago
Adding qawanted here to check branches and regression-window if needed.

Thanks!
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
We don't even need to kill the browser. Just dismissing the auth dialog by clicking on the X in the corner, clicking home, and opening the browser again, it happens the same.
status-b2g-v2.1: --- → ?
status-b2g-v2.2: --- → ?
status-b2g-master: --- → ?
QA Contact: pcheng
3.0 and 2.1 are unaffected. Rocketbar UI remains intact after the STR.

Device: Flame 3.0
BuildID: 20150423010203
Gaia: 9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gecko: 0b202671c9e2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

-----

2.2 is affected. Rocketbar UI becomes blank after the STR.

Device: Flame 2.2
BuildID: 20150423002502
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 8dce56574f28
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

----

Adding regression window wanted to find what fixed this issue on 3.0, if not then what caused this issue on 2.2.

Also changing the title to distinguish this bug with bug 1157432
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: ? → unaffected
Flags: needinfo?(ktucker)
Keywords: qawanted → regression, regressionwindow-wanted
Summary: [Rocketbar][2.2] broken after closing the browser on an Auth dialog → [Rocketbar][2.2] UI becomes blank after closing the browser on an Auth dialog
status-b2g-v2.1: ? → unaffected
status-b2g-v2.2: ? → affected
blocking-b2g: --- → 2.2+
Central reverse regression window:

Last Broken
Device: Flame
BuildID: 20150328213418
Gaia: 67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gecko: 385840329d91
Version: 39.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Working
Device: Flame
BuildID: 20150329163118
Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gecko: 9c786bf6a7ff
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Broken Gaia & First Working Gecko - issue DOES repro
Gaia: 67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gecko: 9c786bf6a7ff

Last Broken Gecko & First Working Gaia - issue does NOT repro
Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
Gecko: 385840329d91

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/67ad91f3f660b1f16b354ee4c5159ddc5a74d149...be25b16efa19bab8d54be08f8fe45dcc93bf93d0

This issue seems to have been fixed in Central by patches for bug 994357.
Keywords: regressionwindow-wanted
(In reply to Pi Wei Cheng [:piwei] from comment #4)
> Central reverse regression window:
> 
> Last Broken
> Device: Flame
> BuildID: 20150328213418
> Gaia: 67ad91f3f660b1f16b354ee4c5159ddc5a74d149
> Gecko: 385840329d91
> Version: 39.0a1 (3.0 Master) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
> 
> First Working
> Device: Flame
> BuildID: 20150329163118
> Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
> Gecko: 9c786bf6a7ff
> Version: 39.0a1 (3.0 Master)
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
> 
> Last Broken Gaia & First Working Gecko - issue DOES repro
> Gaia: 67ad91f3f660b1f16b354ee4c5159ddc5a74d149
> Gecko: 9c786bf6a7ff
> 
> Last Broken Gecko & First Working Gaia - issue does NOT repro
> Gaia: be25b16efa19bab8d54be08f8fe45dcc93bf93d0
> Gecko: 385840329d91
> 
> Gaia pushlog:
> https://github.com/mozilla-b2g/gaia/compare/
> 67ad91f3f660b1f16b354ee4c5159ddc5a74d149...
> be25b16efa19bab8d54be08f8fe45dcc93bf93d0
> 
> This issue seems to have been fixed in Central by patches for bug 994357.

Passing this on to stas, to see how we can fix this in that case. Please re-assign as needed.
Assignee: nobody → stas
Blocks: 994357
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
We probably can't uplift bug 994357. Lets get a regular regression window and try to do a minimal fix here.
Keywords: qawanted, regressionwindow-wanted
I agree with Gregor; bug 994357 must have accidentally fixed this somehow but is not the proper fix.
I'm working on getting the regular window now.
Assignee: stas → nobody
No longer blocks: 994357
QA Whiteboard: [QAnalyst-Triage+]
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20141017203913
Gaia: f3cf5187520cdae91cb2b20583efc9fc294432bc
Gecko: 0bd52a74a872
Version: 36.0a1 (2.2 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken
Device: Flame
BuildID: 20141018040812
Gaia: 0904bab29236116417871805234c88a035d0873a
Gecko: 735c9533684a
Version: 36.0a1 (2.2 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: f3cf5187520cdae91cb2b20583efc9fc294432bc
Gecko: 735c9533684a

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 0904bab29236116417871805234c88a035d0873a
Gecko: 0bd52a74a872

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f3cf5187520cdae91cb2b20583efc9fc294432bc...0904bab29236116417871805234c88a035d0873a

Caused by Bug 1073893.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted, regressionwindow-wanted
Zibi, looks like the work done on bug 1073893 might be the cause here. Can you take a look at this please?
Blocks: 1073893
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gandalf)
(Assignee)

Comment 11

4 years ago
Woah, I have no idea how bug 1073893 may be related.

Based on the logs I see this: https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/app_authentication_dialog.js#L99-L102 

which in 2.2 results in:

04-22 13:28:35.580   209   209 W GeckoConsole: [JavaScript Error: "L10nError: setTextContent is deprecated (https://bugzil.la/1053629). Setting text content of elements with child elements is no longer supported by l10n.js. Offending data-l10n-id: "username" on element <label data-l10n-id="username">
04-22 13:28:35.580   209   209 W GeckoConsole:         <input class="authentication-dialog-http-username-input" type="text">
04-22 13:28:35.580   209   209 W GeckoConsole:       </label> in app://system.gaiamobile.org/index.html"]

and in master will work because of DOM Overlays. Stas, should we do something when l10n doesn't contain elements that are in the code?

The fix should be easy, I'm taking.
Assignee: nobody → gandalf
Flags: needinfo?(gandalf) → needinfo?(stas)
Created attachment 8598407 [details] [review]
[gaia] zbraniecki:1157631-fix-authentication-l10nids > mozilla-b2g:master
(Assignee)

Comment 13

4 years ago
Comment on attachment 8598407 [details] [review]
[gaia] zbraniecki:1157631-fix-authentication-l10nids > mozilla-b2g:master

This is a minor patch that fixes the bug in 2.2.

It should also land on master.
Attachment #8598407 - Flags: review?(kgrandon)
Zibi, is this a dupe of bug 1157128 then?  I chatted with Dale last night and he said those inputs hadn't used to have labels.  He suggested to fix this in an even simpler way and file a new bug if UX wants the input to have the labels.
Flags: needinfo?(gandalf)
Comment on attachment 8598407 [details] [review]
[gaia] zbraniecki:1157631-fix-authentication-l10nids > mozilla-b2g:master

Looks clean enough for me, thanks!
Attachment #8598407 - Flags: review?(kgrandon) → review+
Hey Zibi

This fix seems fine too, I wasnt particularly sure about using the strings as placeholders or labels, but I dont want to muck around with deleting / adding the strings.

However having the test land with this is super important, we cant be breaking http auth like this, I have a test in mine so im gonna dupe this to mine and match your fix with the test added, hope thats ok, cheers
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157128
need to verify this bug after the patch of bug 1157128 uplift to v2.2.
Flags: needinfo?(hcheng)
(Assignee)

Updated

4 years ago
Flags: needinfo?(gandalf)
has been verified with below test env

*test env
Build ID               20150512002502
Gaia Revision          c4c1bf443f2b01c2ba918780510fd4c639a3c360
Gaia Date              2015-05-11 14:12:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/70782f19acbf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150512.041644
Firmware Date          Tue May 12 04:16:55 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
Flags: needinfo?(hcheng)
(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #11)

> and in master will work because of DOM Overlays. Stas, should we do
> something when l10n doesn't contain elements that are in the code?

I filed bug 1203125 to deal with this case.
Flags: needinfo?(stas)
You need to log in before you can comment on or make changes to this bug.