[Bluetooth]The "Deny" on "Accept Bluetooth file transfer?" dialog view is truncated.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: yue.xia, Assigned: sfoster)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, [systemsfe])

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8599787 [details]
Greek_Deny.png

[1.Description]:
[Flame][v2.2][Bluetooth]Received a file via Bluetooth, tap the "Review transfer request" prompt message, the "Deny" on "Accept Bluetooth file transfer?" dialog view is truncated.
See attachment: Greek_Deny.png

[2.Testing Steps]: 
1. Set language to Greek.
2. Launch Settings app and turn on Bluetooth.
3. Pair with another device
4. Test device received a file from another device.
5. The "Review transfer request" prompt message appears on Notification bar and tap it.

[3.Expected Result]: 
5. The "Deny" on "Accept Bluetooth file transfer?" dialog view should not be truncated.

[4.Actual Result]: 
5. The "Deny" on "Accept Bluetooth file transfer?" dialog view is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user (Unaffected)
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034244
Firmware Date          Wed Apr 29 03:42:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
(Reporter)

Updated

3 years ago
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Greek → LocRun2.2,MGSEI-l10n-1F
Hi Pavel, could you please help to take a look the issue? I guess someone revised CSS style in Building Block. Because the issue is not existed in v2.1. Thanks.
Component: Bluetooth → Gaia::System::System UI
Flags: needinfo?(pivanov)
Should be a regression. Flag on the window-wanted.
Keywords: regressionwindow-wanted
3.0 is also affected. I personally think v2.1 is not behaving optimally either because the text appears too close to edge of the button.

I'll work on getting the window anyway.
status-b2g-master: --- → affected
Keywords: regression
QA Contact: pcheng
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150320063412
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: d3c9b899f7d2
Version: 39.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken
Device: Flame
BuildID: 20150320064919
Gaia: 8837f94418d69a0b06c1f4843b0779e2bb72165a
Gecko: c2724e2f9de9
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d3c9b899f7d2&tochange=c2724e2f9de9

Looks like this is an intentional change in Bug 1010675.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
David, can you take a look at this please? This looks to have been caused by the work done on Bug 1010675.
Blocks: 1010675
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dbaron)
sorry for the delay guys ... I think David can give you the answer
Flags: needinfo?(pivanov)
(Assignee)

Comment 7

3 years ago
We want to fix this in Gaia - so I'll cancel dbaron's needinfo. See similar bug 1158740 for some background.
Assignee: nobody → sfoster
No longer blocks: 1010675
Depends on: 1010675
Flags: needinfo?(dbaron)
Created attachment 8600536 [details] [review]
[gaia] sfoster:confirm-btn-padding-bug-1160096 > mozilla-b2g:master
(Assignee)

Comment 9

3 years ago
Created attachment 8600537 [details]
bluetooth-accept-file-el.png

Screenshot with patch applied - should match v2.1
(Assignee)

Comment 10

3 years ago
Comment on attachment 8600536 [details] [review]
[gaia] sfoster:confirm-btn-padding-bug-1160096 > mozilla-b2g:master

More button padding, this time confirm dialog buttons.
Attachment #8600536 - Flags: review?(kgrandon)
Comment on attachment 8600536 [details] [review]
[gaia] sfoster:confirm-btn-padding-bug-1160096 > mozilla-b2g:master

LGTM.
Attachment #8600536 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

3 years ago
Created attachment 8601246 [details]
Verify_3.0user_Greek.png

This problem is verified pass on latest user build of Flame 3.0 in Greek language by the STR in comment 0.
See attachment: Verify_3.0user_Greek.png
Rate: 0/5

Device: Flame 3.0 user (Pass)
Build ID               20150504160201
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.191951
Firmware Date          Mon May  4 19:20:03 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: affected → verified
(Reporter)

Comment 14

3 years ago
Created attachment 8601273 [details]
Verify_3.0user_screenshot.png

I have verified this problem on latest user build of Flame 3.0 in the language of Spanish, Serbian Cyrillic, Serbian Latin, Russian, Bengali from India, Polish, Basque, Portuguese from Brazil, Portuguese from Portugal, Arabic. The verified results are Pass.
See attachment: Verify_3.0user_screenshot.png
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Comment 15

3 years ago
More button truncation fallout, I think we want this on v2.2?
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2,MGSEI-l10n-1F [systemsfe]
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1163950
Blocking 2.2 on this as this is a regression
blocking-b2g: 2.2? → 2.2+
In case I miss this bug
Flags: needinfo?(hcheng)
(Assignee)

Comment 19

3 years ago
Comment on attachment 8600536 [details] [review]
[gaia] sfoster:confirm-btn-padding-bug-1160096 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Fallout from bug 1010675, fix restores 2.1 behavior for confirm buttons
[User impact] if declined: Confirm button labels are truncated in some languages
[Testing completed]: Tested on device in multiple languages, verified by QA on master
[Risk to taking this patch] (and alternatives if risky): Low risk, constrained CSS-only patch
[String changes made]: None
Attachment #8600536 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Keywords: verifyme

Updated

3 years ago
Attachment #8600536 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+

Comment 20

3 years ago
Please help to verify on 2.2 when patch landed. Thanks
Flags: needinfo?(fan.luo)
NI Shine, and she will help to verify on 2.2 when patch is landed.
Flags: needinfo?(yue.xia)
(Assignee)

Comment 22

3 years ago
v2.2: https://github.com/mozilla-b2g/gaia/commit/b388a235e89dab76c24323767cd87ebd7c4c8b17
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S12 (15may)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1164393
(Reporter)

Comment 24

3 years ago
Created attachment 8606797 [details]
Verify_Pass_All language_Deny.png

This problem is verified pass on latest Flame 2.2 user build in Spanish, Serbian Cyrillic, Serbian Latin, Russian, Bengali India, Greek, Polish, Basque, Portuguese Brazil, Portuguese Portugal and Arabic languages by the STR in comment 0.
See attachment: Verify_Pass_All language_Deny.png
Rate: 0/3

Device: Flame 2.2 user (Pass)
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041351
Firmware Date          Sun May 17 04:14:01 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(yue.xia)
Flags: needinfo?(fan.luo)
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
@Shine, thank you!
Flags: needinfo?(hcheng)
QA Whiteboard: [QAnalyst-Triage+][MGSEI-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F [systemsfe] → LocRun2.2, [systemsfe]
You need to log in before you can comment on or make changes to this bug.